- update to pupnp-1.4.0
(Note: upnp-1.3.1 stopped developing, and pupnp-1.4.0 is its successor) - drop maintainership Noticed by: Chris Hilbert <chris.hilbert at fileflash.com>
This commit is contained in:
parent
c342742381
commit
3695038b44
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=165614
@ -6,36 +6,34 @@
|
||||
#
|
||||
|
||||
PORTNAME= upnp
|
||||
PORTVERSION= 1.2.1
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.4.0
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
MASTER_SITE_SUBDIR= pupnp
|
||||
DISTNAME= lib${PORTNAME}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= leeym@FreeBSD.org
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Universal Plug and Play Software Development Kit
|
||||
|
||||
CONFLICTS= upnp-1.[^2].*
|
||||
CONFLICTS= upnp-1.0.*
|
||||
|
||||
USE_GMAKE= yes
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/upnp
|
||||
PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
|
||||
MAKEFILE= makefile
|
||||
GNU_CONFIGURE= yes
|
||||
USE_DOS2UNIX= yes
|
||||
MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
|
||||
NOT_FOR_ARCHS= sparc64
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.if defined(NOPORTDOCS)
|
||||
CONFIGURE_ARGS= --without-docdir
|
||||
.else
|
||||
CONFIGURE_ARGS= --with-docdir=${DOCSDIR}
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${PATCH_WRKSRC} -name "*.[ch]" | \
|
||||
${FIND} ${WRKSRC} -type f | \
|
||||
${XARGS} ${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,'
|
||||
@${FIND} ${PATCH_WRKSRC} -name "[Mm]akefile" | ${XARGS} ${REINPLACE_CMD} \
|
||||
-e 's,lpthread,pthread, ; s,/usr,,g ; s,1\.2\.1,1,g' \
|
||||
-e 's,MAKE = make,MAKE = ${GMAKE},' \
|
||||
-e 's,install bin,${INSTALL_PROGRAM} bin,g' \
|
||||
-e 's,install inc,${INSTALL_DATA} inc,g'
|
||||
@${REINPLACE_CMD} -e 's,MSG_NOSIGNAL,0,' ${PATCH_WRKSRC}/upnp/src/genlib/net/sock.c
|
||||
@${REINPLACE_CMD} -e 's,linux/if,net/if,' ${PATCH_WRKSRC}/upnp/src/api/upnpapi.c
|
||||
${REINPLACE_CMD} -Ee 's,^(pkgconfigexecdir = ).*,\1${PREFIX}/libdata/pkgconfig,' \
|
||||
${WRKSRC}/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (libupnp-1.2.1.tar.gz) = 14b453406c0f768f875de50bdbf5c802
|
||||
SHA256 (libupnp-1.2.1.tar.gz) = e8ddb60fd9e123a2e844c10bde73f7e43788587131497fa79dc43cc501e18ff4
|
||||
SIZE (libupnp-1.2.1.tar.gz) = 412314
|
||||
MD5 (libupnp-1.4.0.tar.gz) = 581c8017dc1b36d29ba034ce1e178c83
|
||||
SHA256 (libupnp-1.4.0.tar.gz) = 816c22d7163f2b74e7dab52b1adf81f5248d760da94fa79672337333a048e906
|
||||
SIZE (libupnp-1.4.0.tar.gz) = 763352
|
||||
|
11
devel/upnp/files/patch-threadutil-src-ThreadPool.c
Normal file
11
devel/upnp/files/patch-threadutil-src-ThreadPool.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- threadutil/src/ThreadPool.c.orig Mon May 22 15:22:46 2006
|
||||
+++ threadutil/src/ThreadPool.c Mon Jun 12 19:25:28 2006
|
||||
@@ -341,7 +341,7 @@
|
||||
struct timeb t;
|
||||
|
||||
ftime( &t );
|
||||
- srand( ( unsigned int )t.millitm + ithread_get_current_thread_id( ) );
|
||||
+ srand( ( unsigned int )t.millitm + ( unsigned int )ithread_get_current_thread_id( ) );
|
||||
}
|
||||
|
||||
/****************************************************************************
|
@ -1,20 +0,0 @@
|
||||
--- threadutil/src/ThreadPool.c.orig Sat Apr 5 23:20:04 2003
|
||||
+++ threadutil/src/ThreadPool.c Sat Apr 5 23:20:47 2003
|
||||
@@ -341,7 +341,7 @@
|
||||
struct timeb t;
|
||||
|
||||
ftime( &t );
|
||||
- srand( ( unsigned int )t.millitm + ithread_get_current_thread_id( ) );
|
||||
+ srand( ( unsigned int )t.millitm + ( unsigned int )ithread_get_current_thread_id( ) );
|
||||
}
|
||||
|
||||
/****************************************************************************
|
||||
@@ -1455,7 +1455,7 @@
|
||||
assert( stats != NULL ); if( stats == NULL ) {
|
||||
return;}
|
||||
|
||||
- printf( "ThreadPoolStats at Time: %ld\n", time( NULL ) );
|
||||
+ printf( "ThreadPoolStats at Time: %lf\n", time( NULL ) );
|
||||
printf
|
||||
( "Average Wait in High Priority Q in milliseconds: %lf\n",
|
||||
stats->avgWaitHQ );
|
18
devel/upnp/files/patch-upnp-inc-upnp.h
Normal file
18
devel/upnp/files/patch-upnp-inc-upnp.h
Normal file
@ -0,0 +1,18 @@
|
||||
--- upnp/inc/upnp.h.orig Sat Jun 17 11:57:02 2006
|
||||
+++ upnp/inc/upnp.h Sat Jun 17 12:01:43 2006
|
||||
@@ -37,6 +37,7 @@
|
||||
//@{
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <time.h>
|
||||
#include "ixml.h"
|
||||
#include "upnpconfig.h"
|
||||
#if UPNP_HAVE_DEBUG
|
||||
@@ -48,6 +49,7 @@
|
||||
#define UPNP_INVALID_SOCKET -1
|
||||
#define SOCKET int
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include <netinet/in.h>
|
||||
|
||||
#define LINE_SIZE 180
|
10
devel/upnp/files/patch-upnp-src-urlconfig-urlconfig.c
Normal file
10
devel/upnp/files/patch-upnp-src-urlconfig-urlconfig.c
Normal file
@ -0,0 +1,10 @@
|
||||
--- upnp/src/urlconfig/urlconfig.c.orig Sat Jun 17 12:18:32 2006
|
||||
+++ upnp/src/urlconfig/urlconfig.c Sat Jun 17 12:21:52 2006
|
||||
@@ -31,6 +31,7 @@
|
||||
|
||||
#include "config.h"
|
||||
#include <assert.h>
|
||||
+#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <netinet/in.h>
|
||||
#include <arpa/inet.h>
|
@ -1,6 +1,6 @@
|
||||
--- upnp/src/uuid/uuid.c.orig Sun Apr 6 02:30:20 2003
|
||||
+++ upnp/src/uuid/uuid.c Sun Apr 6 02:30:41 2003
|
||||
@@ -21,6 +21,7 @@
|
||||
--- upnp/src/uuid/uuid.c.orig Sat Jun 17 12:16:38 2006
|
||||
+++ upnp/src/uuid/uuid.c Sat Jun 17 12:16:52 2006
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <time.h>
|
@ -1,11 +0,0 @@
|
||||
--- upnp/src/inc/sysdep.h.orig Wed Jan 15 07:57:19 2003
|
||||
+++ upnp/src/inc/sysdep.h Sat Apr 5 23:20:48 2003
|
||||
@@ -19,7 +19,7 @@
|
||||
|
||||
#include <sys/types.h>
|
||||
#include <sys/time.h>
|
||||
-#include <sys/sysinfo.h>
|
||||
+//#include <sys/sysinfo.h>
|
||||
#include "ithread.h"
|
||||
|
||||
/* change to point to where MD5 .h's live */
|
@ -1,10 +0,0 @@
|
||||
--- upnp/src/urlconfig/urlconfig.c.orig Sun Apr 6 02:29:45 2003
|
||||
+++ upnp/src/urlconfig/urlconfig.c Sun Apr 6 02:30:02 2003
|
||||
@@ -30,6 +30,7 @@
|
||||
///////////////////////////////////////////////////////////////////////////
|
||||
|
||||
#include <assert.h>
|
||||
+#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <netinet/in.h>
|
||||
#include <arpa/inet.h>
|
@ -1,11 +0,0 @@
|
||||
--- upnp/src/uuid/sysdep.c.orig Thu Jan 16 05:39:44 2003
|
||||
+++ upnp/src/uuid/sysdep.c Sat Apr 5 23:20:48 2003
|
||||
@@ -144,7 +144,7 @@
|
||||
{
|
||||
MD5_CTX c;
|
||||
typedef struct {
|
||||
- struct sysinfo s;
|
||||
+ //struct sysinfo s;
|
||||
struct timeval t;
|
||||
char hostname[257];
|
||||
} randomness;
|
@ -1,18 +1,7 @@
|
||||
The Universal Plug and Play (UPnP) Software Development Kit (SDK) v1.0 for
|
||||
Linux is an SDK for development of UPnP device and control point applications
|
||||
for Linux. It consists of the core UPnP protocols along with a UPnP-specific
|
||||
eXtensible Markup Language (XML) parser supporting the Document Object Model
|
||||
(DOM) Level 1 API and an optional, integrated mini web server for serving UPnP
|
||||
related documents.
|
||||
The portable SDK for UPnP* Devices (libupnp) provides developers with an API
|
||||
and open source code for building control points, devices, and bridges that
|
||||
are compliant with Version 1.0 of the Universal Plug and Play Device
|
||||
Architecture Specification and support several operating systems like Linux,
|
||||
*BSD, Solaris and others.
|
||||
|
||||
Intel is not providing support for the UPnP SDK for Linux. Two mailing lists
|
||||
for the UPnP SDK for Linux are available here:
|
||||
WWW: http://upnp.sourceforge.net/
|
||||
|
||||
Questions and problems should be addressed on the appropriate mailing list.
|
||||
|
||||
If you find this SDK useful, please send an email to upnp@intel.com and let
|
||||
us know.
|
||||
|
||||
* Other brands, names, and trademarks are the property of their respective
|
||||
owners.
|
||||
WWW: http://www.virtualworlds.de/upnp/
|
||||
|
@ -1,6 +1,40 @@
|
||||
include/upnp/config.h
|
||||
include/upnp/FreeList.h
|
||||
include/upnp/LinkedList.h
|
||||
include/upnp/ThreadPool.h
|
||||
include/upnp/TimerThread.h
|
||||
include/upnp/iasnprintf.h
|
||||
include/upnp/ithread.h
|
||||
include/upnp/ixml.h
|
||||
include/upnp/upnp.h
|
||||
include/upnp/upnpconfig.h
|
||||
include/upnp/upnptools.h
|
||||
lib/libixml.a
|
||||
lib/libixml.la
|
||||
lib/libixml.so
|
||||
lib/libixml.so.2
|
||||
lib/libthreadutil.a
|
||||
lib/libthreadutil.la
|
||||
lib/libthreadutil.so
|
||||
lib/libthreadutil.so.2
|
||||
lib/libupnp.a
|
||||
lib/libupnp.la
|
||||
lib/libupnp.so
|
||||
lib/libupnp.so.1
|
||||
lib/libupnp.so.2
|
||||
libdata/pkgconfig/libupnp.pc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
|
||||
%%PORTDOCS%%%%DOCSDIR%%/NEWS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/THANKS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TODO
|
||||
%%PORTDOCS%%%%DOCSDIR%%/UPnP_Programming_Guide.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/sample_util.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/sample_util.h
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/upnp_tv_ctrlpt.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/upnp_tv_ctrlpt.h
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/upnp_tv_ctrlpt_main.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/upnp_tv_device.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/upnp_tv_device.h
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/upnp_tv_device_main.c
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%/examples
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm include/upnp
|
||||
|
Loading…
Reference in New Issue
Block a user