Make x11 optional

PR:		ports/139888
Submitted by:   Marcin Wisnicki <mwisnicki+freebsd@gmail.com>
This commit is contained in:
Michael Johnson 2009-12-14 01:19:55 +00:00
parent 5aeff6dc9a
commit 367d73ee0e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=245738
3 changed files with 41 additions and 4 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= cupsddk
PORTVERSION= 1.2.3
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= print devel
MASTER_SITES= EASYSW
MASTER_SITE_SUBDIR= ${PORTNAME}/${DISTVERSION}
@ -16,21 +16,30 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}-source
MAINTAINER= ahze@FreeBSD.org
COMMENT= CUPS Driver Development Kit
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
cupsimage.2:${PORTSDIR}/print/cups-image
LIB_DEPENDS= cupsimage.2:${PORTSDIR}/print/cups-image
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf:262
USE_GMAKE= yes
OPTIONS= X11 "built with FLTK gui" on
MAN1= commandtoescpx.1 commandtopclx.1 cupsprofile.1 ppdc.1 ppdhtml.1 \
ppdi.1 ppdmerge.1 ppdpo.1 rastertoescpx.1 rastertopclx.1
MAN5= ppdcfile.5
.include <bsd.port.pre.mk>
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
.if defined(WITH_X11)
LIB_DEPENDS+= fltk.1:${PORTSDIR}/x11-toolkits/fltk
CONFIGURE_ARGS+= --with-fltk
.endif
post-patch:
@${REINPLACE_CMD} -e 's|/cupsprofile.ppm|${DATADIR:S,${PREFIX}/share,,}/cupsprofile.ppm|' \
${WRKSRC}/cups/cupsprofile.c
@ -40,4 +49,4 @@ post-patch:
post-install:
@${INSTALL_DATA} ${WRKSRC}/cups/cupsprofile.ppm ${DATADIR}
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -0,0 +1,27 @@
diff -urN configure.in configure.in
--- configure.in 2007-10-05 22:42:17.000000000 +0200
+++ configure.in 2007-10-14 20:19:40.000000000 +0200
@@ -155,14 +155,16 @@
AC_CHECK_HEADER(cups/cups.h,,AC_MSG_ERROR(CUPS headers are not installed!))
dnl Check for FLTK...
-AC_PATH_PROG(FLTKCONFIG,fltk-config)
+AC_ARG_WITH([fltk], AS_HELP_STRING([--with-fltk], [Build with fltk library GUI (default: disabled)]))
-if test "x$FLTKCONFIG" = x; then
-# AC_MSG_ERROR([Sorry, the CUPS DDK requires FLTK 1.1.x.])
- GUILIBS=""
-else
- CXXFLAGS="`$FLTKCONFIG --cflags` $CXXFLAGS"
- GUILIBS="`$FLTKCONFIG --use-images --ldstaticflags`"
+if test "x$with_fltk" == "xyes"; then
+ AC_PATH_PROG(FLTKCONFIG,fltk-config)
+ if test "x$FLTKCONFIG" = x; then
+ AC_MSG_ERROR([Sorry, the CUPS DDK GUI requires FLTK 1.1.x.])
+ else
+ CXXFLAGS="`$FLTKCONFIG --cflags` $CXXFLAGS"
+ GUILIBS="`$FLTKCONFIG --use-images --ldstaticflags`"
+ fi
fi
AC_SUBST(FLTKCONFIG)

View File

@ -57,6 +57,7 @@ share/doc/cups/help/ref-ppdcfile.html
@dirrmtry share/cups/drv
@dirrmtry share/cups
@dirrmtry share/doc/cups/help
@dirrmtry share/doc/cups/examples
@dirrmtry share/doc/cups
@dirrmtry libexec/cups/driver
@dirrmtry libexec/cups