MFH: r554148
math/cantor: Support ptyhon3.9 - instead of adding 'python3.9' to the list, simply patch in python-${PYTHON_VER} -- this way, this should fix two issues 1) make it work with python 2) help cmake find the "wanted" python version in unclean environments PR: 250884 Reported by: Oleg Sidorkin <osidorkin@gmail.com>, fluffy (previously) Approved by: ports-secteam (implicit)
This commit is contained in:
parent
8b0550574d
commit
36571e80b6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q4/; revision=554167
@ -58,8 +58,7 @@ CMAKE_ON= CMAKE_DISABLE_FIND_PACKAGE_PythonLibs
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e '/FIND_PROGRAM(_GFORTRAN_EXECUTABLE/s,gfortran,${FC},' \
|
||||
${WRKSRC}/cmake/FindR.cmake
|
||||
${REINPLACE_CMD} -e '/find_library(PYTHONLIBS3_LIBRARY/s,python3.5m,python3.5m python3.6m,' \
|
||||
-e '/pkg_check_modules/s,python3,python-${PYTHON_VER},' \
|
||||
${REINPLACE_CMD} -e 's|%%PYTHON_VER%%|${PYTHON_VER}|g' \
|
||||
${WRKSRC}/cmake/FindPythonLibs3.cmake
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
18
math/cantor/files/patch-cmake_FindPythonLibs3.cmake
Normal file
18
math/cantor/files/patch-cmake_FindPythonLibs3.cmake
Normal file
@ -0,0 +1,18 @@
|
||||
--- cmake/FindPythonLibs3.cmake.orig 2020-10-31 16:59:49 UTC
|
||||
+++ cmake/FindPythonLibs3.cmake
|
||||
@@ -1,5 +1,5 @@
|
||||
find_package(PkgConfig)
|
||||
-pkg_check_modules(PYTHONLIBS3 QUIET python3)
|
||||
+pkg_check_modules(PYTHONLIBS3 QUIET python-%%PYTHON_VER%%)
|
||||
set(PYTHONLIBS3_DEFINITIONS ${PYTHONLIBS3_CFLAGS_OTHER})
|
||||
|
||||
find_path(PYTHONLIBS3_INCLUDE_DIR Python.h
|
||||
@@ -9,7 +9,7 @@ IF(WIN32)
|
||||
find_library(PYTHONLIBS3_LIBRARY NAMES python32 python33 python34 python35 python36 python37 python38
|
||||
HINTS ${PYTHONLIBS3_LIBDIR} ${PYTHONLIBS3_LIBRARY_DIRS} )
|
||||
ELSE()
|
||||
- find_library(PYTHONLIBS3_LIBRARY NAMES python3.2m python3.3m python3.4m python3.5m python3.6m python3.7m python3.8
|
||||
+ find_library(PYTHONLIBS3_LIBRARY NAMES python%%PYTHON_VER%% python3.7 python3.2m python3.3m python3.4m python3.5m python3.6m python3.7m python3.8
|
||||
HINTS ${PYTHONLIBS3_LIBDIR} ${PYTHONLIBS3_LIBRARY_DIRS} )
|
||||
ENDIF()
|
||||
|
Loading…
Reference in New Issue
Block a user