New port: misc/opennn: Open neural networks library

This commit is contained in:
Yuri Victorovich 2019-11-29 01:58:05 +00:00
parent 496206e9cc
commit 3628e02108
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=518618
7 changed files with 138 additions and 0 deletions

View File

@ -270,6 +270,7 @@
SUBDIR += openhantek
SUBDIR += openhmd
SUBDIR += openmvg
SUBDIR += opennn
SUBDIR += openr2
SUBDIR += openvdb
SUBDIR += orange3

38
misc/opennn/Makefile Normal file
View File

@ -0,0 +1,38 @@
# $FreeBSD$
PORTNAME= opennn
DISTVERSION= 0.1-86
DISTVERSIONSUFFIX= -g449b346
CATEGORIES= misc # machine-learning
MAINTAINER= yuri@FreeBSD.org
COMMENT= Open neural networks library
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
USES= cmake compiler:c++11-lang dos2unix
DOS2UNIX_FILES= CMakeLists.txt
USE_GITHUB= yes
GH_ACCOUNT= Artelnics
GH_PROJECT= OpenNN
USE_LDCONFIG= yes
CMAKE_OFF= OpenNN_BUILD_EXAMPLES OpenNN_BUILD_TESTS
OPTIONS_DEFINE= MPI OPENMP
OPTIONS_DEFAULT= OPENMP
MPI_CMAKE_BOOL= __OPENNN_MPI__
MPI_BROKEN= https://github.com/Artelnics/OpenNN/issues/86
OPENMP_CMAKE_BOOL= __OPENNN_OMP__
OPENMP_LIB_DEPENDS= libomp.so:devel/openmp
OPENMP_USES= localbase:ldflags
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/include/${PORTNAME} && ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/*.h ${STAGEDIR}${PREFIX}/include/${PORTNAME}
${INSTALL_DATA} ${BUILD_WRKSRC}/${PORTNAME}/libopennn.so ${STAGEDIR}${PREFIX}/lib
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libopennn.so
.include <bsd.port.mk>

3
misc/opennn/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1574568515
SHA256 (Artelnics-OpenNN-0.1-86-g449b346_GH0.tar.gz) = 1277637d5593bbe652ef0499d762aa54c1085e4dac2fc4b01ba7e304878f2352
SIZE (Artelnics-OpenNN-0.1-86-g449b346_GH0.tar.gz) = 3572152

View File

@ -0,0 +1,13 @@
--- CMakeLists.txt.orig 2019-11-29 00:56:51 UTC
+++ CMakeLists.txt
@@ -8,8 +8,8 @@ if(__OPENNN_MPI__)
find_package(MPI)
if(MPI_FOUND)
message("Using MPI")
- set(CMAKE_CXX_COMPILER mpicxx)
- set(CMAKE_C_COMPILER mpicc)
+ set(CMAKE_CXX_COMPILER ${CMAKE_INSTALL_PREFIX}/bin/mpicxx)
+ set(CMAKE_C_COMPILER ${CMAKE_INSTALL_PREFIX}/bin/mpicc)
set(CMAKE_CXX_COMPILE_FLAGS "${CMAKE_CXX_COMPILE_FLAGS} ${MPI_COMPILE_FLAGS}")
set(CMAKE_CXX_LINK_FLAGS "${CMAKE_CXX_LINK_FLAGS} ${MPI_LINK_FLAGS}")
add_definitions(-D__OPENNN_MPI__ )

View File

@ -0,0 +1,11 @@
--- opennn/CMakeLists.txt.orig 2019-11-29 00:38:47 UTC
+++ opennn/CMakeLists.txt
@@ -6,7 +6,7 @@ cmake_minimum_required(VERSION 2.8.10)
project(opennn)
-add_library(opennn
+add_library(opennn SHARED
adaptive_moment_estimation.cpp
association_rules.cpp
bounding_layer.cpp

15
misc/opennn/pkg-descr Normal file
View File

@ -0,0 +1,15 @@
OpenNN is a software library written in C++ for advanced analytics. It
implements neural networks, the most successful machine learning method.
The main advantage of OpenNN is its high performance. This library outstands in
terms of execution speed and memory allocation. It is constantly optimized and
parallelized in order to maximize its efficiency.
Some typical applications of OpenNN are business intelligence (customer
segmentation, churn prevention...), health care (early diagnosis, microarray
analysis...) and engineering (performance optimization, predictive
maitenance...).
OpenNN does not deal with computer vision or natural language processing.
WWW: https://www.opennn.net/

57
misc/opennn/pkg-plist Normal file
View File

@ -0,0 +1,57 @@
include/opennn/adaptive_moment_estimation.h
include/opennn/association_rules.h
include/opennn/bounding_layer.h
include/opennn/conjugate_gradient.h
include/opennn/correlation_analysis.h
include/opennn/cross_entropy_error.h
include/opennn/data_set.h
include/opennn/file_utilities.h
include/opennn/genetic_algorithm.h
include/opennn/golden_section_order.h
include/opennn/gradient_descent.h
include/opennn/growing_inputs.h
include/opennn/incremental_order.h
include/opennn/inputs.h
include/opennn/inputs_selection_algorithm.h
include/opennn/inputs_trending_layer.h
include/opennn/instances.h
include/opennn/k_nearest_neighbors.h
include/opennn/learning_rate_algorithm.h
include/opennn/levenberg_marquardt_algorithm.h
include/opennn/loss_index.h
include/opennn/matrix.h
include/opennn/mean_squared_error.h
include/opennn/minkowski_error.h
include/opennn/missing_values.h
include/opennn/model_selection.h
include/opennn/multilayer_perceptron.h
include/opennn/neural_network.h
include/opennn/normalized_squared_error.h
include/opennn/numerical_differentiation.h
include/opennn/numerical_integration.h
include/opennn/opennn.h
include/opennn/optimization_algorithm.h
include/opennn/order_selection_algorithm.h
include/opennn/outputs.h
include/opennn/outputs_trending_layer.h
include/opennn/perceptron_layer.h
include/opennn/principal_components_layer.h
include/opennn/probabilistic_layer.h
include/opennn/pruning_inputs.h
include/opennn/quasi_newton_method.h
include/opennn/scaled_conjugate_gradient.h
include/opennn/scaling_layer.h
include/opennn/selective_pruning.h
include/opennn/simulated_annealing_order.h
include/opennn/sparse_matrix.h
include/opennn/stochastic_gradient_descent.h
include/opennn/sum_squared_error.h
include/opennn/testing_analysis.h
include/opennn/text_analytics.h
include/opennn/tinyxml2.h
include/opennn/training_strategy.h
include/opennn/unscaling_layer.h
include/opennn/variables.h
include/opennn/vector.h
include/opennn/weighted_squared_error.h
lib/libopennn.so