Fix multiple build problems

- Remove bundled jsoncpp, it may conflict with system one
- Fix plist (nls files are installed when both CLIENT and NLS are enabled)
- Add patch to fix include order which causes build failure in presence of ${LOCALBASE}/include/event.h

PR:		248540
Reported by:	doctorwhoguy@gmail.com, wolfi@karpador.xyz
This commit is contained in:
Dmitry Marakasov 2020-12-03 16:18:23 +00:00
parent 412a013eae
commit 35c66ad2f3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=556909
3 changed files with 70 additions and 71 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= minetest
PORTVERSION= 5.3.0
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= games
MAINTAINER= amdmi3@FreeBSD.org
@ -13,14 +13,16 @@ LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/doc/lgpl-2.1.txt
LIB_DEPENDS= libsqlite3.so:databases/sqlite3 \
libgmp.so:math/gmp
libgmp.so:math/gmp \
libjsoncpp.so:devel/jsoncpp
USE_GITHUB= yes
GH_ACCOUNT= minetest
USES= cmake compiler:c11 iconv:wchar_t
CMAKE_ARGS= -DCUSTOM_MANDIR="${PREFIX}/man" \
-DCUSTOM_EXAMPLE_CONF_DIR="${PREFIX}/etc"
-DCUSTOM_EXAMPLE_CONF_DIR="${PREFIX}/etc" \
-DENABLE_SYSTEM_JSONCPP=ON
LDFLAGS_i386= -Wl,-znotext
@ -111,9 +113,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-irrlichtdepend
post-extract:
# make sure no bundled gmp is used
@${RM} -rf ${WRKSRC}/lib/gmp
# bundled jsoncpp is OK, see comment in cmake/Modules/FindJson.cmake
# (not sure if it affects FreeBSD, but too lazy to investigate)
@${RM} -rf ${WRKSRC}/lib/gmp ${WRKSRC}/lib/jsoncpp
# bundled lua is OK, there's no option to use system one
post-patch:

View File

@ -1,26 +1,25 @@
--- src/CMakeLists.txt.orig 2020-01-11 18:29:02 UTC
--- src/CMakeLists.txt.orig 2020-07-09 20:04:20 UTC
+++ src/CMakeLists.txt
@@ -485,6 +485,7 @@ if (CMAKE_VERSION VERSION_GREATER 3.8.1)
@@ -517,9 +517,13 @@ if (CMAKE_VERSION VERSION_GREATER 3.8.1)
source_group(TREE ${PROJECT_SOURCE_DIR} PREFIX "Source Files" FILES ${server_SRCS})
endif()
include_directories(
+ ${JSON_INCLUDE_DIR}
-include_directories(
+include_directories(BEFORE
${PROJECT_BINARY_DIR}
${PROJECT_SOURCE_DIR}
+ ${PROJECT_SOURCE_DIR}/script
+)
+
+include_directories(
${IRRLICHT_INCLUDE_DIR}
@@ -495,7 +496,6 @@ include_directories(
${SQLITE3_INCLUDE_DIR}
${LUA_INCLUDE_DIR}
${ZLIB_INCLUDE_DIR}
${PNG_INCLUDE_DIR}
@@ -529,7 +533,6 @@ include_directories(
${GMP_INCLUDE_DIR}
- ${JSON_INCLUDE_DIR}
${JSON_INCLUDE_DIR}
${X11_INCLUDE_DIR}
${PROJECT_SOURCE_DIR}/script
- ${PROJECT_SOURCE_DIR}/script
)
@@ -715,7 +715,6 @@ else()
set(CMAKE_CXX_FLAGS_RELEASE "-DNDEBUG ${RELEASE_WARNING_FLAGS} ${WARNING_FLAGS} ${OTHER_FLAGS} -Wall -pipe -funroll-loops")
if(CMAKE_SYSTEM_NAME MATCHES "(Darwin|BSD|DragonFly)")
- set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -Os")
else()
set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -O3 -ffast-math -fomit-frame-pointer")
endif(CMAKE_SYSTEM_NAME MATCHES "(Darwin|BSD|DragonFly)")
if(USE_GETTEXT)

View File

@ -6,53 +6,53 @@ man/man6/minetestserver.6.gz
share/applications/net.minetest.minetest.desktop
share/icons/hicolor/128x128/apps/minetest.png
share/icons/hicolor/scalable/apps/minetest.svg
%%NLS%%share/locale/ar/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/ca/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/cs/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/da/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/de/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/dv/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/el/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/eo/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/es/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/et/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/eu/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/fil/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/fr/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/gd/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/gl/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/hi/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/hu/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/id/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/it/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/ja/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/ja_KS/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/jbo/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/kk/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/kn/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/lo/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/lt/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/lv/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/ms/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/ms_Arab/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/my/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/nb/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/nl/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/nn/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/pl/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/pt/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/ro/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/ru/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/sk/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/sl/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/sr_Cyrl/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/sv/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/sw/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/th/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/tr/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/uk/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/vi/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/minetest.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/ar/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/ca/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/cs/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/da/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/de/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/dv/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/el/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/eo/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/es/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/et/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/eu/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/fil/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/fr/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/gd/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/gl/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/hi/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/hu/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/id/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/it/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/ja/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/ja_KS/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/jbo/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/kk/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/kn/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/lo/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/lt/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/lv/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/ms/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/ms_Arab/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/my/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/nb/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/nl/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/nn/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/pl/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/pt/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/pt_BR/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/ro/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/ru/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/sk/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/sl/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/sr_Cyrl/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/sv/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/sw/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/th/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/tr/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/uk/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/vi/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/zh_CN/LC_MESSAGES/minetest.mo
%%CLIENT%%%%NLS%%share/locale/zh_TW/LC_MESSAGES/minetest.mo
share/metainfo/net.minetest.minetest.appdata.xml