sysutils/ganglia-monitor-core: Upgrade to 3.7.2, disable python modules

Ganglia python modules require python 2.x, which is being removed from
the ports tree.  Ganglia is no longer being developed upstream and upgrading
to python 3 appears to be fairly involved.  Hence, I'm disabling python
modules in order to keep the port alive through the python 2 removal.

PR:             249772
Reported by:    swills
This commit is contained in:
Jason W. Bacon 2020-10-01 18:00:56 +00:00
parent ccc89e5b67
commit 359243cc0a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=550854
9 changed files with 35 additions and 40 deletions

View File

@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= monitor-core
PORTVERSION= 3.7.1
PORTREVISION= 2
PORTVERSION= 3.7.2
CATEGORIES= sysutils net
MASTER_SITES= SF/ganglia/ganglia%20monitoring%20core/${PORTVERSION}
PKGNAMEPREFIX= ganglia-
@ -22,15 +21,11 @@ LIB_DEPENDS= libapr-1.so:devel/apr1 \
libpcre.so:devel/pcre \
libexpat.so:textproc/expat2
OPTIONS_DEFINE= GMETAD
OPTIONS_DEFAULT= GMETAD
GMETAD_DESC= include gmetad
USES= libtool pkgconfig python:2.7
USES= libtool pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-setuid=ganglia --enable-setgid=ganglia \
--with-python=${PYTHON_CMD}
--disable-python
CONFIGURE_ENV= GANGLIA_ACK_SYSCONFDIR=1
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@ -38,6 +33,10 @@ LDFLAGS+= -L${LOCALBASE}/lib
USERS= ganglia
GROUPS= ganglia
OPTIONS_DEFINE= GMETAD
OPTIONS_DEFAULT= GMETAD
GMETAD_DESC= include gmetad
PLIST_SUB+= PORTVERSION=${PORTVERSION}
SUB_FILES+= pkg-message
@ -71,25 +70,24 @@ MODULES= modcpu.so \
modmulticpu.so \
modnet.so \
modproc.so \
modpython.so \
modsys.so
# gmond.conf.5 and gmond.conf.html can be generated from conf.pod, but
# doing so requires perl installed in the build stage.
post-patch:
${REINPLACE_CMD} \
pre-configure:
@${REINPLACE_CMD} \
-e "s|/etc/ganglia/\(gm[a-z]*d.conf\)|${PREFIX}/etc/\1|g" \
${WRKSRC}/README \
${WRKSRC}/mans/gmetad.1 \
${WRKSRC}/mans/gmond.1
${REINPLACE_CMD} -e "s|nobody|ganglia|g" \
@${REINPLACE_CMD} -e "s|nobody|ganglia|g" \
${WRKSRC}/gmetad/gmetad.conf.in \
${WRKSRC}/gmond/conf.pod \
${WRKSRC}/gmond/gmond.conf.5 \
${WRKSRC}/gmond/gmond.conf.html
post-build:
${WRKSRC}/gmond/gmond -t > ${WRKDIR}/gmond.conf
@${WRKSRC}/gmond/gmond -t > ${WRKDIR}/gmond.conf
post-install:
${INSTALL_DATA} ${WRKDIR}/gmond.conf \
@ -110,6 +108,6 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/gmond/gmond.conf.5 \
${STAGEDIR}${MANPREFIX}/man/man5
${MKDIR} ${STAGEDIR}/var/db/ganglia/rrds
${MKDIR} ${STAGEDIR}${PREFIX}/lib/ganglia/python_modules
@${CHMOD} -R a+rX ${STAGEDIR}/var/db/ganglia
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1470747673
SHA256 (ganglia-3.7.1.tar.gz) = e735a6218986a0ff77c737e5888426b103196c12dc2d679494ca9a4269ca69a3
SIZE (ganglia-3.7.1.tar.gz) = 1311019
TIMESTAMP = 1601485985
SHA256 (ganglia-3.7.2.tar.gz) = 042dbcaf580a661b55ae4d9f9b3566230b2232169a0898e91a797a4c61888409
SIZE (ganglia-3.7.2.tar.gz) = 1302320

View File

@ -1,6 +1,6 @@
--- gmetad/Makefile.in.orig 2013-05-07 09:39:40.000000000 -0500
+++ gmetad/Makefile.in 2014-10-14 15:31:54.000000000 -0500
@@ -659,8 +659,6 @@
--- gmetad/Makefile.in.orig 2015-07-01 19:49:35 UTC
+++ gmetad/Makefile.in
@@ -713,8 +713,6 @@ gmetad.service: gmetad.service.in $(FIXCONFIG)
$(FIXCONFIG) gmetad.service.in
install-data-hook: gmetad.conf

View File

@ -1,11 +1,11 @@
--- gmetad/conf.c.in.orig 2013-05-07 09:39:40.000000000 -0500
+++ gmetad/conf.c.in 2014-10-14 15:31:54.000000000 -0500
@@ -374,7 +374,7 @@
--- gmetad/conf.c.in.orig 2015-07-01 19:49:35 UTC
+++ gmetad/conf.c.in
@@ -475,7 +475,7 @@ set_defaults (gmetad_config_t *config)
config->trusted_hosts = NULL;
config->debug_level = 0;
config->should_setuid = 1;
- config->setuid_username = "nobody";
+ config->setuid_username = SETUID_USER;
config->rrd_rootdir = "@varstatedir@/ganglia/rrds";
config->write_rrds = 1;
config->scalable_mode = 1;
config->rrdcached_addrstr = NULL;
memset(&config->rrdcached_address, 0, sizeof (config->rrdcached_address));

View File

@ -1,6 +1,6 @@
--- gmond/modules/conf.d/modpython.conf.in.orig 2013-05-07 09:39:40.000000000 -0500
+++ gmond/modules/conf.d/modpython.conf.in 2014-10-14 15:31:54.000000000 -0500
@@ -9,8 +9,8 @@
--- gmond/modules/conf.d/modpython.conf.in.orig 2015-07-01 19:49:35 UTC
+++ gmond/modules/conf.d/modpython.conf.in
@@ -9,8 +9,8 @@ modules {
module {
name = "python_module"
path = "modpython.so"

View File

@ -1,6 +1,6 @@
--- gmond/modules/python/Makefile.in.orig 2013-05-07 09:39:40.000000000 -0500
+++ gmond/modules/python/Makefile.in 2014-10-14 15:31:54.000000000 -0500
@@ -601,8 +601,8 @@
--- gmond/modules/python/Makefile.in.orig 2015-07-01 19:49:35 UTC
+++ gmond/modules/python/Makefile.in
@@ -639,8 +639,8 @@ README: README.in $(FIXCONFIG)
# Note that README is listed as a dependency to be generated, but it
# is not currently installed anywhere
install-exec-hook: ../conf.d/modpython.conf README

View File

@ -1,6 +1,6 @@
--- lib/default_conf.h.in.orig 2013-05-07 09:39:40.000000000 -0500
+++ lib/default_conf.h.in 2014-10-14 15:31:54.000000000 -0500
@@ -397,7 +397,7 @@
--- lib/default_conf.h.in.orig 2015-07-01 19:49:35 UTC
+++ lib/default_conf.h.in
@@ -393,7 +393,7 @@ collection_group {\n\
}\n\
}\n\
\n\

View File

@ -1,6 +1,6 @@
--- libmetrics/freebsd/metrics.c.orig 2013-05-07 09:39:40.000000000 -0500
+++ libmetrics/freebsd/metrics.c 2014-10-14 15:32:43.000000000 -0500
@@ -461,6 +461,17 @@
--- libmetrics/freebsd/metrics.c.orig 2015-07-01 19:49:35 UTC
+++ libmetrics/freebsd/metrics.c
@@ -461,6 +461,17 @@ cpu_sintr_func ( void )
return val;
}

View File

@ -1,7 +1,6 @@
bin/ganglia-config
bin/gmetric
bin/gstat
etc/gmond.conf.d/modpython.conf
@sample etc/gmond.conf.sample
%%GMETAD%%@sample etc/gmetad.conf.sample
include/ganglia.h
@ -19,7 +18,6 @@ lib/ganglia/modmem.so
lib/ganglia/modmulticpu.so
lib/ganglia/modnet.so
lib/ganglia/modproc.so
lib/ganglia/modpython.so
lib/ganglia/modsys.so
lib/libganglia.so.0
lib/libganglia.so.0.0.0
@ -34,6 +32,5 @@ man/man5/gmond.conf.5.gz
%%GMETAD%%sbin/gmetad
%%GMETAD%%sbin/gmetasnap
sbin/gmond
@dir lib/ganglia/python_modules
@dir(ganglia,ganglia,) /var/db/ganglia/rrds
@dir(ganglia,ganglia,) /var/db/ganglia