POE::Component::Hailo is a POE component that provides a non-blocking wrapper
around Hailo. It accepts the events listed under "INPUT" and emits the events listed under "OUTPUT". WWW: http://search.cpan.org/dist/POE-Component-Hailo/ PR: ports/159295 Submitted by: milki <milki@rescomp.berkeley.edu>
This commit is contained in:
parent
ac7e0ee7ad
commit
358b9d259e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=279708
@ -2082,6 +2082,7 @@
|
||||
SUBDIR += p5-POE-Component-Daemon
|
||||
SUBDIR += p5-POE-Component-DebugShell
|
||||
SUBDIR += p5-POE-Component-DirWatch
|
||||
SUBDIR += p5-POE-Component-Hailo
|
||||
SUBDIR += p5-POE-Component-IKC
|
||||
SUBDIR += p5-POE-Component-JobQueue
|
||||
SUBDIR += p5-POE-Component-Logger
|
||||
|
29
devel/p5-POE-Component-Hailo/Makefile
Normal file
29
devel/p5-POE-Component-Hailo/Makefile
Normal file
@ -0,0 +1,29 @@
|
||||
# New ports collection makefile for: POE-Componenet-Hailo
|
||||
# Date created: 2011-07-19
|
||||
# Whom: milki <milki@rescomp.berkeley.edu>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= POE-Component-Hailo
|
||||
PORTVERSION= 0.10
|
||||
CATEGORIES= devel perl5
|
||||
MASTER_SITES= CPAN
|
||||
MASTER_SITE_SUBDIR= CPAN:HINRIK
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= milki@rescomp.berkeley.edu
|
||||
COMMENT= A non-blocking wrapper around Hailo
|
||||
|
||||
LICENSE= ART10 GPLv1
|
||||
LICENSE_COMB= dual
|
||||
|
||||
BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
|
||||
p5-Hailo>=0:${PORTSDIR}/textproc/p5-Hailo
|
||||
RUN_DEPENDS:= ${BUILD_DEPENDS}
|
||||
|
||||
PERL_CONFIGURE= yes
|
||||
|
||||
MAN3= POE::Component::Hailo.3
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/p5-POE-Component-Hailo/distinfo
Normal file
2
devel/p5-POE-Component-Hailo/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
SHA256 (POE-Component-Hailo-0.10.tar.gz) = 2fb1a36b2bf4ed1b055be0427be95fad441f5c9bbc42dbc0f216d01d3f558edc
|
||||
SIZE (POE-Component-Hailo-0.10.tar.gz) = 12258
|
16
devel/p5-POE-Component-Hailo/files/patch-Makefile.PL.in
Normal file
16
devel/p5-POE-Component-Hailo/files/patch-Makefile.PL.in
Normal file
@ -0,0 +1,16 @@
|
||||
--- Makefile.PL.new 2011-07-29 07:05:19.000000000 -0700
|
||||
+++ Makefile.PL 2011-07-29 07:06:44.000000000 -0700
|
||||
@@ -48,5 +48,12 @@
|
||||
|
||||
WriteMakefile(%WriteMakefileArgs);
|
||||
|
||||
+package MY;
|
||||
|
||||
-
|
||||
+sub init_PM {
|
||||
+ my $self = shift;
|
||||
+ $self->SUPER::init_PM(@_);
|
||||
+ # Do not install the README and README.pod
|
||||
+ delete $self->{PM}{"README.pod"};
|
||||
+ delete $self->{PM}{"README"};
|
||||
+}
|
5
devel/p5-POE-Component-Hailo/pkg-descr
Normal file
5
devel/p5-POE-Component-Hailo/pkg-descr
Normal file
@ -0,0 +1,5 @@
|
||||
POE::Component::Hailo is a POE component that provides a non-blocking wrapper
|
||||
around Hailo. It accepts the events listed under "INPUT" and emits the events
|
||||
listed under "OUTPUT".
|
||||
|
||||
WWW: http://search.cpan.org/dist/POE-Component-Hailo/
|
7
devel/p5-POE-Component-Hailo/pkg-plist
Normal file
7
devel/p5-POE-Component-Hailo/pkg-plist
Normal file
@ -0,0 +1,7 @@
|
||||
%%SITE_PERL%%/POE/Component/Hailo.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Hailo/.packlist
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Hailo
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
|
||||
@dirrmtry %%SITE_PERL%%/POE/Component
|
||||
@dirrmtry %%SITE_PERL%%/POE
|
Loading…
Reference in New Issue
Block a user