Add ftpcopy, a two command line ftp tools.

- ftpcopy is a simply FTP client written to copy files or directories
  (recursively) from a FTP server.

- ftpls is a FTP client which generates directory listings, either in plain
  text or HTML.
This commit is contained in:
Maxim Sobolev 2000-07-05 16:34:48 +00:00
parent ebf8f6f313
commit 35764879e6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=30241
7 changed files with 63 additions and 0 deletions

View File

@ -6,6 +6,7 @@
SUBDIR += cftp
SUBDIR += curl
SUBDIR += downloader
SUBDIR += ftpcopy
SUBDIR += ftpfind
SUBDIR += ftplocate
SUBDIR += ftpmirror

21
ftp/ftpcopy/Makefile Normal file
View File

@ -0,0 +1,21 @@
# New ports collection makefile for: ftpcopy
# Date created: 5 June 2000
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= ftpcopy
PORTVERSION= 0.2.2
CATEGORIES= ftp
MASTER_SITES= http://www.ohse.de/uwe/releases/
MAINTAINER= sobomax@FreeBSD.org
do-install:
${MKDIR} ${PREFIX}/share/ftpcopy
cd ${WRKSRC} && \
${INSTALL_PROGRAM} ftpcopy ftpls ${PREFIX}/bin && \
${INSTALL_DATA} NEWS README ${PREFIX}/share/ftpcopy
.include <bsd.port.mk>

1
ftp/ftpcopy/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (ftpcopy-0.2.2.tar.gz) = 2b4a61167b561bcf19553229bdb7f2ad

View File

@ -0,0 +1,21 @@
--- Makefile.orig Wed Jul 5 19:14:15 2000
+++ Makefile Wed Jul 5 19:14:57 2000
@@ -1,6 +1,6 @@
VERSION=0.2.2
PACKAGE=ftpcopy
-prefix=/usr/local
+prefix=$(PREFIX)
PACKAGE_VERSION=$(PACKAGE)-$(VERSION)
HEADERS= ftpparse.h ftplib.h urlparse.h timeoutio.h
@@ -8,8 +8,8 @@
EXTRA_DIST= README $(man_MANS) NEWS ChangeLog install.list
INCLUDES=-I. -DPACKAGE_VERSION=\"$(PACKAGE)-$(VERSION)\" -DPACKAGE=\"$(PACKAGE)\" -DVERSION=\"$(VERSION)\"
EXTRA_DIST+=premake.defs premake.pl Makefile.pre premake.rules
-TAR=tar
-CC=gcc
+TAR?=tar
+CC?=gcc
LINK=./link.sh
COMPILE=./compile.sh
AR=ar

1
ftp/ftpcopy/pkg-comment Normal file
View File

@ -0,0 +1 @@
Two command line ftp tools

13
ftp/ftpcopy/pkg-descr Normal file
View File

@ -0,0 +1,13 @@
Two command line ftp tools.
ftpcopy is a simply FTP client written to copy files or directories
(recursively) from a FTP server. It's main purpose is to mirror FTP sites which
support the EPLF directory listing format, although it also supports the
traditional listing format (/bin/ls).
ftpls is a FTP client which generates directory listings, either in plain text
or HTML.
The tools only support passive mode FTP.
WWW: http://www.ohse.de/uwe/software/ftpcopy.html

5
ftp/ftpcopy/pkg-plist Normal file
View File

@ -0,0 +1,5 @@
bin/ftpcopy
bin/ftpls
share/ftpcopy/NEWS
share/ftpcopy/README
@dirrm share/ftpcopy