add dia2code

Dia2Code is a small utility used to generate code from a Dia diagram
This commit is contained in:
Ying-Chieh Liao 2001-03-07 04:17:49 +00:00
parent c9f58b01cb
commit 356b628722
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=39161
7 changed files with 67 additions and 0 deletions

View File

@ -75,6 +75,7 @@
SUBDIR += cweb
SUBDIR += cxref
SUBDIR += ddd
SUBDIR += dia2code
SUBDIR += diffconvert
SUBDIR += dmake
SUBDIR += dmalloc

28
devel/dia2code/Makefile Normal file
View File

@ -0,0 +1,28 @@
# ex:ts=8
# New ports collection makefile for: dia2code
# Date created: Mar 7, 2001
# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= dia2code
PORTVERSION= 0.5
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ijliao@FreeBSD.org
LIB_DEPENDS= xml.5:${PORTSDIR}/textproc/libxml
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
XML_CONFIG= ${LOCALBASE}/bin/xml-config
USE_GMAKE= yes
post-patch:
@${PERL} -pi -e "s|%%XML_CONFIG%%|${XML_CONFIG}|g" ${WRKSRC}/dia2code/Makefile.in
.include <bsd.port.mk>

1
devel/dia2code/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (dia2code-0.5.tar.gz) = 5cea69ebb58c3b5c262850a86cd98d9d

View File

@ -0,0 +1,20 @@
--- dia2code/Makefile.in.orig Wed Jan 24 04:43:08 2001
+++ dia2code/Makefile.in Wed Mar 7 11:56:58 2001
@@ -68,7 +68,7 @@
####### kdevelop will overwrite this part!!! (end)############
bin_PROGRAMS = dia2code
dia2code_SOURCES = scan_tree.c generate_code_c.c parse_diagram.c dia2code.c generate_code_java.c generate_code_cpp.c main.c
-dia2code_LDADD = -lxml
+dia2code_LDADD = `%%XML_CONFIG%% --libs`
SUBDIRS = docs
@@ -79,7 +79,7 @@
PROGRAMS = $(bin_PROGRAMS)
-DEFS = @DEFS@ -I. -I$(srcdir) -I..
+DEFS = @DEFS@ -I. -I$(srcdir) -I.. -I/usr/local/include
CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
LIBS = @LIBS@

View File

@ -0,0 +1 @@
Dia2Code is a small utility used to generate code from a Dia diagram

15
devel/dia2code/pkg-descr Normal file
View File

@ -0,0 +1,15 @@
Dia2Code is a small utility used to generate code from a Dia diagram.
Dia is a program to make diagrams (ports/graphics/dia)
- Reads UML diagrams.
- Can handle UML - Generalization, UML - Realization and UML - Implements.
- Selective code generation.
- User-defined output directory.
- Stereotype handling: interfaces, abstract classes.
- "Import" and "include" based on the parent classes, the type of
attributes and return type of methods iff they're declared in the same
diagram.
- Support for JavaBeans(tm): will create automagically methods to access
and modify each attribute.
WWW: http://dia2code.sourceforge.net/

1
devel/dia2code/pkg-plist Normal file
View File

@ -0,0 +1 @@
bin/dia2code