Update 2.2.1. Also support ${PREFIX} properly.
This commit is contained in:
parent
b4199efa18
commit
355ccf2a1d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=30471
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= pdq
|
||||
PORTVERSION= 2.1.1
|
||||
PORTVERSION= 2.2.1
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= ftp://feynman.tam.uiuc.edu/pub/pdq/
|
||||
EXTRACT_SUFX= .tgz
|
||||
@ -19,6 +19,7 @@ GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
|
||||
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-pdqlibdir=${PREFIX}/etc/pdq
|
||||
CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
|
||||
GLIB_CONFIG="${GLIB_CONFIG}"
|
||||
|
||||
@ -26,12 +27,11 @@ MAN1= lpd_cancel.1 lpd_print.1 lpd_status.1 pdq.1 xpdq.1
|
||||
MAN5= printrc.5
|
||||
|
||||
post-install:
|
||||
${CP} ${WRKSRC}/sample_etc_printrc ${PREFIX}/etc/printrc.sample
|
||||
strip ${PREFIX}/bin/pdq
|
||||
strip ${PREFIX}/bin/xpdq
|
||||
strip ${PREFIX}/bin/lpd_cancel
|
||||
strip ${PREFIX}/bin/lpd_print
|
||||
strip ${PREFIX}/bin/lpd_status
|
||||
@${CAT} pkg/MESSAGE
|
||||
@${SED} 's|%%PREFIX%%|${PREFIX}|g' pkg/MESSAGE
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1 @@
|
||||
MD5 (pdq-2.1.1.tgz) = bcdcb66d449ae9c5ec544227dc2a059a
|
||||
MD5 (pdq-2.1.1.tgz) = 6c684021b2f22ae5d957480b3a196d61
|
||||
|
||||
MD5 (pdq-2.2.1.tgz) = c72d076b4ba59bf206bc469c57201785
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- src/parse_rc.c.orig Sat May 15 01:03:20 1999
|
||||
+++ src/parse_rc.c Sat May 15 07:06:17 1999
|
||||
--- src/parse_rc.c.orig Fri Mar 31 23:36:30 2000
|
||||
+++ src/parse_rc.c Tue Jul 11 11:08:20 2000
|
||||
@@ -23,7 +23,6 @@
|
||||
#include <glob.h>
|
||||
#include <string.h>
|
||||
@ -8,16 +8,7 @@
|
||||
|
||||
|
||||
#include "parse.h"
|
||||
@@ -35,6 +34,8 @@
|
||||
#include "driver.h"
|
||||
#include "interface.h"
|
||||
|
||||
+#define PRINTRC "/usr/local/etc/printrc"
|
||||
+
|
||||
void try_parse_rc_glob (char *rc_glob, rc_items *rc) {
|
||||
|
||||
glob_t globbuf;
|
||||
@@ -46,12 +47,8 @@
|
||||
@@ -46,12 +45,8 @@
|
||||
i = glob (d, 0, NULL, &globbuf);
|
||||
free (d);
|
||||
if (i != 0) {
|
||||
@ -32,7 +23,7 @@
|
||||
} else {
|
||||
/* Globbed something real */
|
||||
for (i = 0; i < globbuf.gl_pathc; i++) {
|
||||
@@ -71,11 +68,7 @@
|
||||
@@ -74,11 +69,7 @@
|
||||
|
||||
i = glob (d, 0, NULL, &globbuf);
|
||||
if (i != 0) {
|
||||
@ -45,44 +36,3 @@
|
||||
free (d);
|
||||
my_exit (1);
|
||||
} else {
|
||||
@@ -258,7 +251,7 @@
|
||||
int trouble_flag;
|
||||
|
||||
rc_locs = NULL;
|
||||
- find_rc_glob_locations (type, name, "/etc/printrc", &rc_locs);
|
||||
+ find_rc_glob_locations (type, name, PRINTRC, &rc_locs);
|
||||
find_rc_glob_locations (type, name, "~/.printrc", &rc_locs);
|
||||
|
||||
set_flag = 0;
|
||||
@@ -282,7 +275,7 @@
|
||||
}
|
||||
|
||||
if ( (set_flag == 0) || (trouble_flag == 1) ) {
|
||||
- if (0 != append_to_rc_file ("/etc/printrc", buf) ) {
|
||||
+ if (0 != append_to_rc_file (PRINTRC, buf) ) {
|
||||
append_to_rc_file ("~/.printrc", buf); /* Return code not checked.
|
||||
* What else can we do?
|
||||
*/
|
||||
@@ -299,7 +292,7 @@
|
||||
int trouble_flag;
|
||||
|
||||
rc_locs = NULL;
|
||||
- find_rc_glob_locations (type, name, "/etc/printrc", &rc_locs);
|
||||
+ find_rc_glob_locations (type, name, PRINTRC, &rc_locs);
|
||||
find_rc_glob_locations (type, name, "~/.printrc", &rc_locs);
|
||||
|
||||
trouble_flag = 0;
|
||||
@@ -315,11 +308,11 @@
|
||||
|
||||
/* In this case, buf should have been set to some commands that
|
||||
* indicate to delete the object. For example, say printer foo is
|
||||
- * defined in /etc/printrc. Ordinary users cannot delete it, but
|
||||
+ * defined in /usr/local/etc/printrc. Ordinary users cannot delete it, but
|
||||
* they may add the command "printer foo delete" to their own rc file.
|
||||
*/
|
||||
if (trouble_flag == 1) {
|
||||
- if (0 != append_to_rc_file ("/etc/printrc", buf) ) {
|
||||
+ if (0 != append_to_rc_file (PRINTRC, buf) ) {
|
||||
append_to_rc_file ("~/.printrc", buf); /* Return code not checked.
|
||||
* What else can we do?
|
||||
*/
|
||||
|
@ -1,6 +1,6 @@
|
||||
*******************************************************
|
||||
* *
|
||||
* Please copy /usr/local/etc/printrc.sample to *
|
||||
* /usr/local/etc/printrc by yourself, thanks. *
|
||||
* *
|
||||
*******************************************************
|
||||
***********************************************************
|
||||
|
||||
Please copy %%PREFIX%%/etc/pdq/printrc.example to
|
||||
%%PREFIX%%/etc/pdq/printrc by yourself, thanks.
|
||||
|
||||
***********************************************************
|
||||
|
@ -3,4 +3,37 @@ bin/xpdq
|
||||
bin/lpd_cancel
|
||||
bin/lpd_print
|
||||
bin/lpd_status
|
||||
etc/printrc.sample
|
||||
etc/pdq/drivers/generic/generic-postscript-1.2
|
||||
etc/pdq/drivers/generic/generic-text-only-1.1
|
||||
etc/pdq/drivers/generic/printcap-emulation-1.0
|
||||
etc/pdq/drivers/ghostscript/gs-bjc600-0.1
|
||||
etc/pdq/drivers/ghostscript/gs-bjc800-0.1
|
||||
etc/pdq/drivers/ghostscript/gs-cdj1600-0.1
|
||||
etc/pdq/drivers/ghostscript/gs-cdj500-0.1
|
||||
etc/pdq/drivers/ghostscript/gs-cdj550-0.1
|
||||
etc/pdq/drivers/ghostscript/gs-cdj670-0.1
|
||||
etc/pdq/drivers/ghostscript/gs-cdj850-0.1
|
||||
etc/pdq/drivers/ghostscript/gs-cdj890-0.1
|
||||
etc/pdq/drivers/ghostscript/gs-declj250-0.1
|
||||
etc/pdq/drivers/ghostscript/gs-pjtest-0.1
|
||||
etc/pdq/drivers/ghostscript/gs-pjxl300-0.1
|
||||
etc/pdq/drivers/ghostscript/gs-pjxltest-0.1
|
||||
etc/pdq/drivers/ghostscript/gs-stcolor-0.1
|
||||
etc/pdq/drivers/ghostscript/gs-uniprint-simple-0.1
|
||||
etc/pdq/drivers/misc/hp-laserjet-5-0.9
|
||||
etc/pdq/drivers/postscript/hp-2500-cm-2.0
|
||||
etc/pdq/drivers/postscript/hp-4050-tn-1.0
|
||||
etc/pdq/drivers/postscript/qms-magicolor-cx-1.1
|
||||
etc/pdq/interfaces/appletalk-1.0
|
||||
etc/pdq/interfaces/bsd-lpd-2.0
|
||||
etc/pdq/interfaces/efax-0.1
|
||||
etc/pdq/interfaces/local-port-1.0
|
||||
etc/pdq/interfaces/tcp-port-2.0
|
||||
etc/pdq/printrc.example
|
||||
@dirrm etc/pdq/interfaces
|
||||
@dirrm etc/pdq/drivers/postscript
|
||||
@dirrm etc/pdq/drivers/misc
|
||||
@dirrm etc/pdq/drivers/ghostscript
|
||||
@dirrm etc/pdq/drivers/generic
|
||||
@dirrm etc/pdq/drivers
|
||||
@dirrm etc/pdq
|
||||
|
Loading…
Reference in New Issue
Block a user