Neo4j is the world's leading Graph Database. It is a high performance graph

store with all the features expected of a mature and robust database, like a
friendly query language and ACID transactions. The programmer works with a
flexible network structure of nodes and relationships rather than static
tables yet enjoys all the benefits of enterprise-quality database. For many
applications, Neo4j offers orders of magnitude performance benefits compared
to relational DBs.

WWW: https://neo4j.com
This commit is contained in:
Chris Rees 2016-08-25 02:19:15 +00:00
parent 843dc79555
commit 34f9c11fbb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=420830
9 changed files with 235 additions and 0 deletions

View File

@ -236,6 +236,7 @@
SUBDIR += nagios-check_postgres_replication
SUBDIR += nagios-check_redis
SUBDIR += namazu2
SUBDIR += neo4j
SUBDIR += ntdb
SUBDIR += ocaml-dbm
SUBDIR += ocaml-mysql

42
databases/neo4j/Makefile Normal file
View File

@ -0,0 +1,42 @@
# $FreeBSD$
PORTNAME= neo4j
DISTVERSION= 3.0.4
CATEGORIES= databases java
MASTER_SITES= http://dist.neo4j.org/
DISTNAME= ${PORTNAME}-community-${DISTVERSION}-unix
MAINTAINER= crees@FreeBSD.org
COMMENT= High performance graph store and database
RUN_DEPENDS= bash:shells/bash
WRKSRC= ${WRKDIR}/${DISTNAME:S,-unix,,}
NO_BUILD= yes
USE_JAVA= yes
USE_RC_SUBR= ${PORTNAME}
SUB_FILES= ${PORTNAME}.sh
post-patch:
${REINPLACE_CMD} ${_SUB_LIST_TEMP} ${WRKSRC}/bin/neo4j-shared.sh \
${WRKSRC}/conf/neo4j.conf
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}/tools
${INSTALL_SCRIPT} ${WRKSRC}/bin/tools/* \
${STAGEDIR}${PREFIX}/libexec/${PORTNAME}/tools
.for j in j j-admin j-import j-shell
${INSTALL_SCRIPT} ${WRKSRC}/bin/neo4$j ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}
-cd ${STAGEDIR}${PREFIX}/bin && ${LN} ${PORTNAME} neo4$j 2>/dev/null
.endfor
${MKDIR} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/plugins
${INSTALL_SCRIPT} ${WRKSRC}/lib/* ${STAGEDIR}${PREFIX}/lib/${PORTNAME}
${INSTALL_SCRIPT} ${WRKSRC}/bin/${PORTNAME}-shared.sh \
${STAGEDIR}${PREFIX}/libexec/${PORTNAME}
.for f in ${PORTNAME}.conf ${PORTNAME}-wrapper.conf
${INSTALL_DATA} ${WRKSRC}/conf/$f \
${STAGEDIR}${PREFIX}/etc/$f.sample
.endfor
${MKDIR} ${STAGEDIR}${DATADIR} ${STAGEDIR}${PREFIX}/etc/neo4j-certificates
.include <bsd.port.mk>

3
databases/neo4j/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1472081606
SHA256 (neo4j-community-3.0.4-unix.tar.gz) = e1da51163eb18380623788eabea34dfe23ee21c99deca4e7922094b0d242e805
SIZE (neo4j-community-3.0.4-unix.tar.gz) = 61425809

View File

@ -0,0 +1,39 @@
#!/bin/sh
# $FreeBSD$
#
# PROVIDE: neo4j
# REQUIRE: DAEMON
# KEYWORD: shutdown
# Add the following line to /etc/rc.conf to enable neo4j:
#
# neo4j_enable=YES
. /etc/rc.subr
name=neo4j
rcvar=neo4j_enable
desc="Graphing database"
load_rc_config $name
: ${neo4j_enable:=NO}
command=%%PREFIX%%/libexec/neo4j
start_cmd="$command start"
start_precmd=neo4j_prestart
stop_cmd="$command stop"
status_cmd="$command status"
neo4j_prestart()
{
NEO4J_DATA=%%DATADIR%%
NEO4J_LIB=%%PREFIX%%/lib/neo4j
NEO4J_LOGS=/var/log/neo4j
NEO4J_PLUGINS=${NEO4J_LIB}/plugins
NEO4J_RUN=/var/run/neo4j
mkdir -p ${NEO4J_LOGS} ${NEO4J_RUN}
}
run_rc_command $1

View File

@ -0,0 +1,7 @@
#!/usr/bin/env bash
#
# $FreeBSD$
. %%PREFIX%%/libexec/neo4j/neo4j-shared.sh
exec %%PREFIX%%/libexec/neo4j/$(basename $0) ${1+"$@"}

View File

@ -0,0 +1,29 @@
$FreeBSD$
--- bin/neo4j-shared.sh.orig 2016-08-25 00:54:03.496139435 +0100
+++ bin/neo4j-shared.sh 2016-08-25 01:02:34.689503862 +0100
@@ -124,7 +124,7 @@
if [[ -z "${NEO4J_HOME:-}" ]]; then
NEO4J_HOME="$(cd "$(dirname "$0")"/.. && pwd)"
fi
- : "${NEO4J_CONF:="${NEO4J_HOME}/conf"}"
+ export NEO4J_CONF=%%PREFIX%%/etc
readonly NEO4J_HOME NEO4J_CONF
}
@@ -159,10 +159,10 @@
}
_setup_configurable_paths() {
- NEO4J_DATA=$(resolve_path "${dbms_directories_data:-data}")
- NEO4J_LIB=$(resolve_path "${dbms_directories_lib:-lib}")
- NEO4J_LOGS=$(resolve_path "${dbms_directories_logs:-logs}")
- NEO4J_PLUGINS=$(resolve_path "${dbms_directories_plugins:-plugins}")
- NEO4J_RUN=$(resolve_path "${dbms_directories_run:-run}")
+ export NEO4J_DATA=%%DATADIR%%
+ export NEO4J_LIB=%%PREFIX%%/lib/neo4j
+ export NEO4J_LOGS=/var/log/neo4j
+ export NEO4J_PLUGINS=${NEO4J_LIB}/plugins
+ export NEO4J_RUN=/var/run
readonly NEO4J_DATA NEO4J_LIB NEO4J_LOGS NEO4J_PLUGINS NEO4J_RUN
}

View File

@ -0,0 +1,17 @@
$FreeBSD$
--- conf/neo4j.conf.orig 2016-08-25 02:30:25.057742736 +0100
+++ conf/neo4j.conf 2016-08-25 02:32:53.932724521 +0100
@@ -6,9 +6,9 @@
#dbms.active_database=graph.db
# Paths of directories in the installation.
-#dbms.directories.data=data
-#dbms.directories.plugins=plugins
-#dbms.directories.certificates=certificates
+dbms.directories.data=%%DATADIR%%
+dbms.directories.plugins=%%PREFIX%%/lib/neo4j/plugins
+dbms.directories.certificates=%%PREFIX%%/etc/neo4j-certificates
# This setting constrains all `LOAD CSV` import files to be under the `import` directory. Remove or uncomment it to
# allow files to be loaded from anywhere in filesystem; this introduces possible security problems. See the `LOAD CSV`

View File

@ -0,0 +1,9 @@
Neo4j is the world's leading Graph Database. It is a high performance graph
store with all the features expected of a mature and robust database, like a
friendly query language and ACID transactions. The programmer works with a
flexible network structure of nodes and relationships rather than static
tables yet enjoys all the benefits of enterprise-quality database. For many
applications, Neo4j offers orders of magnitude performance benefits compared
to relational DBs.
WWW: https://neo4j.com

88
databases/neo4j/pkg-plist Normal file
View File

@ -0,0 +1,88 @@
bin/neo4j
bin/neo4j-admin
bin/neo4j-import
bin/neo4j-shell
@sample etc/neo4j-wrapper.conf.sample
@sample etc/neo4j.conf.sample
lib/neo4j/asm-5.0.2.jar
lib/neo4j/bcpkix-jdk15on-1.53.jar
lib/neo4j/bcprov-jdk15on-1.53.jar
lib/neo4j/commons-beanutils-1.8.3.jar
lib/neo4j/commons-configuration-1.10.jar
lib/neo4j/commons-digester-2.1.jar
lib/neo4j/commons-io-2.4.jar
lib/neo4j/commons-lang-2.6.jar
lib/neo4j/commons-lang3-3.3.2.jar
lib/neo4j/commons-logging-1.1.1.jar
lib/neo4j/concurrentlinkedhashmap-lru-1.4.2.jar
lib/neo4j/jackson-core-asl-1.9.13.jar
lib/neo4j/jackson-jaxrs-1.9.13.jar
lib/neo4j/jackson-mapper-asl-1.9.13.jar
lib/neo4j/javax.servlet-api-3.1.0.jar
lib/neo4j/jersey-core-1.19.jar
lib/neo4j/jersey-multipart-1.19.jar
lib/neo4j/jersey-server-1.19.jar
lib/neo4j/jersey-servlet-1.19.jar
lib/neo4j/jetty-http-9.2.9.v20150224.jar
lib/neo4j/jetty-io-9.2.9.v20150224.jar
lib/neo4j/jetty-security-9.2.9.v20150224.jar
lib/neo4j/jetty-server-9.2.9.v20150224.jar
lib/neo4j/jetty-servlet-9.2.9.v20150224.jar
lib/neo4j/jetty-util-9.2.9.v20150224.jar
lib/neo4j/jetty-webapp-9.2.9.v20150224.jar
lib/neo4j/jetty-xml-9.2.9.v20150224.jar
lib/neo4j/jline-2.12.jar
lib/neo4j/jsr311-api-1.1.2.r612.jar
lib/neo4j/lucene-analyzers-common-5.5.0.jar
lib/neo4j/lucene-codecs-5.5.0.jar
lib/neo4j/lucene-core-5.5.0.jar
lib/neo4j/lucene-queryparser-5.5.0.jar
lib/neo4j/mimepull-1.9.3.jar
lib/neo4j/neo4j-bolt-3.0.4.jar
lib/neo4j/neo4j-browser-1.1.8.jar
lib/neo4j/neo4j-codegen-3.0.4.jar
lib/neo4j/neo4j-collections-3.0.4.jar
lib/neo4j/neo4j-command-line-3.0.4.jar
lib/neo4j/neo4j-common-3.0.4.jar
lib/neo4j/neo4j-consistency-check-3.0.4.jar
lib/neo4j/neo4j-csv-3.0.4.jar
lib/neo4j/neo4j-cypher-3.0.4.jar
lib/neo4j/neo4j-cypher-compiler-2.3-2.3.5.jar
lib/neo4j/neo4j-cypher-compiler-3.0-3.0.4.jar
lib/neo4j/neo4j-cypher-frontend-2.3-2.3.5.jar
lib/neo4j/neo4j-cypher-frontend-3.0-3.0.4.jar
lib/neo4j/neo4j-dbms-3.0.4.jar
lib/neo4j/neo4j-graph-algo-3.0.4.jar
lib/neo4j/neo4j-graph-matching-3.0.4.jar
lib/neo4j/neo4j-graphdb-api-3.0.4.jar
lib/neo4j/neo4j-import-tool-3.0.4.jar
lib/neo4j/neo4j-io-3.0.4.jar
lib/neo4j/neo4j-jmx-3.0.4.jar
lib/neo4j/neo4j-kernel-3.0.4.jar
lib/neo4j/neo4j-logging-3.0.4.jar
lib/neo4j/neo4j-lucene-index-3.0.4.jar
lib/neo4j/neo4j-lucene-upgrade-3.0.4.jar
lib/neo4j/neo4j-primitive-collections-3.0.4.jar
lib/neo4j/neo4j-resource-3.0.4.jar
lib/neo4j/neo4j-security-3.0.4.jar
lib/neo4j/neo4j-server-3.0.4.jar
lib/neo4j/neo4j-shell-3.0.4.jar
lib/neo4j/neo4j-udc-3.0.4.jar
lib/neo4j/neo4j-unsafe-3.0.4.jar
lib/neo4j/netty-all-4.0.28.Final.jar
lib/neo4j/opencsv-2.3.jar
lib/neo4j/parboiled-core-1.1.7.jar
lib/neo4j/parboiled-scala_2.11-1.1.7.jar
lib/neo4j/rhino-1.7R4.jar
lib/neo4j/scala-library-2.11.8.jar
lib/neo4j/scala-reflect-2.11.8.jar
lib/neo4j/server-api-3.0.4.jar
libexec/neo4j/neo4j
libexec/neo4j/neo4j-admin
libexec/neo4j/neo4j-import
libexec/neo4j/neo4j-shared.sh
libexec/neo4j/neo4j-shell
libexec/neo4j/tools/config-migrator.jar
@dir lib/neo4j/plugins
@dir %%DATADIR%%
@dir etc/neo4j-certificates