Update to 1.7

Pass maintainership to submitter

PR:		165139
Submitted by:	John Hein <jhein@symmetricom.com>
This commit is contained in:
Tilman Keskinoz 2012-02-27 17:39:39 +00:00
parent a12012fda0
commit 34ec4c9f65
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=292316
13 changed files with 178 additions and 192 deletions

View File

@ -6,47 +6,44 @@
#
PORTNAME= gpstk
PORTVERSION= 1.5
PORTREVISION= 1
PORTVERSION= 1.7
CATEGORIES= astro devel
MASTER_SITES= SF
DISTNAME= ${PORTNAME}${PORTVERSION}.src
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= ports@FreeBSD.org
MAINTAINER= jhein@symmetricom.com
COMMENT= Toolkit for developing GPS applications
BUILD_DEPENDS= ${LOCALBASE}/bin/jam:${PORTSDIR}/devel/jam
BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_PYTHON_RUN= yes
USE_LDCONFIG= yes
USE_DOS2UNIX= yes
JAM= ${LOCALBASE}/bin/jam
JAM= jam
JAM_ENV= PREFIX="${PREFIX}" \
BINDIR="${PREFIX}/bin" \
INCDIR="${PREFIX}/include/$(PORTNAME)" \
INCDIR="${PREFIX}/include/${PORTNAME}" \
LIBDIR="${PREFIX}/lib" \
CC="${CC}" CCFLAGS="${CFLAGS}" \
C++="${CXX}" C++FLAGS="${CXXFLAGS}" \
OPTIM="-DHAVE_UINTPTR_T"
post-patch:
@${REINPLACE_CMD} -e \
's|python2.5|python|g' ${WRKSRC}/apps/reszilla/ordPlot
C++="${CXX}" C++FLAGS="${CXXFLAGS}"
do-build:
cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM}
NOSTRIPFILES= ddPlot|ordPlot # don't strip scripts
SHLIBS= geodyn geomatics gpstk procframe rxio vdraw vplot
SHLIBVER= ${PORTVERSION:C/.//g}
do-install:
@${MKDIR} ${PREFIX}/include/${PORTNAME}
cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM} install
.for shlib in geomatics gpstk procframe rxio vplot
@${LN} -sf lib${shlib}.so.15 ${PREFIX}/lib/lib${shlib}.so
.for shlib in ${SHLIBS}
@${LN} -sf lib${shlib}.so.${SHLIBVER} ${PREFIX}/lib/lib${shlib}.so
.endfor
@${STRIP_CMD} `${CAT} ${PLIST} | \
${GREP} '^bin/' | \
${GREP} -E -v 'ddPlot$$|mdpscreen$$|ordPlot$$' | \
${SED} 's:^bin/:${PREFIX}/bin/:g'`
@${STRIP_CMD} `${GREP} '^bin/' ${PLIST} | \
${GREP} -E -v '^bin/(${NOSTRIPFILES})$$' | \
${SED} 's:^:${PREFIX}/:g'`
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (gpstk1.5.src.tar.gz) = 2bc699d9eb8d9774fa6a635e0f75da2f38c00e1b700974fe9197b8ba7c867277
SIZE (gpstk1.5.src.tar.gz) = 7050592
SHA256 (gpstk-1.7.src.tar.gz) = 56f234d33b67011794612a132e84c204078ae50db223dfecadbf45301bce0373
SIZE (gpstk-1.7.src.tar.gz) = 22837053

View File

@ -1,5 +1,10 @@
--- Jamrules.orig 2008-03-12 00:48:21.000000000 +0900
+++ Jamrules 2009-05-08 23:57:05.000000000 +0900
$FreeBSD$
- make sure link pulls in libstdc++ (jam link invoked as cc instead of c++)
- don't name shlib files with extra trailing .0
--- Jamrules.orig 2011-02-22 09:10:30.000000000 -0700
+++ Jamrules 2012-02-09 17:14:48.000000000 -0700
@@ -33,6 +33,10 @@
case CYGWIN :
LINKLIBS += -lstdc++ ;
@ -11,7 +16,7 @@
case LINUX :
LINKLIBS += -lstdc++ ;
CCSHARE_FLAGS = -fPIC ;
@@ -115,7 +119,7 @@
@@ -133,7 +137,7 @@
# compiler specific stuff - this is probably actually pretty clumsy
if ( $(CC) != gcc )
{
@ -20,12 +25,12 @@
}
if $(PREFIX)
@@ -215,7 +219,7 @@
if $(UNIX) && $(OS) != CYGWIN && $(OS) != MACOSX
@@ -238,7 +242,7 @@
if $(UNIX) && $(OS) != CYGWIN
{
soname = $(LIBPREFIX)$(<:S=$(SUFLIBSHR)).$(GPSTK_SO_VERSION) ;
- shlib = $(LIBPREFIX)$(<:S=$(SUFLIBSHR).$(GPSTK_SO_VERSION).0) ;
+ shlib = $(LIBPREFIX)$(<:S=$(SUFLIBSHR)).$(GPSTK_SO_VERSION) ;
shrobjs = $(>:S=$(SUFOBJ2)) ;
ObjectCcFlags $(shrobjs) : $(CCSHARE_FLAGS) ;
ObjectC++Flags $(shrobjs) : $(CCSHARE_FLAGS) ;
soname = $(LIBPREFIX)$(<:S=$(SUFLIBSHR)).$(GPSTK_SO_VERSION) ;
- shlib = $(LIBPREFIX)$(<:S=$(SUFLIBSHR).$(GPSTK_SO_VERSION).0) ;
+ shlib = $(LIBPREFIX)$(<:S=$(SUFLIBSHR)).$(GPSTK_SO_VERSION) ;
shrobjs = $(>:S=$(SUFOBJ2)) ;
ObjectCcFlags $(shrobjs) : $(CCSHARE_FLAGS) ;
ObjectC++Flags $(shrobjs) : $(CCSHARE_FLAGS) ;

View File

@ -1,18 +0,0 @@
--- apps/checktools/ficacheck.cpp.orig Wed Jan 19 19:36:30 2005
+++ apps/checktools/ficacheck.cpp Thu May 12 15:12:26 2005
@@ -1,11 +1,14 @@
#pragma ident "$Id: //depot/sgl/gpstk/dev/apps/checktools/ficacheck.cpp#1 $"
+using namespace std;
+
+#include <ostream>
+
#include "CheckFrame.hpp"
#include "FICAStream.hpp"
#include "FICData.hpp"
-using namespace std;
using namespace gpstk;
int main(int argc, char* argv[])

View File

@ -1,17 +0,0 @@
--- apps/checktools/ficcheck.cpp.orig Wed Jan 19 19:36:30 2005
+++ apps/checktools/ficcheck.cpp Thu May 12 15:12:26 2005
@@ -1,11 +1,13 @@
#pragma ident "$Id: //depot/sgl/gpstk/dev/apps/checktools/ficcheck.cpp#1 $"
+using namespace std;
+#include <ostream>
+
#include "CheckFrame.hpp"
#include "FICStream.hpp"
#include "FICData.hpp"
-using namespace std;
using namespace gpstk;
int main(int argc, char* argv[])

View File

@ -1,18 +0,0 @@
--- apps/checktools/rmwcheck.cpp.orig Wed Jan 19 19:36:30 2005
+++ apps/checktools/rmwcheck.cpp Thu May 12 15:12:26 2005
@@ -1,12 +1,14 @@
#pragma ident "$Id: //depot/sgl/gpstk/dev/apps/checktools/rmwcheck.cpp#1 $"
+using namespace std;
+#include <ostream>
+
#include "CheckFrame.hpp"
#include "RinexMetStream.hpp"
#include "RinexMetData.hpp"
#include "RinexMetFilterOperators.hpp"
-using namespace std;
using namespace gpstk;
int main(int argc, char* argv[])

View File

@ -1,17 +0,0 @@
--- apps/checktools/rnwcheck.cpp.orig Wed Jan 19 19:36:30 2005
+++ apps/checktools/rnwcheck.cpp Thu May 12 15:12:26 2005
@@ -1,11 +1,13 @@
#pragma ident "$Id: //depot/sgl/gpstk/dev/apps/checktools/rnwcheck.cpp#1 $"
+using namespace std;
+#include <ostream>
+
#include "CheckFrame.hpp"
#include "RinexNavStream.hpp"
#include "RinexNavData.hpp"
-using namespace std;
using namespace gpstk;
int main(int argc, char* argv[])

View File

@ -1,17 +0,0 @@
--- apps/checktools/rowcheck.cpp.orig Wed Jan 19 19:36:30 2005
+++ apps/checktools/rowcheck.cpp Thu May 12 15:12:26 2005
@@ -1,11 +1,13 @@
#pragma ident "$Id: //depot/sgl/gpstk/dev/apps/checktools/rowcheck.cpp#1 $"
+using namespace std;
+#include <ostream>
+
#include "CheckFrame.hpp"
#include "RinexObsStream.hpp"
#include "RinexObsData.hpp"
-using namespace std;
using namespace gpstk;
int main(int argc, char* argv[])

View File

@ -1,23 +0,0 @@
--- lib/rxio/NovatelData.cpp.FCS 2009-11-24 09:08:46.000000000 +1100
+++ lib/rxio/NovatelData.cpp 2009-11-24 09:40:31.000000000 +1100
@@ -304,7 +304,9 @@
cout << "datasize:" << datasize << endl;
// read the rest of the record
- if(datasize-12 >= 1024) {
+ // Note: OEM2 The Message byte count equals the total
+ // length of the data block including the header.
+ if(datasize >= sizeof(buffer)) {
//FFStreamError fe("Read error - buffer overflow");
//GPSTK_THROW(fe);
failure = 1;
@@ -440,7 +442,8 @@
// ---------------------------------------
// read the data message, but don't overwrite the header
// first check against buffer overflow
- if(datasize-28 >= 1024 || datasize-28 < 0) {
+ // OEM4 total buffer usage = header+data
+ if(datasize+28 >= sizeof(buffer)) {
//FFStreamError fe("Read error - buffer overflow");
//GPSTK_THROW(fe);
failure = 1;

View File

@ -1,11 +0,0 @@
--- lib/rxio/NovatelData.hpp.FCS 2009-11-24 09:08:58.000000000 +1100
+++ lib/rxio/NovatelData.hpp 2009-11-24 09:09:34.000000000 +1100
@@ -165,7 +165,7 @@
private:
/// private data members
- unsigned char buffer[1024]; ///< buffer for raw data
+ unsigned char buffer[2048]; ///< buffer for raw data
/// Reference GPS week, for OEM2, where the nav records require a GPS week,
/// but only the obs records have one, and then it is 10-bit.

View File

@ -1,12 +0,0 @@
--- src/MiscMath.hpp.orig Thu Jan 11 21:29:49 2007
+++ src/MiscMath.hpp Thu Jan 11 21:30:37 2007
@@ -145,6 +145,9 @@
}
} // end void LagrangeInterpolation(vector, vector, const T, T&, T&)
+ template <class T>
+ T RSS (T aa, T bb, T cc);
+
/// Perform the root sum square of aa, bb
template <class T>
T RSS (T aa, T bb)

View File

@ -1,11 +0,0 @@
--- src/getopt.c.orig Thu Jan 11 21:34:50 2007
+++ src/getopt.c Thu Jan 11 21:36:24 2007
@@ -31,7 +31,7 @@
# include <config.h>
#endif
-#if defined(WIN32) || defined(_WIN32)
+#if defined(WIN32) || defined(_WIN32) || defined(__FreeBSD__)
#define HAVE_STRING_H 1
#endif

View File

@ -1,13 +1,19 @@
@comment $FreeBSD$
bin/CalcDOPs
bin/ConstellationList
bin/DDBase
bin/DOPcalc
bin/DiscFix
bin/EditRinex
bin/IonoBias
bin/NavMerge
bin/ORDPhaseParser
bin/PRSolve
bin/ResCor
bin/RinSum
bin/RinexDump
bin/TECMaps
bin/TIAPhaseParser
bin/ash2mdp
bin/ash2xyz
bin/ats2mdp
@ -15,11 +21,15 @@ bin/bc2sp3
bin/calgps
bin/compSatVis
bin/compStaVis
bin/convertSSEph
bin/daa
bin/dallandev
bin/ddGen
bin/ddPlot
bin/ddmerge
bin/ephdiff
bin/ephsum
bin/ffp
bin/fic2rin
bin/ficacheck
bin/ficafic
@ -27,10 +37,10 @@ bin/ficcheck
bin/ficdiff
bin/ficfica
bin/findMoreThan12
bin/lsfilt
bin/mallandev
bin/mdp2rinex
bin/mdpEdit
bin/mdpscreen
bin/mdpscreenx
bin/mdptool
bin/mergeFIC
bin/mergeRinMet
@ -38,20 +48,25 @@ bin/mergeRinNav
bin/mergeRinObs
bin/mergeSRI
bin/mpsolve
bin/nallandev
bin/navdmp
bin/navsum
bin/novaRinex
bin/oallandev
bin/ohadamarddev
bin/ordClock
bin/ordEdit
bin/ordGen
bin/ordLinEst
bin/ordPlot
bin/ordStats
bin/pff
bin/posInterp
bin/poscvt
bin/rfw
bin/rinexpvt
bin/rinexthin
bin/rmoutlier
bin/rmwcheck
bin/rmwdiff
bin/rnwcheck
@ -59,15 +74,28 @@ bin/rnwdiff
bin/rowcheck
bin/rowdiff
bin/rstats
bin/scale
bin/sp3version
bin/svvis
bin/tallandev
bin/testSSEph
bin/timeconvert
bin/trunc
bin/vecsol
bin/wheresat
include/gpstk/ANSITime.hpp
include/gpstk/ASConstant.hpp
include/gpstk/ATSData.hpp
include/gpstk/ATSStream.hpp
include/gpstk/Adler32.hpp
include/gpstk/AllanDeviation.hpp
include/gpstk/AlmOrbit.hpp
include/gpstk/Antenna.hpp
include/gpstk/AntexBase.hpp
include/gpstk/AntexData.hpp
include/gpstk/AntexHeader.hpp
include/gpstk/AntexReader.hpp
include/gpstk/AntexStream.hpp
include/gpstk/AshtechALB.hpp
include/gpstk/AshtechData.hpp
include/gpstk/AshtechEPB.hpp
@ -75,8 +103,13 @@ include/gpstk/AshtechMBEN.hpp
include/gpstk/AshtechPBEN.hpp
include/gpstk/AshtechStream.hpp
include/gpstk/AstronomicalFunctions.hpp
include/gpstk/AtmosphericDrag.hpp
include/gpstk/Axis.hpp
include/gpstk/AxisStyle.hpp
include/gpstk/BLQDataReader.hpp
include/gpstk/Bancroft.hpp
include/gpstk/Base64Encoder.hpp
include/gpstk/BaseDistribution.hpp
include/gpstk/BasicFramework.hpp
include/gpstk/BasicModel.hpp
include/gpstk/BasicShape.hpp
@ -84,15 +117,22 @@ include/gpstk/BinUtils.hpp
include/gpstk/BinexData.hpp
include/gpstk/BinexFilterOperators.hpp
include/gpstk/BinexStream.hpp
include/gpstk/Bitmap.hpp
include/gpstk/BivarStats.hpp
include/gpstk/BorderLayout.hpp
include/gpstk/CRC32.hpp
include/gpstk/Canvas.hpp
include/gpstk/CheckPRData.hpp
include/gpstk/Chi2Distribution.hpp
include/gpstk/CiraExponentialDrag.hpp
include/gpstk/Circle.hpp
include/gpstk/CivilTime.hpp
include/gpstk/ClockModel.hpp
include/gpstk/CodeBuffer.hpp
include/gpstk/CodeKalmanSolver.hpp
include/gpstk/CodeSmoother.hpp
include/gpstk/Color.hpp
include/gpstk/ColorMap.hpp
include/gpstk/CommandOption.hpp
include/gpstk/CommandOptionParser.hpp
include/gpstk/CommandOptionWithCommonTimeArg.hpp
@ -101,7 +141,9 @@ include/gpstk/CommandOptionWithTimeArg.hpp
include/gpstk/Comment.hpp
include/gpstk/CommonTime.hpp
include/gpstk/ComputeCombination.hpp
include/gpstk/ComputeDOP.hpp
include/gpstk/ComputeIURAWeights.hpp
include/gpstk/ComputeIonoModel.hpp
include/gpstk/ComputeLC.hpp
include/gpstk/ComputeLI.hpp
include/gpstk/ComputeLdelta.hpp
@ -111,29 +153,47 @@ include/gpstk/ComputeMelbourneWubbena.hpp
include/gpstk/ComputePC.hpp
include/gpstk/ComputePI.hpp
include/gpstk/ComputePdelta.hpp
include/gpstk/ComputeSatPCenter.hpp
include/gpstk/ComputeTropModel.hpp
include/gpstk/ComputeWindUp.hpp
include/gpstk/ConfDataReader.hpp
include/gpstk/ConfDataWriter.hpp
include/gpstk/CorrectCodeBiases.hpp
include/gpstk/CorrectObservables.hpp
include/gpstk/DCinternals.hpp
include/gpstk/DCBDataReader.hpp
include/gpstk/DDid.hpp
include/gpstk/DOP.hpp
include/gpstk/DataHeaders.hpp
include/gpstk/DataStatus.hpp
include/gpstk/DataStructures.hpp
include/gpstk/DayTime.hpp
include/gpstk/Decimate.hpp
include/gpstk/DeltaOp.hpp
include/gpstk/DiscCorr.hpp
include/gpstk/DoubleOp.hpp
include/gpstk/Dumper.hpp
include/gpstk/ECEF.hpp
include/gpstk/EGM96GravityModel.hpp
include/gpstk/ENUUtil.hpp
include/gpstk/EPSImage.hpp
include/gpstk/EarthBody.hpp
include/gpstk/EarthOceanTide.hpp
include/gpstk/EarthOrientation.hpp
include/gpstk/EarthPoleTide.hpp
include/gpstk/EarthSolidTide.hpp
include/gpstk/EclipsedSatFilter.hpp
include/gpstk/EllipsoidModel.hpp
include/gpstk/EngAlmanac.hpp
include/gpstk/EngEphemeris.hpp
include/gpstk/EngNav.hpp
include/gpstk/EphReader.hpp
include/gpstk/EphemerisRange.hpp
include/gpstk/Epoch.hpp
include/gpstk/EpochClockModel.hpp
include/gpstk/EpochDataStore.hpp
include/gpstk/Equation.hpp
include/gpstk/EquationOfMotion.hpp
include/gpstk/EquationSystem.hpp
include/gpstk/Exception.hpp
include/gpstk/Expression.hpp
include/gpstk/ExtractC1.hpp
@ -172,33 +232,51 @@ include/gpstk/FileSpec.hpp
include/gpstk/FileStore.hpp
include/gpstk/FileUtils.hpp
include/gpstk/Fillable.hpp
include/gpstk/ForceModel.hpp
include/gpstk/ForceModelList.hpp
include/gpstk/Frame.hpp
include/gpstk/GDCconfiguration.hpp
include/gpstk/GPSAlmanacStore.hpp
include/gpstk/GPSEllipsoid.hpp
include/gpstk/GPSEphemerisStore.hpp
include/gpstk/GPSEpochWeekSecond.hpp
include/gpstk/GPSGeoid.hpp
include/gpstk/GPSWeek.hpp
include/gpstk/GPSWeekSecond.hpp
include/gpstk/GPSWeekZcount.hpp
include/gpstk/GPSZcount.hpp
include/gpstk/GPSZcount29.hpp
include/gpstk/GPSZcount32.hpp
include/gpstk/GSatID.hpp
include/gpstk/GaussianDistribution.hpp
include/gpstk/GenXSequence.hpp
include/gpstk/Geodetic.hpp
include/gpstk/GeodeticFrames.hpp
include/gpstk/GeoidModel.hpp
include/gpstk/GraphicsConstants.hpp
include/gpstk/GravitationalDelay.hpp
include/gpstk/GridLayout.hpp
include/gpstk/HLayout.hpp
include/gpstk/HarrisPriesterDrag.hpp
include/gpstk/Helper.hpp
include/gpstk/IERS.hpp
include/gpstk/InOutFramework.hpp
include/gpstk/Integrator.hpp
include/gpstk/InterpolatedColorMap.hpp
include/gpstk/IonexBase.hpp
include/gpstk/IonexData.hpp
include/gpstk/IonexHeader.hpp
include/gpstk/IonexModel.hpp
include/gpstk/IonexStore.hpp
include/gpstk/IonexStream.hpp
include/gpstk/IonoModel.hpp
include/gpstk/IonoModelStore.hpp
include/gpstk/JGM3GravityModel.hpp
include/gpstk/JulianDate.hpp
include/gpstk/Keeper.hpp
include/gpstk/KeplerOrbit.hpp
include/gpstk/LEOSatOrbit.hpp
include/gpstk/LICSDetector.hpp
include/gpstk/LICSDetector2.hpp
include/gpstk/Layout.hpp
include/gpstk/Line.hpp
include/gpstk/LinePlot.hpp
include/gpstk/LinearClockModel.hpp
include/gpstk/LinearCombinations.hpp
include/gpstk/LoopedFramework.hpp
@ -232,14 +310,19 @@ include/gpstk/ModelObsFixedStation.hpp
include/gpstk/ModeledPR.hpp
include/gpstk/ModeledPseudorangeBase.hpp
include/gpstk/ModeledReferencePR.hpp
include/gpstk/MoonForce.hpp
include/gpstk/MoonPosition.hpp
include/gpstk/Msise00Drag.hpp
include/gpstk/NEDUtil.hpp
include/gpstk/NablaOp.hpp
include/gpstk/Namelist.hpp
include/gpstk/NavSatOrbit.hpp
include/gpstk/NetworkObsStreams.hpp
include/gpstk/NovatelData.hpp
include/gpstk/NovatelStream.hpp
include/gpstk/ORDEpoch.hpp
include/gpstk/ObsClockModel.hpp
include/gpstk/ObsEphReaderFramework.hpp
include/gpstk/ObsEpochMap.hpp
include/gpstk/ObsID.hpp
include/gpstk/ObsReader.hpp
@ -249,21 +332,32 @@ include/gpstk/OceanLoading.hpp
include/gpstk/OneFreqCSDetector.hpp
include/gpstk/PCSmoother.hpp
include/gpstk/PCodeConst.hpp
include/gpstk/PNG.hpp
include/gpstk/PRSolution.hpp
include/gpstk/PSImage.hpp
include/gpstk/PSImageBase.hpp
include/gpstk/Palette.hpp
include/gpstk/Path.hpp
include/gpstk/PhaseCodeAlignment.hpp
include/gpstk/PhaseWindup.hpp
include/gpstk/Plot.hpp
include/gpstk/PoleTides.hpp
include/gpstk/PolyFit.hpp
include/gpstk/Polygon.hpp
include/gpstk/Position.hpp
include/gpstk/PowerSum.hpp
include/gpstk/PreciseRange.hpp
include/gpstk/ProcessingClass.hpp
include/gpstk/ProcessingList.hpp
include/gpstk/ProcessingVector.hpp
include/gpstk/Pruner.hpp
include/gpstk/PvtStore.hpp
include/gpstk/RACRotation.hpp
include/gpstk/RTFileFrame.hpp
include/gpstk/Rectangle.hpp
include/gpstk/ReferenceFrames.hpp
include/gpstk/RelativityEffect.hpp
include/gpstk/RequireObservables.hpp
include/gpstk/RinexConverters.hpp
include/gpstk/RinexEphemerisStore.hpp
include/gpstk/RinexMetBase.hpp
@ -286,6 +380,7 @@ include/gpstk/RinexSatID.hpp
include/gpstk/RinexUtilities.hpp
include/gpstk/RobustStats.hpp
include/gpstk/RungeKutta4.hpp
include/gpstk/RungeKuttaFehlberg.hpp
include/gpstk/SEMAlmanacStore.hpp
include/gpstk/SEMBase.hpp
include/gpstk/SEMData.hpp
@ -301,26 +396,50 @@ include/gpstk/SP3SatID.hpp
include/gpstk/SP3Stream.hpp
include/gpstk/SRI.hpp
include/gpstk/SRIFilter.hpp
include/gpstk/SRIMatrix.hpp
include/gpstk/SRIleastSquares.hpp
include/gpstk/SVExclusionList.hpp
include/gpstk/SVGImage.hpp
include/gpstk/SVNumXRef.hpp
include/gpstk/SVPCodeGen.hpp
include/gpstk/SatArcMarker.hpp
include/gpstk/SatDataReader.hpp
include/gpstk/SatID.hpp
include/gpstk/SatOrbit.hpp
include/gpstk/SatOrbitPropagator.hpp
include/gpstk/SatOrbitStore.hpp
include/gpstk/SatPass.hpp
include/gpstk/ScatterPlot.hpp
include/gpstk/SeriesList.hpp
include/gpstk/SimpleFilter.hpp
include/gpstk/SimpleIURAWeight.hpp
include/gpstk/SimpleKalmanFilter.hpp
include/gpstk/SolarPosition.hpp
include/gpstk/SolarRadiationPressure.hpp
include/gpstk/SolarSystem.hpp
include/gpstk/SolidTides.hpp
include/gpstk/SolverBase.hpp
include/gpstk/SolverGeneral.hpp
include/gpstk/SolverLMS.hpp
include/gpstk/SolverPPP.hpp
include/gpstk/SolverPPPFB.hpp
include/gpstk/SolverWMS.hpp
include/gpstk/SourceID.hpp
include/gpstk/Spacecraft.hpp
include/gpstk/SpecialFunctions.hpp
include/gpstk/SphericalHarmonicGravity.hpp
include/gpstk/Splitter.hpp
include/gpstk/Stats.hpp
include/gpstk/StochasticModel.hpp
include/gpstk/StringUtils.hpp
include/gpstk/StrokeStyle.hpp
include/gpstk/StudentDistribution.hpp
include/gpstk/SunEarthSatGeometry.hpp
include/gpstk/SunForce.hpp
include/gpstk/SunPosition.hpp
include/gpstk/SuperKalmanFilter.hpp
include/gpstk/SurfacePlot.hpp
include/gpstk/Synchronize.hpp
include/gpstk/SystemTime.hpp
include/gpstk/TabularEphemerisStore.hpp
include/gpstk/Text.hpp
@ -333,10 +452,12 @@ include/gpstk/TimeTag.hpp
include/gpstk/Triple.hpp
include/gpstk/TropModel.hpp
include/gpstk/TypeID.hpp
include/gpstk/UTCTime.hpp
include/gpstk/UnixTime.hpp
include/gpstk/VDrawException.hpp
include/gpstk/VGImage.hpp
include/gpstk/VGState.hpp
include/gpstk/VLayout.hpp
include/gpstk/VPlotException.hpp
include/gpstk/ValidType.hpp
include/gpstk/Variable.hpp
include/gpstk/Vector.hpp
@ -344,6 +465,7 @@ include/gpstk/VectorBase.hpp
include/gpstk/VectorBaseOperators.hpp
include/gpstk/VectorOperators.hpp
include/gpstk/ViewerManager.hpp
include/gpstk/WGS84Ellipsoid.hpp
include/gpstk/WGS84Geoid.hpp
include/gpstk/WeightBase.hpp
include/gpstk/WxObsMap.hpp
@ -366,26 +488,32 @@ include/gpstk/gps_constants.hpp
include/gpstk/gpstkplatform.h
include/gpstk/icd_200_constants.hpp
include/gpstk/index.hpp
include/gpstk/logstream.hpp
include/gpstk/mergePCodeWords.h
include/gpstk/miscdefs.hpp
include/gpstk/miscenum.hpp
include/gpstk/plottypes.hpp
include/gpstk/random.hpp
include/gpstk/regex.h
include/gpstk/stl_helpers.hpp
include/gpstk/xregex2.h
lib/libgeodyn.a
lib/libgeodyn.so
lib/libgeodyn.so.17
lib/libgeomatics.a
lib/libgeomatics.so
lib/libgeomatics.so.15
lib/libgeomatics.so.17
lib/libgpstk.a
lib/libgpstk.so
lib/libgpstk.so.15
lib/libgpstk.so.17
lib/libprocframe.a
lib/libprocframe.so
lib/libprocframe.so.15
lib/libprocframe.so.17
lib/librxio.a
lib/librxio.so
lib/librxio.so.15
lib/librxio.so.17
lib/libvdraw.a
lib/libvdraw.so
lib/libvdraw.so.17
lib/libvplot.a
lib/libvplot.so
lib/libvplot.so.15
lib/libvplot.so.17
@dirrm include/gpstk