Add ppgen 1.0, a program to generate random passphrases from dictionary

words, with a desired amount of entropy.

Obtained from:	OpenBSD
This commit is contained in:
Kris Kennaway 2001-08-23 07:03:56 +00:00
parent a69ee4a7f9
commit 34d9284dd3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46684
8 changed files with 67 additions and 0 deletions

View File

@ -140,6 +140,7 @@
SUBDIR += pktsuckers
SUBDIR += portscanner
SUBDIR += portsentry
SUBDIR += ppgen
SUBDIR += pscan
SUBDIR += py-amkCrypto
SUBDIR += py-fchksum

25
security/ppgen/Makefile Normal file
View File

@ -0,0 +1,25 @@
# Ports collection makefile for: ppgen
# Date created: 22 Aug 2001
# Whom: Kris Kennaway <kris@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= ppgen
PORTVERSION= 1.0
CATEGORIES= security
MASTER_SITES= ftp://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/ppgen/
DISTFILES= ${DISTNAME}.tar.gz en.gz
EXTRACT_ONLY= ${DISTNAME}.tar.gz
MAINTAINER= kris@FreeBSD.org
GNU_CONFIGURE= yes
MAN1= ppgen.1
post-install:
${MKDIR} ${PREFIX}/share/ppgen
${GZIP_CMD} -dc ${DISTDIR}/en.gz > ${PREFIX}/share/ppgen/en
.include <bsd.port.mk>

2
security/ppgen/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (en.gz) = 2a84c2d569c334dee1770e49de14455b
MD5 (ppgen-1.0.tar.gz) = 7544cda944428cfc2d17432adda25dc3

View File

@ -0,0 +1,11 @@
--- ppg_random.c.orig Tue Aug 29 04:19:01 1995
+++ ppg_random.c Sat Aug 12 20:14:39 2000
@@ -109,7 +109,7 @@ pgp_rand_really_init()
int i;
- SRAND(time(NULL)^getpid());
+ srandomdev();
for (i = 0; i < cachesize; i++) {
/* Conservatively, take what RAND() returns and fold it down

View File

@ -0,0 +1,10 @@
--- ppgen.c.orig Tue Aug 29 05:10:45 1995
+++ ppgen.c Sat Aug 12 19:55:51 2000
@@ -29,6 +29,7 @@
#else
char *optarg;
#endif
+#include <errno.h>
#include "ppg_random.h"

View File

@ -0,0 +1 @@
Secure passphrase generator

14
security/ppgen/pkg-descr Normal file
View File

@ -0,0 +1,14 @@
From the author (Michael Shields <shields@tembel.org>):
ppgen generates passphrases using strings of words, long enough to have
an arbitrary level of entropy. It can use any dictionary and the best
available source of randomness, including PGP's cryptographic RNG if you
have version 2.6.2. It is written in portable C, and it is fairly fast.
You can use ppgen to generate passphrases whenever you have a program that
accepts long passwords. I use it for Kerberos and for local passwords
(I use the FreeBSD MD5-based crypt(3), not the standard limited Unix one),
and for my PGP keyring.
Because ppgen is so simple, it can also easily be used by passwd(1)
or adduser(1) programs to choose passwords for users.

3
security/ppgen/pkg-plist Normal file
View File

@ -0,0 +1,3 @@
bin/ppgen
share/ppgen/en
@dirrm share/ppgen