- Switch from BROKEN to IGNORE

- Add OPTIONS for X11

PR:		ports/89300
Submitted by:	Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com> (maintainer)
This commit is contained in:
Pav Lucistnik 2005-11-22 22:19:46 +00:00
parent d3e01bc865
commit 348d185b7d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=149119
3 changed files with 49 additions and 10 deletions

View File

@ -3,30 +3,43 @@
# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
#
# $FreeBSD$
# $Id: Makefile,v 1.8 2005/11/19 23:21:24 itetcu Rel $
#
PORTNAME= bsdav
PORTVERSION= 1.3
CATEGORIES= multimedia
MASTER_SITES= http://www.jakemsr.com/bsdav/ \
http://people.tecnik93.com/~itetcu/FreeBSD/ports/${PORTNAME}/sources/
http://people.tecnik93.com/~itetcu/FreeBSD/ports/${PORTNAME}/sources/
MAINTAINER= itetcu@people.tecnik93.com
COMMENT= BSD native set of programs for audio and video reading and writing
BROKEN= Does not compile
IGNORE= does not work. We need to import bktv patches from OpenBSD to make it work
INSTALLS_SHLIB= yes
MAN1= audiorec.1 bktrrec.1 bsdavdemux.1 bsdavrec.1 btv.1 tunerctl.1 avplay.1 \
bktrplay.1 bsdavplay.1
MAN5= bsdav.5
MAN1= audiorec.1 bktrrec.1 bsdavdemux.1 bsdavrec.1 btv.1 tunerctl.1
MAN5= bsdav.5
PORTDOCS= README
OPTIONS= X11 "Build and install player progs (brings X libs)" on
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_X11)
USE_XLIB= yes
MAN1+= avplay.1 bktrplay.1 bsdavplay.1
PLIST_SUB+= X11=""
.else
MAKE_ENV+= NO_X11=true
PLIST_SUB+= X11="@comment "
.endif
.if !( defined(NO_PORTDOCS) || defined(NOPORTDOCS) )
PORTDOCS= README
post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -0,0 +1,26 @@
--- btv.dist Thu Aug 11 08:37:38 2005
+++ btv Sat Nov 5 22:44:15 2005
@@ -20,7 +20,7 @@
: ${CHANSET=nabcst}
-function usage
+usage()
{
echo "Usage: tv [-vm] [-c channel] [-d directory] [-n norm]"
echo " [-r command]"
@@ -34,8 +34,13 @@
V=""
RET=0
+args=`getopt c:d:mn:r:v $*`
+if [ $? -ne 0 ]
+then
+ usage
+fi
+set -- ${args}
-set -- `getopt c:d:mn:r:v $*` || usage
for i
do

View File

@ -1,9 +1,9 @@
bin/audiorec
bin/avplay
bin/bktrplay
%%X11%%bin/avplay
%%X11%%bin/bktrplay
bin/bktrrec
bin/bsdavdemux
bin/bsdavplay
%%X11%%bin/bsdavplay
bin/bsdavrec
bin/btv
bin/tunerctl