Add p5-Gimp, it's perl binding for gimp.

This commit is contained in:
Vanilla I. Shu 2001-03-14 22:16:41 +00:00
parent cb3fe7de93
commit 346d17e89d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=39857
8 changed files with 170 additions and 0 deletions

View File

@ -149,6 +149,7 @@
SUBDIR += p5-GD-Graph
SUBDIR += p5-GD-Graph3d
SUBDIR += p5-GD-TextUtil
SUBDIR += p5-Gimp
SUBDIR += p5-Image-Size
SUBDIR += p5-chart
SUBDIR += panorama

49
graphics/p5-Gimp/Makefile Normal file
View File

@ -0,0 +1,49 @@
# New ports collection makefile for: p5-Gimp
# Date created: Dec 22 2000
# Whom: vanilla@FreeBSD.org
#
# $FreeBSD$
#
PORTNAME= Gimp
PORTVERSION= 1.21
CATEGORIES= graphics perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Gimp
PKGNAMEPREFIX= p5-
MAINTAINER= vanilla@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Gtk.pm:${PORTSDIR}/x11-toolkits/p5-Gtk \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/PDL.pm:${PORTSDIR}/math/PDL \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
LIB_DEPENDS= gimp.1:${PORTSDIR}/graphics/gimp1
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_GTK= yes
USE_PERL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lintl"
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN1= embedxpm.1 \
scm2perl.1 \
scm2scm.1 \
xcftopnm.1
MAN3= Gimp.3 \
Gimp::Compat.3 \
Gimp::Data.3 \
Gimp::Feature.3 \
Gimp::Fu.3 \
Gimp::Lib.3 \
Gimp::Module.3 \
Gimp::Net.3 \
Gimp::OO.3 \
Gimp::PDL.3 \
Gimp::Pixel.3 \
Gimp::Pod.3 \
Gimp::UI.3 \
Gimp::Util.3 \
Gimp::basewidget.3
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (Gimp-1.21.tar.gz) = d66b1876ea7317e17f3ebc5513855f9e

View File

@ -0,0 +1,11 @@
--- Net/Makefile.PL.orig Fri Dec 22 07:12:42 2000
+++ Net/Makefile.PL Fri Dec 22 07:20:48 2000
@@ -15,7 +15,7 @@
'NAME' => 'Gimp::Net',
'VERSION_FROM' => '../Gimp.pm',
#'INC' => "$INC1 $CPPFLAGS $pdl_inc $cfg{GLIB_CFLAGS} $CFLAGS",
- 'INC' => "$INC1 $CPPFLAGS $pdl_inc $CFLAGS",
+ 'INC' => "$INC1 $CPPFLAGS $pdl_inc $CFLAGS -I/usr/local/include",
'DEFINE' => "$DEFINE1 $DEFS",
'TYPEMAPS' => ["$topdir/typemap",@pdl_typemaps],
#dynamic_lib => { OTHERLDFLAGS => "$LDFLAGS $LIBS $cfg{GLIB_LIBS}" },

View File

@ -0,0 +1,10 @@
--- config.pl.in.orig Fri Dec 22 07:18:01 2000
+++ config.pl.in Fri Dec 22 07:18:29 2000
@@ -92,7 +92,7 @@
$GIMP_LIBS_NOUI =~ s%\$topdir%$topdir%g;
# $...1 variables should be put in front of the corresponding MakeMaker values.
-$INC1 = "-I$topdir";
+$INC1 = "-I$topdir -I\$(PERL_INC)";
$DEFINE1 = $IN_GIMP ? "-DIN_GIMP" : "";
$DEFINE1 = " -Ddatadir=\"\\\"".expand($datadir)."\\\"\"";

View File

@ -0,0 +1 @@
A perl5 module for writing Gimp extension

View File

@ -0,0 +1,3 @@
Gimp - Perl extension for writing Gimp Extension/Plug-ins/Load & Save-Handlers.
WWW: http://www.goof.com/pcg/marc/gimp.html

View File

@ -0,0 +1,94 @@
bin/embedxpm
bin/gimpdoc
bin/scm2perl
bin/scm2scm
bin/xcftopnm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp/Compat.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp/Config.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp/Data.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp/Feature.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp/Fu.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp/Lib.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp/Module.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp/Net.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp/OO.pod
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp/PDL.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp/Pixel.pod
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp/Pod.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp/UI.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp/Util.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp/basewidget.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gimp/.packlist
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gimp/Gimp.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gimp/Gimp.so
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gimp/Lib/Lib.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gimp/Lib/Lib.so
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gimp/Net/Net.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gimp/Net/Net.so
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gimp/UI/UI.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gimp/UI/UI.so
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gimp/UI
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gimp/Net
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gimp/Lib
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gimp
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gimp
@cwd %%X11BASE%%
libexec/gimp/1.2/plug-ins/PDB
libexec/gimp/1.2/plug-ins/Perl-Server
libexec/gimp/1.2/plug-ins/animate_cells
libexec/gimp/1.2/plug-ins/avi
libexec/gimp/1.2/plug-ins/blended2
libexec/gimp/1.2/plug-ins/blowinout
libexec/gimp/1.2/plug-ins/border
libexec/gimp/1.2/plug-ins/bricks
libexec/gimp/1.2/plug-ins/burst
libexec/gimp/1.2/plug-ins/centerguide
libexec/gimp/1.2/plug-ins/clear_alpha
libexec/gimp/1.2/plug-ins/colorhtml
libexec/gimp/1.2/plug-ins/dataurl
libexec/gimp/1.2/plug-ins/ditherize
libexec/gimp/1.2/plug-ins/dust
libexec/gimp/1.2/plug-ins/fade-alpha
libexec/gimp/1.2/plug-ins/fire
libexec/gimp/1.2/plug-ins/fit-text
libexec/gimp/1.2/plug-ins/font_table
libexec/gimp/1.2/plug-ins/frame_filter
libexec/gimp/1.2/plug-ins/frame_reshuffle
libexec/gimp/1.2/plug-ins/glowing_steel
libexec/gimp/1.2/plug-ins/goldenmean
libexec/gimp/1.2/plug-ins/gouge
libexec/gimp/1.2/plug-ins/guide_remove
libexec/gimp/1.2/plug-ins/guidegrid
libexec/gimp/1.2/plug-ins/guides_to_selection
libexec/gimp/1.2/plug-ins/image_tile
libexec/gimp/1.2/plug-ins/innerbevel
libexec/gimp/1.2/plug-ins/layerfuncs
libexec/gimp/1.2/plug-ins/logulator
libexec/gimp/1.2/plug-ins/map_to_gradient
libexec/gimp/1.2/plug-ins/miff
libexec/gimp/1.2/plug-ins/mirrorsplit
libexec/gimp/1.2/plug-ins/parasite-editor
libexec/gimp/1.2/plug-ins/perlcc
libexec/gimp/1.2/plug-ins/perlotine
libexec/gimp/1.2/plug-ins/pixelmap
libexec/gimp/1.2/plug-ins/prep4gif
libexec/gimp/1.2/plug-ins/randomart1
libexec/gimp/1.2/plug-ins/randomblends
libexec/gimp/1.2/plug-ins/repdup
libexec/gimp/1.2/plug-ins/roundsel
libexec/gimp/1.2/plug-ins/scratches
libexec/gimp/1.2/plug-ins/sethspin
libexec/gimp/1.2/plug-ins/stampify
libexec/gimp/1.2/plug-ins/stamps
libexec/gimp/1.2/plug-ins/terral_text
libexec/gimp/1.2/plug-ins/tex-to-float
libexec/gimp/1.2/plug-ins/translogo
libexec/gimp/1.2/plug-ins/view3d
libexec/gimp/1.2/plug-ins/warp-sharp
libexec/gimp/1.2/plug-ins/webify
libexec/gimp/1.2/plug-ins/windify
libexec/gimp/1.2/plug-ins/xachlego
libexec/gimp/1.2/plug-ins/xachshadow
libexec/gimp/1.2/plug-ins/xachvision
libexec/gimp/1.2/plug-ins/yinyang