Update to 0.3
This commit is contained in:
parent
7e62ac9eac
commit
345c24c498
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=94898
@ -6,16 +6,10 @@
|
||||
#
|
||||
|
||||
PORTNAME= passepartout
|
||||
PORTVERSION= 0.2
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 0.3
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= http://www.stacken.kth.se/project/pptout/files/
|
||||
|
||||
PATCH_SITES= ${MASTER_SITES}
|
||||
PATCHFILES= passepartout-0.2-assert.patch \
|
||||
passepartout-0.2-thread.patch
|
||||
PATCH_DIST_STRIP= -p1
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= DTP application for X
|
||||
|
||||
@ -27,9 +21,11 @@ USE_BZIP2= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_GNOME= gnometarget gnomehack
|
||||
USE_GNOME= gnomehack gnometarget
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
MAN= xml2ps.1 passepartout.1x
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
@ -39,7 +35,7 @@ EXTRA_PATCHES= ${PATCHDIR}/extra-patch-old_cxx
|
||||
# Fix for recent libxml++ API change
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC}/src/pptout -name *.cc \
|
||||
| grep -v -E 'pagesel|undodialog' \
|
||||
| ${GREP} -v -E 'pagesel|undodialog' \
|
||||
| ${XARGS} ${REINPLACE_CMD} \
|
||||
-e 's|add_attribute|set_attribute|' \
|
||||
-e 's|add_content|add_child_text|'
|
||||
|
@ -1,3 +1 @@
|
||||
MD5 (passepartout-0.2.tar.bz2) = 92df4384de96b308690557cd4d11339e
|
||||
MD5 (passepartout-0.2-assert.patch) = aa79d1566167ce6b371450c54f0d2f20
|
||||
MD5 (passepartout-0.2-thread.patch) = a46a1f8dffb27c22f8e8964cd208d022
|
||||
MD5 (passepartout-0.3.tar.bz2) = 84ca77ac477b3ae53b841023e78adc44
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- src/pptout/filewatcher.h.orig Sun Nov 2 11:53:06 2003
|
||||
+++ src/pptout/filewatcher.h Sun Nov 2 11:53:23 2003
|
||||
--- src/util/filewatcher.h.orig Sun Nov 2 11:53:06 2003
|
||||
+++ src/util/filewatcher.h Sun Nov 2 11:53:23 2003
|
||||
@@ -5,6 +5,7 @@
|
||||
///
|
||||
#include <sigc++/sigc++.h>
|
||||
|
@ -1,12 +1,16 @@
|
||||
--- src/util/filesys.cc.orig Fri Oct 31 20:53:31 2003
|
||||
+++ src/util/filesys.cc Fri Oct 31 20:55:05 2003
|
||||
@@ -5,7 +5,9 @@
|
||||
#include "stringutil.h"
|
||||
--- src/util/filesys.cc.orig Thu Oct 30 22:42:31 2003
|
||||
+++ src/util/filesys.cc Fri Nov 21 16:31:15 2003
|
||||
@@ -6,11 +6,13 @@
|
||||
#include "os.h"
|
||||
#include <unistd.h>
|
||||
+#include <errno.h>
|
||||
#include <stdexcept>
|
||||
+#include <memory>
|
||||
#include "defines.h"
|
||||
#ifndef HAVE_MKDTEMP
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
#endif
|
||||
+#include <errno.h>
|
||||
|
||||
using std::string;
|
||||
|
||||
|
@ -1,9 +1,9 @@
|
||||
--- src/xml2ps/pagedstream.cc.orig Sun Nov 2 11:48:29 2003
|
||||
+++ src/xml2ps/pagedstream.cc Sun Nov 2 11:49:54 2003
|
||||
@@ -3,6 +3,8 @@
|
||||
#include <fstream>
|
||||
--- src/xml2ps/pagedstream.cc.orig Thu Nov 20 04:13:54 2003
|
||||
+++ src/xml2ps/pagedstream.cc Fri Nov 21 16:32:48 2003
|
||||
@@ -7,6 +7,8 @@
|
||||
#include <sstream>
|
||||
#include <iostream>
|
||||
#include <vector>
|
||||
+#include <exception>
|
||||
+#include <memory>
|
||||
|
||||
|
@ -1,10 +1,10 @@
|
||||
bin/pptout
|
||||
bin/passepartout
|
||||
bin/xml2ps
|
||||
share/doc/passepartout/README
|
||||
share/doc/passepartout/docbook.xslt
|
||||
share/doc/passepartout/examples/docbook.xslt
|
||||
share/doc/passepartout/examples/example1.html
|
||||
share/doc/passepartout/examples/example1.ppt
|
||||
share/doc/passepartout/examples/example1.pp
|
||||
share/doc/passepartout/examples/gradient.eps
|
||||
share/doc/passepartout/examples/hippie.jpg
|
||||
share/doc/passepartout/examples/hline.eps
|
||||
@ -19,7 +19,7 @@ share/doc/passepartout/nsfaq.html
|
||||
share/doc/passepartout/nsfaq.xml
|
||||
share/doc/passepartout/pptout-sv.eps
|
||||
share/doc/passepartout/users_guide.html
|
||||
share/doc/passepartout/users_guide.ppt
|
||||
share/doc/passepartout/users_guide.pp
|
||||
share/doc/passepartout/users_guide.xml
|
||||
share/doc/passepartout/xhtml.xslt
|
||||
share/xml/passepartout/docbook.xslt
|
||||
|
Loading…
Reference in New Issue
Block a user