Don't use libbsd & libutil on package.

Agreed by:	maintainer
This commit is contained in:
Vanilla I. Shu 1998-09-05 18:22:17 +00:00
parent bac996df49
commit 345084608f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=13016
4 changed files with 208 additions and 25 deletions

View File

@ -1,5 +1,5 @@
--- ../../SSLtelnet-0.11/Makefile Sat Aug 2 16:08:25 1997
+++ ./Makefile Sun Mar 29 18:28:44 1998
--- Makefile.orig Sat Aug 2 15:08:25 1997
+++ Makefile Wed Sep 2 12:53:13 1998
@@ -47,7 +47,7 @@
# the location where SSLeay is installed ...
@ -55,3 +55,14 @@
cd $(INSTALLTOP)/certs; \
ssleay req -new -x509 -nodes -days 365 -out telnetd.pem -keyout telnetd.pem; \
ln -s telnetd.pem `ssleay x509 -noout -hash < telnetd.pem`.0 ;\
--- lib/Makefile.orig Wed Sep 2 13:11:39 1998
+++ lib/Makefile Wed Sep 2 13:11:49 1998
@@ -1,7 +1,7 @@
#SUBDIRS= gmp-1.2 kerberosIV/krb libbsd libdes/des libpk libtelnet libutil
SUBDIRS= gmp-1.3.2 libbsd libpk libtelnet libutil
-SUBDIRS= libbsd libtelnet libutil
+SUBDIRS= libtelnet
all:
@for i in $(SUBDIRS); \

View File

@ -1,9 +1,90 @@
--- ../../SSLtelnet-0.11/lib/libbsd/Makefile Fri Jun 30 09:05:37 1995
+++ ./lib/libbsd/Makefile Sun Mar 29 14:31:30 1998
@@ -1,5 +1,5 @@
LIB= bsd
-CFLAGS= -DLIBC_SCCS -I../../include
+CFLAGS+= -DLIBC_SCCS -I$(PREFIX)/include
OBJS= getenv.o herror.o setenv.o strerror.o getpass.o inet_addr.o
--- telnetd/pathnames.h.orig Sat Jun 15 17:26:10 1996
+++ telnetd/pathnames.h Wed Sep 2 12:53:18 1998
@@ -53,7 +53,7 @@
/* I'm working on having this work as is with SunOS 5.x */
#ifndef USE_SRALOGIN
#undef _PATH_LOGIN
-#ifdef __bsdi__
+#if defined(__bsdi__) || defined(__FreeBSD__)
#define _PATH_LOGIN "/usr/bin/login"
#else
#define _PATH_LOGIN "/bin/login"
--- telnetd/sys_term.c.orig Wed Sep 2 12:53:19 1998
+++ telnetd/sys_term.c Wed Sep 2 12:53:22 1998
@@ -739,7 +739,7 @@
else
termbuf.lflags &= ~LPASS8;
#else
- if (on) {
+ if (1) {
termbuf.c_iflag &= ~ISTRIP;
} else {
termbuf.c_iflag |= ISTRIP;
--- telnetd/telnetd.c.orig Sat Aug 2 14:40:48 1997
+++ telnetd/telnetd.c Wed Sep 2 12:53:21 1998
@@ -140,7 +140,7 @@
highpty = getnpty();
#endif /* CRAY */
lib${LIB}.a: ${OBJS}
- while ((ch = getopt(argc, argv, "d:a:e:lhnr:I:D:B:sS:a:X:z:")) != EOF) {
+ while ((ch = getopt(argc, argv, "d:a:e:lhnr:I:D:B:sS:a:X:z:q")) != EOF) {
switch(ch) {
#ifdef USE_SSL
@@ -203,6 +203,11 @@
}
break;
+
+ case 'q':
+ ssl_quiet_flag = 1;
+ break;
+
#endif /* USE_SSL */
#ifdef AUTHENTICATE
@@ -584,7 +589,7 @@
#ifdef USE_SSL
/* might as well output something useful here ... */
fprintf(stderr, " [-z ssl] [-z secure] [-z debug] [-z verify=int]\n\t");
- fprintf(stderr, " [-z cert=file] [-z key=file]\n\t");
+ fprintf(stderr, " [-z cert=file] [-z key=file] [-q]\n\t");
#endif /* USE_SSL */
fprintf(stderr, " [port]\n");
exit(1);
@@ -656,7 +661,12 @@
fflush(stderr);
}
- fatal(net,"[SSL required - connection rejected]");
+ if (ssl_quiet_flag) {
+ sleep(1);
+ exit(1);
+ }
+ else
+ fatal(net,"[SSL required - connection rejected]");
}
}
--- telnetd/Makefile.orig Tue Sep 12 10:22:51 1995
+++ telnetd/Makefile Fri Sep 4 15:10:46 1998
@@ -4,16 +4,13 @@
PROG= telnetd
-CFLAGS= -DTERMCAP -DKLUDGELINEMODE -DUSE_TERMIO -DAUTHENTICATE -DUSE_SSL \
- -DDIAGNOSTICS -DFILIO_H \
- -I../lib -I../lib/libbsd/include \
+CFLAGS+= -DTERMCAP -DKLUDGELINEMODE -DUSE_TERMIO -DAUTHENTICATE -DUSE_SSL \
+ -DDIAGNOSTICS -DFILIO_H -I../lib -I../lib/libbsd/include \
-I$(SSLTOP)/include
LIBS= ../lib/libtelnet/libtelnet.a \
- ../lib/libbsd/libbsd.a \
- ../lib/libutil/libutil.a \
$(SSLTOP)/lib/libssl.a \
- $(SSLTOP)/lib/libcrypto.a
+ $(SSLTOP)/lib/libcrypto.a -lutil
# $(SSLTOP)/lib/libdes.a
OBJS= authenc.o global.o slc.o state.o sys_term.o telnetd.o \

View File

@ -1,11 +1,30 @@
--- ../../SSLtelnet-0.11/lib/libbsd/getpass.c Sat Jun 15 18:28:30 1996
+++ ./lib/libbsd/getpass.c Sun Mar 29 14:30:01 1998
@@ -6,7 +6,7 @@
--- telnet/sys_bsd.c.orig Sat Aug 2 14:18:09 1997
+++ telnet/sys_bsd.c Wed Sep 2 12:53:22 1998
@@ -580,7 +580,7 @@
else
lmode &= ~LPASS8;
#else
- if (f & MODE_INBIN)
+ if (1)
tmp_tc.c_iflag &= ~ISTRIP;
else
tmp_tc.c_iflag |= ISTRIP;
--- telnet/Makefile.orig Sat Aug 2 13:30:16 1997
+++ telnet/Makefile Wed Sep 2 13:20:26 1998
@@ -6,14 +6,12 @@
PROG= telnet
#define TTY "/dev/tty"
-#if !defined(HPUX) && !defined(__bsdi__)
+#if !defined(HPUX) && !defined(__bsdi__) && !defined(__FreeBSD__)
-CFLAGS= -DKLUDGELINEMODE -DUSE_TERMIO -DAUTHENTICATE -DUSE_SSL \
- -DFILIO_H \
- -I../lib/libbsd/include -I../lib \
+CFLAGS+= -DKLUDGELINEMODE -DUSE_TERMIO -DAUTHENTICATE -DUSE_SSL \
+ -DFILIO_H -I../lib -I../lib/libbsd/include \
-I$(SSLTOP)/include
/* under HPUX use the "system" supplied routine as I cannot
* be bothered to "port" this code at the moment --tjh
LIBS= ../lib/libtelnet/libtelnet.a \
- ../lib/libbsd/libbsd.a \
$(SSLTOP)/lib/libssl.a \
$(SSLTOP)/lib/libcrypto.a
# $(SSLTOP)/lib/libdes.a

View File

@ -1,11 +1,83 @@
--- ../../SSLtelnet-0.11/lib/libbsd/inet_addr.c Sat Jun 15 18:28:34 1996
+++ ./lib/libbsd/inet_addr.c Sun Mar 29 14:33:07 1998
@@ -37,7 +37,7 @@
--- lib/libtelnet/sslapp.c.orig Sat Aug 2 13:52:35 1997
+++ lib/libtelnet/sslapp.c Wed Sep 2 12:53:21 1998
@@ -31,6 +31,7 @@
int ssl_cert_required=0;
int ssl_verbose_flag=0;
int ssl_disabled_flag=0;
+int ssl_quiet_flag=0;
char *ssl_cert_file=NULL;
char *ssl_key_file=NULL;
char *ssl_cipher_list=NULL;
@@ -59,7 +60,7 @@
* a clean interface for doing things
*/
if (ssl_debug_flag)
- BIO_printf(bio_err,"SSL_DEBUG_FLAG on\n");
+ BIO_printf(bio_err,"SSL_DEBUG_FLAG on\r\n");
#if defined(__GNUC__)
-#if defined(__bsdi__) || defined(SUNOS) && !defined(SOLARIS2)
+#if defined(__bsdi__) || defined(SUNOS) && !defined(SOLARIS2) || defined(__FreeBSD__)
/* init things so we will get meaningful error messages
@@ -79,15 +80,18 @@
if (SSL_CTX_need_tmp_RSA(ssl_ctx)) {
RSA *rsa;
/* nothing required for SunOS 4.1.x */
- BIO_printf(bio_err,"Generating temp (512 bit) RSA key ...\n");
+ if (!ssl_quiet_flag)
+ BIO_printf(bio_err,"Generating temp (512 bit) RSA key ...\r\n");
rsa=RSA_generate_key(512,RSA_F4,NULL);
- BIO_printf(bio_err,"Generation of temp (512 bit) RSA key done\n");
+ if (!ssl_quiet_flag)
+ BIO_printf(bio_err,"Generation of temp (512 bit) RSA key done\r\n");
- if (!SSL_CTX_set_tmp_rsa(ssl_ctx,rsa)) {
- BIO_printf(bio_err,"Failed to assign generated temp RSA key!\n");
+ if (!SSL_CTX_set_tmp_rsa(ssl_ctx,rsa) && !ssl_quiet_flag) {
+ BIO_printf(bio_err,"Failed to assign generated temp RSA key!\r\n");
}
RSA_free(rsa);
- BIO_printf(bio_err,"Assigned temp (512 bit) RSA key\n");
+ if (!ssl_quiet_flag)
+ BIO_printf(bio_err,"Assigned temp (512 bit) RSA key\r\n");
}
}
@@ -161,14 +165,14 @@
int ret;
{
if (where==SSL_CB_CONNECT_LOOP) {
- BIO_printf(bio_err,"SSL_connect:%s %s\n",
+ BIO_printf(bio_err,"SSL_connect:%s %s\r\n",
SSL_state_string(s),SSL_state_string_long(s));
} else if (where==SSL_CB_CONNECT_EXIT) {
if (ret == 0) {
- BIO_printf(bio_err,"SSL_connect:failed in %s %s\n",
+ BIO_printf(bio_err,"SSL_connect:failed in %s %s\r\n",
SSL_state_string(s),SSL_state_string_long(s));
} else if (ret < 0) {
- BIO_printf(bio_err,"SSL_connect:error in %s %s\n",
+ BIO_printf(bio_err,"SSL_connect:error in %s %s\r\n",
SSL_state_string(s),SSL_state_string_long(s));
}
}
--- lib/libtelnet/sslapp.h.orig Sat Aug 2 13:56:21 1997
+++ lib/libtelnet/sslapp.h Wed Sep 2 12:53:22 1998
@@ -53,6 +53,7 @@
extern int ssl_disabled_flag;
extern int ssl_cert_required;
extern int ssl_certsok_flag;
+extern int ssl_quiet_flag;
extern char *ssl_log_file;
extern char *ssl_cert_file;
--- lib/libtelnet/Makefile.orig Sat Aug 2 13:31:37 1997
+++ lib/libtelnet/Makefile Wed Sep 2 13:16:15 1998
@@ -12,8 +12,7 @@
#CFLAGS= -DENCRYPT -DAUTHENTICATE -DSRA -DUSE_SSL -DDES_ENCRYPTION \
#-I../libbsd/include -I../libpk
-CFLAGS= -DAUTHENTICATE -DUSE_SSL \
--I../libbsd/include -I$(SSLTOP)/include -I../libpk -g
+CFLAGS+= -DAUTHENTICATE -DUSE_SSL -I$(SSLTOP)/include -I../libbsd/include
lib${LIB}.a: ${OBJS}
echo building standard ${LIB} library