Add p5-Smart-Comments.

Smart comments provide an easy way to insert debugging and tracking code into
a program. They can report the value of a variable, track the progress of a
loop, and verify that particular assertions are true.

Best of all, when you're finished debugging, you don't have to remove them.
Simply commenting out the use Smart::Comments line turns them back into
regular comments. Leaving smart comments in your code is smart because if you
needed them once, you'll almost certainly need them again later.

Author: Damian Conway <DCONWAY@cpan.org>

WWW: http://search.cpan.org/dist/Smart-Comments/

PR:		ports/81476
Submitted by:	Aaron Dalton <aaron@daltons.ca>
This commit is contained in:
Jean-Yves Lefort 2005-05-26 18:44:26 +00:00
parent 3ddd61a421
commit 343f60a740
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=136194
6 changed files with 72 additions and 0 deletions

View File

@ -1054,6 +1054,7 @@
SUBDIR += p5-Shape
SUBDIR += p5-Shell-Base
SUBDIR += p5-Shell-Parser
SUBDIR += p5-Smart-Comments
SUBDIR += p5-Sort-ArrayOfArrays
SUBDIR += p5-Sort-Tree
SUBDIR += p5-Sort-Versions

View File

@ -0,0 +1,38 @@
# New ports collection makefile for: p5-Smart-Comments
# Date created: 24 May 2005
# Whom: Aaron Dalton <aaron@daltons.ca>
#
# $FreeBSD$
#
PORTNAME= Smart-Comments
PORTVERSION= 1.0.1
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/D/DC/DCONWAY
PKGNAMEPREFIX= p5-
MAINTAINER= aaron@daltons.ca
COMMENT= Comments that do more than just sit there
BUILD_DEPENDS= ${SITE_PERL}/Filter/Simple.pm:${PORTSDIR}/textproc/p5-Filter-Simple \
${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced \
${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
${SITE_PERL}/${PERL_ARCH}/List/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
${SITE_PERL}/${PERL_ARCH}/Data/Dumper.pm:${PORTSDIR}/devel/p5-Data-Dumper
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= Smart::Comments.3
post-patch:
@${FIND} ${WRKSRC} -type f -name '*.orig' -exec ${RM} -f {} \;
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
IGNORE= Perl5.6 or greater required. Please install lang/perl5 or lang/perl5.8
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,2 @@
MD5 (Smart-Comments-1.0.1.tar.gz) = 387ce88a5aba1a7a9c49d0dbc343365c
SIZE (Smart-Comments-1.0.1.tar.gz) = 12704

View File

@ -0,0 +1,11 @@
--- lib/Smart/Comments.pm Tue May 24 15:54:42 2005
+++ lib/Smart/Comments.pm.patched Tue May 24 20:32:10 2005
@@ -1,6 +1,7 @@
package Smart::Comments;
-use version; $VERSION = qv('1.0.1');
+#use version; $VERSION = qv('1.0.1');
+$VERSION = 1.001001;
use warnings;
use strict;

View File

@ -0,0 +1,15 @@
Smart comments provide an easy way to insert debugging and tracking code into
a program. They can report the value of a variable, track the progress of a
loop, and verify that particular assertions are true.
Best of all, when you're finished debugging, you don't have to remove them.
Simply commenting out the use Smart::Comments line turns them back into
regular comments. Leaving smart comments in your code is smart because if you
needed them once, you'll almost certainly need them again later.
Author: Damian Conway <DCONWAY@cpan.org>
WWW: http://search.cpan.org/dist/Smart-Comments/
- Aaron Dalton
aaron@daltons.ca

View File

@ -0,0 +1,5 @@
%%SITE_PERL%%/Smart/Comments.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Smart/Comments/.packlist
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Smart/Comments
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Smart 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/Smart 2>/dev/null || true