MFH: r514755 r514770 r518301

audio/audacity: Remove bogus STATIC_WX option

This was accepted by me in r495224.  STATIC_WX_ENABLE was probably
supposed to be STATIC_WX_CONFIGURE_ENABLE but the entire idea of
the option is flawed.  wxgtk31 does not provide static libraries.

While here drop unhooked JACK_LIB_DEPENDS options helper.  Audacity
has been using the system Portaudio for a while and JACK support
can be enabled there.

Remove a bunch of unused *_DESC

Update to upstream version 2.3.3

PR:		242169
Submitted by:	xxjack12xx@gmail.com (maintainer)

Approved by:	ports-secteam (riggs)
This commit is contained in:
Thomas Zander 2019-11-24 20:08:49 +00:00
parent e93a50d692
commit 3438fddffd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2019Q4/; revision=518359
15 changed files with 18 additions and 42 deletions

View File

@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= audacity
PORTVERSION= 2.3.2
PORTVERSION= 2.3.3
DISTVERSIONPREFIX= Audacity-
PORTREVISION= 2
CATEGORIES= audio
MAINTAINER= xxjack12xx@gmail.com
@ -41,7 +40,7 @@ USE_GITHUB= yes
OPTIONS_DEFINE= DEBUG DOCS DYNLOAD FFMPEG FLAC ID3TAG LADSPA LAME LV2 \
MAD MOD_NYQ_BENCH MOD_SCRIPT_PIPE NLS SBSMS SOUNDTOUCH \
SSE STATIC_WX TWOLAME VAMP VORBIS VST
SSE TWOLAME VAMP VORBIS VST
OPTIONS_DEFAULT= FLAC ID3TAG LADSPA MAD SBSMS SOUNDTOUCH TWOLAME VAMP \
VORBIS VST
@ -56,8 +55,6 @@ MOD_SCRIPT_PIPE_DESC= mod-script-pipe scripting support
MOD_NYQ_BENCH_DESC= Enable Nyquist Workbench
SBSMS_DESC= Use libsbsms for pitch and tempo changing
SOUNDTOUCH_DESC= Use libSoundTouch for pitch and tempo changing
STATIC_WX_DESC= Link wx statically
TAGLIB_DESC= Use TagLib for metadata support
TWOLAME_DESC= Use libtwolame for MP2 export support
VAMP_DESC= Vamp plug-in support
VST_DESC= VST plug-in support
@ -100,8 +97,6 @@ FLAC_LIB_DEPENDS= libFLAC.so:audio/flac
ID3TAG_CONFIGURE_WITH= libid3tag=system
ID3TAG_LIB_DEPENDS= libid3tag.so:audio/libid3tag
JACK_LIB_DEPENDS= libjack.so:audio/jack
LADSPA_CONFIGURE_ENABLE= ladspa
LADSPA_RUN_DEPENDS= listplugins:audio/ladspa
@ -131,8 +126,6 @@ SOUNDTOUCH_LIB_DEPENDS= libSoundTouch.so:audio/soundtouch
SSE_CONFIGURE_ENABLE= sse
STATIC_WX_ENABLE= static-wx
TWOLAME_CONFIGURE_WITH= libtwolame=system
TWOLAME_LIB_DEPENDS= libtwolame.so:audio/twolame

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1557793254
SHA256 (audacity-audacity-Audacity-2.3.2_GH0.tar.gz) = cc477a71ff5571c72887a7a155365b07a1a50bcea1abf490a4de7b884376c731
SIZE (audacity-audacity-Audacity-2.3.2_GH0.tar.gz) = 61972597
TIMESTAMP = 1574484432
SHA256 (audacity-audacity-Audacity-2.3.3_GH0.tar.gz) = 9ab6c8989e21165b86aad80b7e6691015cb5b0c91ab77e6170d7192f840313a8
SIZE (audacity-audacity-Audacity-2.3.3_GH0.tar.gz) = 62099027

View File

@ -1,6 +1,6 @@
--- configure.ac.orig 2019-02-24 08:28:05 UTC
+++ configure.ac
@@ -204,14 +204,6 @@ if test x$enable_universal_binary = xyes; then
@@ -200,14 +200,6 @@ if test x$enable_universal_binary = xyes; then
esac
fi
@ -15,7 +15,7 @@
if test x$enable_sse = xyes; then
if test "${ax_cv_cxx_compiler_vendor}" = "gnu"; then
@@ -243,20 +235,7 @@ dnl check if alloca.h exists. If it does, we need to i
@@ -239,20 +231,7 @@ dnl check if alloca.h exists. If it does, we need to i
dnl Solaris builds, by defining HAVE_ALLOCA_H
AC_CHECK_HEADERS_ONCE(alloca.h)

View File

@ -1,6 +1,6 @@
--- include/audacity/Types.h.orig 2018-10-01 14:07:33 UTC
+++ include/audacity/Types.h
@@ -100,7 +100,7 @@ class sampleCount (public)
@@ -311,7 +311,7 @@ class sampleCount (public)
sampleCount ( long v ) : value { v } {}
// unsigned long is 64 bit on some platforms. Let it narrow.

View File

@ -1,6 +1,6 @@
--- lib-src/FileDialog/Makefile.am.orig 2018-10-01 14:07:33 UTC
+++ lib-src/FileDialog/Makefile.am
@@ -1,5 +1,7 @@
@@ -2,5 +2,7 @@
ACLOCAL_AMFLAGS = -I m4
+SUBDIRS= $(GTK_SUBDIR) $(MAC_SUBDIR) $(WINDOWS_SUBDIR)
@ -8,7 +8,7 @@
lib_LTLIBRARIES = libFileDialog.la
libFileDialog_la_LIBTOOLFLAGS = --tag=CXX
@@ -8,22 +10,32 @@ libFileDialog_la_LIBADD = $(WX_LIBS)
@@ -11,22 +13,32 @@ libFileDialog_la_LIBADD = $(WX_LIBS)
libFileDialog_la_SOURCES = FileDialog.cpp FileDialog.h
if GTK

View File

@ -1,14 +1,14 @@
--- src/AudioIO.cpp.orig 2018-10-01 14:07:33 UTC
+++ src/AudioIO.cpp
@@ -479,7 +479,6 @@ TimeTrack and AudioIOListener and whether the playback
@@ -480,7 +480,6 @@ TimeTrack and AudioIOListener and whether the playback
#define ROUND(x) (int) ((x)+0.5)
//#include <string.h>
#include "../lib-src/portmidi/pm_common/portmidi.h"
// #include "../lib-src/portmidi/pm_common/portmidi.h"
- #include "../lib-src/portaudio-v19/src/common/pa_util.h"
#include "NoteTrack.h"
#endif
@@ -799,13 +800,22 @@ struct AudioIO::ScrubState (private)
@@ -793,13 +797,22 @@ struct AudioIO::ScrubState (private)
// return the system time as a double
static double streamStartTime = 0; // bias system time to small number

View File

@ -1,6 +1,6 @@
--- src/FFmpeg.h.orig 2018-10-01 14:07:33 UTC
+++ src/FFmpeg.h
@@ -671,7 +671,7 @@ extern "C" {
@@ -667,7 +667,7 @@ extern "C" {
FFMPEG_FUNCTION_WITH_RETURN(
AVOutputFormat*,
av_oformat_next,
@ -9,7 +9,7 @@
(f)
);
#endif
@@ -752,7 +752,7 @@ extern "C" {
@@ -748,7 +748,7 @@ extern "C" {
FFMPEG_FUNCTION_WITH_RETURN(
int,
av_fifo_size,
@ -18,7 +18,7 @@
(f)
);
#endif
@@ -814,7 +814,7 @@ extern "C" {
@@ -810,7 +810,7 @@ extern "C" {
FFMPEG_FUNCTION_WITH_RETURN(
AVDictionaryEntry *,
av_dict_get,

View File

@ -1,11 +0,0 @@
--- src/MemoryX.h.orig 2019-03-09 11:55:09 UTC
+++ src/MemoryX.h
@@ -641,7 +641,7 @@ make_iterator_range( const Container &container )
// For using std::unordered_map on wxString
namespace std
{
- template<typename T> struct hash;
+ //template<typename T> struct hash;
template<> struct hash< wxString > {
size_t operator () (const wxString &str) const // noexcept
{

View File

@ -1,6 +1,6 @@
--- src/prefs/PrefsDialog.cpp.orig 2019-05-13 18:00:33.704997000 -0700
+++ src/prefs/PrefsDialog.cpp 2019-05-13 17:52:51.702814000 -0700
@@ -29,6 +29,7 @@
@@ -30,6 +30,7 @@
#include <wx/intl.h>
#include <wx/listbox.h>
#include <wx/sizer.h>

View File

@ -80,7 +80,6 @@ share/applications/audacity.desktop
%%DATADIR%%/plug-ins/sample-data-import.ny
%%DATADIR%%/plug-ins/tremolo.ny
%%DATADIR%%/plug-ins/vocalrediso.ny
%%DATADIR%%/plug-ins/vocalremover.ny
%%DATADIR%%/plug-ins/vocoder.ny
share/icons/hicolor/16x16/apps/audacity.png
share/icons/hicolor/22x22/apps/audacity.png

View File

@ -32,7 +32,6 @@ OPTIONS_GROUP_AIFACE= ALSA PORTAUDIO
AIFACE_DESC= Other audio interfaces
SYSTRAY_DESC= System tray icon support
TOOLKIT_DESC= Qt toolkit
XUNIQUE_DESC= X11 unique/single instance
ALSA_CONFIGURE_ENABLE= alsa_seq

View File

@ -56,7 +56,7 @@ MAIL_DESC= Mail applet
#RUBY_DESC= Ruby interface
SOUND_EFFECTS_DESC= Sound Effects applet
UPOWER_DESC= D-Bus daemon for power management tasks
TERMINAL_DESC= Terminal applet
#TERMINAL_DESC= Terminal applet
#VALA_DESC= Vala interface
WEBLETS_DESC= Weblets applet
XGAMMA_DESC= Xgamma applet

View File

@ -21,8 +21,6 @@ GH_TAGNAME= ccb792fc713aa7163fffd37fc20c83ffe9ca7523
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
I18N_DESC= Install localization files
CONFLICTS_INSTALL= lumina-1.2.*
WRKSRC_SUBDIR= src-qt5

View File

@ -42,7 +42,6 @@ ULINK_DESC= Support Keil ULINK-JTAG Programmer
ARMJTAGEW_DESC= Support Olimex ARM-JTAG-EW Programmer
BUSPIRATE_DESC= Support BusPirate Programmer
STLINK_DESC= Support STLink Programmer
TI_ICDI_DESC= Support TI ICDI JTAG Programmer
OSBDM_DESC= Support OSBDM Programmer (JTAG only)
OPENDOUS_DESC= Support EStick/OpenDous Programmer
SYSFSGPIO_DESC= Support Programming via sysfs GPIOs

View File

@ -58,7 +58,6 @@ OPTIONS_DEFINE= MANPAGES PR_DOWNLOADER DOCS
OPTIONS_DEFAULT=MANPAGES PR_DOWNLOADER
OPTIONS_SUB= yes
HTMLDOCS_DESC= Build and install HTML documentation
PR_DOWNLOADER_DESC= Map and game downloader
MANPAGES_CMAKE_ON= -DCREATE_MAN_PAGES:BOOL=true -DMANDIR:STRING="man"