Convert to staging, add missing includes.

This commit is contained in:
Christian Weisgerber 2013-11-05 15:52:36 +00:00
parent c96c966098
commit 3437a31511
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=332860
9 changed files with 81 additions and 12 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= grpn
PORTVERSION= 1.1.2
PORTREVISION= 5
PORTREVISION= 6
CATEGORIES= math
MASTER_SITES= http://lashwhip.com/grpn/
@ -14,12 +14,10 @@ USE_GNOME= gtk12
ALL_TARGET=
MAN1= grpn.1
PLIST_FILES= bin/grpn
PLIST_FILES= bin/grpn man/man1/grpn.1.gz
NO_STAGE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/grpn ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/grpn.1 ${PREFIX}/man/man1
${INSTALL_PROGRAM} ${WRKSRC}/grpn ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/grpn.1 ${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.mk>

View File

@ -1,7 +1,7 @@
--- Makefile.orig Mon May 31 21:46:31 1999
+++ Makefile Mon Oct 25 19:52:03 1999
@@ -3,7 +3,7 @@
# Please read the next few lines and enter the correct values.
--- Makefile.orig 2002-04-05 05:56:05.000000000 +0200
+++ Makefile 2013-11-05 16:39:16.000000000 +0100
@@ -6,7 +6,7 @@
PREFIX = /usr/local/
# What compiler should be used
-CC = gcc
@ -9,7 +9,7 @@
# Where to find the gtk-config script
GTK_DIR =
@@ -17,9 +17,9 @@
@@ -20,9 +20,9 @@ GTK_DIR =
# add -DUSE_GNOME if you want to make grpn GNOME compliant.
@ -21,7 +21,7 @@
# end of user configurable section
@@ -34,7 +34,7 @@
@@ -37,7 +37,7 @@ OBJS = test_gtk_ver.o real.o complex.o m

View File

@ -0,0 +1,10 @@
--- complex.c.orig 2002-04-04 05:46:10.000000000 +0200
+++ complex.c 2013-11-05 16:40:36.000000000 +0100
@@ -21,6 +21,7 @@ Foundation, Inc., 59 Temple Place - Suit
#include <stdio.h>
#include <stdlib.h>
+#include <string.h>
#include <math.h>
#include "complex.h"

View File

@ -0,0 +1,10 @@
--- help.c.orig 2002-04-04 05:46:11.000000000 +0200
+++ help.c 2013-11-05 16:44:41.000000000 +0100
@@ -19,6 +19,7 @@ Foundation, Inc., 59 Temple Place - Suit
*/
#include <stdio.h>
#include <stdlib.h>
+#include <string.h>
#include <gtk/gtk.h>
#include "help.h"

View File

@ -0,0 +1,11 @@
--- lcd.c.orig 2002-04-04 05:46:11.000000000 +0200
+++ lcd.c 2013-11-05 16:42:40.000000000 +0100
@@ -20,6 +20,8 @@ Foundation, Inc., 59 Temple Place - Suit
/* lcd.c by Paul Wilkins 3/22/97 */
#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
#include <gtk/gtk.h>
#include <gdk/gdkkeysyms.h>

View File

@ -0,0 +1,10 @@
--- main.c.orig 2002-04-04 05:46:11.000000000 +0200
+++ main.c 2013-11-05 16:42:00.000000000 +0100
@@ -23,6 +23,7 @@ Foundation, Inc., 59 Temple Place - Suit
*/
#include <stdio.h>
+#include <stdlib.h>
#ifdef USE_GNOME
#include <gnome.h>
#endif

View File

@ -0,0 +1,10 @@
--- mode.c.orig 2002-04-04 05:46:11.000000000 +0200
+++ mode.c 2013-11-05 16:44:30.000000000 +0100
@@ -20,6 +20,7 @@ Foundation, Inc., 59 Temple Place - Suit
/* setup mode.c by Paul Wilkins 2/8/98 */
#include <stdio.h>
+#include <string.h>
#include <gtk/gtk.h>
#include "mode.h"

View File

@ -0,0 +1,10 @@
--- process_input.c.orig 2002-04-04 05:46:11.000000000 +0200
+++ process_input.c 2013-11-05 16:43:55.000000000 +0100
@@ -20,6 +20,7 @@ Foundation, Inc., 59 Temple Place - Suit
/* process_input.c by Paul Wilkins 3/21/97 */
#include <stdio.h>
+#include <stdlib.h>
#include <gtk/gtk.h>
#include <gdk/gdkkeysyms.h>

View File

@ -0,0 +1,10 @@
--- run_cmd.c.orig 2002-04-04 05:46:11.000000000 +0200
+++ run_cmd.c 2013-11-05 16:41:30.000000000 +0100
@@ -20,6 +20,7 @@ Foundation, Inc., 59 Temple Place - Suit
/* run_cmd.c by Paul Wilkins */
#include <stdio.h>
+#include <string.h>
#include <gtk/gtk.h>
#include "buttons.h"