Update astro/geographiclib to 1.4.9

Highlights:
- Update from 1.4.6 to 1.4.9
- MAGNETIC_EMM2017 model addd
- Switched to CMake for build

head/tail usage must be patched to avoid use of --lines; work is in progress
to eventually grow this long-option alternative to -n so that such patching
isn't necessary at some point in the future.

PR:		218158
Approved by:	ak (ports), Tatsuki Makino (maintainer)
This commit is contained in:
Kyle Evans 2018-02-03 15:42:08 +00:00
parent 90928eb46e
commit 3424b81888
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=460821
8 changed files with 105 additions and 18 deletions

View File

@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= geographiclib
PORTVERSION= 1.46
PORTREVISION= 2
PORTVERSION= 1.49
CATEGORIES= astro
MASTER_SITES= SF/geographiclib/distrib\
SF/geographiclib:geoids,gravity,magnetic
DISTNAME= GeographicLib-${PORTVERSION}
DISTNAME= GeographicLib-${PORTVERSION}${DISTVERSIONSUFFIX}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
DIST_SUBDIR= GeographicLib
@ -17,16 +16,15 @@ COMMENT= Library for geographic projections
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/ax_check_compile_flag.m4:devel/autoconf-archive
USES= autoreconf compiler:c++11-lang gmake libtool python
USES= cmake compiler:c++14-lang python
WRKSRC= ${WRKDIR}/GeographicLib-${PORTVERSION}
PORTDOCS= *
FETCH_ENV+= HTTP_REFERER=
GNU_CONFIGURE= yes
MAKE_ARGS+= geographiclib_data=${DATADIR:Q}
MAKE_ARGS+= pythondir=${PYTHON_SITELIBDIR}/geographiclib
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
CMAKE_ARGS= -DGEOGRAPHICLIB_DATA:STRING=${DATADIR:Q}\
-DGEOGRAPHICLIB_LIB_TYPE:STRING=BOTH\
-DINSTALL_PYTHON_DIR:STRING=${PYTHON_SITELIBDIR:Q}\
-DINSTALL_DOC_DIR:STRING=${DOCSDIR:Q}
OPTIONS_DEFINE= DOXYGEN PERL
OPTIONS_DEFAULT= DOXYGEN PERL\
@ -35,16 +33,18 @@ OPTIONS_DEFAULT= DOXYGEN PERL\
PERL_DESC= Build documentation with pod2man and pod2html
OPTIONS_GROUP= DATASETS
OPTIONS_SUB= yes
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
DOXYGEN_CONFIGURE_ENV_OFF= ac_cv_prog_DOXYGEN=
DOXYGEN_CMAKE_BOOL= GEOGRAPHICLIB_DOCUMENTATION
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen\
sphinx-build:textproc/py-sphinx
PERL_CMAKE_BOOL_OFF= GEOGRAPHICLIB_NO_PERL
PERL_USE= PERL5=build
PERL_USES= perl5
PERL_CONFIGURE_ENV_OFF= ac_cv_prog_POD2MAN= ac_cv_prog_POD2HTML=
GEOID_NAMES= egm84-30 egm84-15 egm96-15 egm96-5\
egm2008-5 egm2008-2_5 egm2008-1
GRAVITY_NAMES= egm84 egm96 egm2008 wgs84 grs80
MAGNETIC_NAMES= wmm2010 wmm2015 igrf11 igrf12 emm2010 emm2015
MAGNETIC_NAMES= wmm2010 wmm2015 igrf11 igrf12\
emm2010 emm2015 emm2017
.for n in ${GEOID_NAMES}
GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} geoid dataset
@ -71,6 +71,9 @@ OPTIONS_DEFAULT= ${MAKESUM_OPTIONS_DEFAULT}
.endif
post-patch:
${REINPLACE_CMD} -e 's/\(tail\) --lines/\1 -n/g'\
-e "s,head --lines -4,${SED} -e '\$$d' | ${SED} -e '\$$d' | ${SED} -e '\$$d' | ${SED} -e '\$$d',"\
${WRKSRC}/man/makeusage.sh
${REINPLACE_CMD} -e '/wget/s/wget -O/fetch -o /'\
${WRKSRC}/tools/geographiclib-get-*.sh

View File

@ -1,5 +1,6 @@
SHA256 (GeographicLib/GeographicLib-1.46.tar.gz) = 3a0606fd99fb099572ba1923f556b05b545965359edb92930a658fc99172d962
SIZE (GeographicLib/GeographicLib-1.46.tar.gz) = 2208372
TIMESTAMP = 1517542980
SHA256 (GeographicLib/GeographicLib-1.49.tar.gz) = aec0ab52b6b9c9445d9d0a77e3af52257e21d6e74e94d8c2cb8fa6f11815ee2b
SIZE (GeographicLib/GeographicLib-1.49.tar.gz) = 2448498
SHA256 (GeographicLib/geoids-distrib/egm84-30.tar.bz2) = 18bc3e2b55c4f9f2f9ba8d14380dc47cc5c0d00dc2363b723d2305f30a91498e
SIZE (GeographicLib/geoids-distrib/egm84-30.tar.bz2) = 416481
SHA256 (GeographicLib/geoids-distrib/egm84-15.tar.bz2) = 579e3dad2f33b54f1fed16edb3ed9d4ae8cdad6ea064f7375af30d678eb2e51c
@ -36,3 +37,5 @@ SHA256 (GeographicLib/magnetic-distrib/emm2010.tar.bz2) = aa8782fddb505d8dc24e3d
SIZE (GeographicLib/magnetic-distrib/emm2010.tar.bz2) = 3627692
SHA256 (GeographicLib/magnetic-distrib/emm2015.tar.bz2) = 8e71a9704c5f2714bb65581df68e30f0d84d0ad17286d00efb782e7232334c3f
SIZE (GeographicLib/magnetic-distrib/emm2015.tar.bz2) = 659405
SHA256 (GeographicLib/magnetic-distrib/emm2017.tar.bz2) = 13ace8ecaf05bf07c7dda93f4a52e98e14be7147d23213fcbe946de3362954a1
SIZE (GeographicLib/magnetic-distrib/emm2017.tar.bz2) = 1733711

View File

@ -0,0 +1,23 @@
--- CMakeLists.txt.orig 2017-10-05 10:11:23 UTC
+++ CMakeLists.txt
@@ -177,6 +177,11 @@ option (APPLE_MULTIPLE_ARCHITECTURES
# directory is present you get this behavior regardless.
option (CONVERT_WARNINGS_TO_ERRORS "Convert warnings into errors?" OFF)
+# (12) Allow perl usage to be explicitly disabled. It might exist on the
+# system, but the user may not necessarily want it to be used for one reason
+# or another.
+option (GEOGRAPHICLIB_NO_PERL "Disable usage of pod2man and pod2html" OFF)
+
set (LIBNAME Geographic)
if (MSVC OR CMAKE_CONFIGURATION_TYPES)
# For multi-config systems and for Visual Studio, the debug version of
@@ -450,7 +455,7 @@ endif ()
# documentation files into the source tree. Skip Apple here because
# man/makeusage.sh uses "head --lines -4" to drop the last 4 lines of a
# file and there's no simple equivalent for MacOSX
-if (NOT WIN32 AND NOT APPLE)
+if (NOT WIN32 AND NOT APPLE AND NOT GEOGRAPHICLIB_NO_PERL)
find_program (HAVE_POD2MAN pod2man)
find_program (HAVE_POD2HTML pod2html)
find_program (HAVE_COL col)

View File

@ -0,0 +1,8 @@
--- cmake/CMakeLists.txt.orig 2017-10-05 10:11:23 UTC
+++ cmake/CMakeLists.txt
@@ -77,4 +77,4 @@ set (PACKAGE_VERSION "${PROJECT_VERSION}
configure_file (project.pc.in geographiclib.pc @ONLY)
install (FILES
"${CMAKE_CURRENT_BINARY_DIR}/geographiclib.pc"
- DESTINATION "lib${LIB_SUFFIX}/pkgconfig")
+ DESTINATION "libdata/pkgconfig")

View File

@ -0,0 +1,14 @@
--- doc/CMakeLists.txt.orig 2017-10-05 10:11:23 UTC
+++ doc/CMakeLists.txt
@@ -9,9 +9,9 @@ foreach (TOOL ${TOOLS})
endforeach ()
if (COMMON_INSTALL_PATH)
- set (INSTALL_DOC_DIR "share/doc/GeographicLib")
+ set (INSTALL_DOC_DIR "share/doc/GeographicLib" CACHE STRING "")
else ()
- set (INSTALL_DOC_DIR "doc")
+ set (INSTALL_DOC_DIR "doc" CACHE STRING "")
endif ()
# Run doxygen, if available

View File

@ -0,0 +1,12 @@
--- man/CMakeLists.txt.orig 2017-10-05 10:11:24 UTC
+++ man/CMakeLists.txt
@@ -101,7 +101,7 @@ else ()
endif ()
# Install the man pages.
-install (FILES ${MANPAGES} DESTINATION share/man/man1)
+install (FILES ${MANPAGES} DESTINATION man/man1)
if (NOT WIN32)
- install (FILES ${SYSMANPAGES} DESTINATION share/man/man8)
+ install (FILES ${SYSMANPAGES} DESTINATION man/man8)
endif ()

View File

@ -0,0 +1,15 @@
--- python/geographiclib/CMakeLists.txt.orig 2017-10-05 10:11:24 UTC
+++ python/geographiclib/CMakeLists.txt
@@ -4,9 +4,10 @@
file (GLOB PYTHON_FILES [A-Za-z_]*.py)
file (GLOB TEST_FILES test/[A-Za-z_]*.py)
if (COMMON_INSTALL_PATH)
- set (INSTALL_PYTHON_DIR "lib${LIB_SUFFIX}/python/site-packages")
+ set (INSTALL_PYTHON_DIR "lib${LIB_SUFFIX}/python/site-packages"
+ CACHE STRING "")
else ()
- set (INSTALL_PYTHON_DIR "python")
+ set (INSTALL_PYTHON_DIR "python" CACHE STRING "")
endif ()
install (FILES ${PYTHON_FILES}

View File

@ -38,6 +38,7 @@ include/GeographicLib/MGRS.hpp
include/GeographicLib/MagneticCircle.hpp
include/GeographicLib/MagneticModel.hpp
include/GeographicLib/Math.hpp
include/GeographicLib/NearestNeighbor.hpp
include/GeographicLib/NormalGravity.hpp
include/GeographicLib/OSGB.hpp
include/GeographicLib/PolarStereographic.hpp
@ -51,10 +52,16 @@ include/GeographicLib/TransverseMercator.hpp
include/GeographicLib/TransverseMercatorExact.hpp
include/GeographicLib/UTMUPS.hpp
include/GeographicLib/Utility.hpp
lib/cmake/GeographicLib/geographiclib-config-version.cmake
lib/cmake/GeographicLib/geographiclib-config.cmake
lib/cmake/GeographicLib/geographiclib-namespace-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/GeographicLib/geographiclib-namespace-targets.cmake
lib/cmake/GeographicLib/geographiclib-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/GeographicLib/geographiclib-targets.cmake
lib/libGeographic.a
lib/libGeographic.so
lib/libGeographic.so.17
lib/libGeographic.so.17.0.0
lib/libGeographic.so.17.1.2
lib/node_modules/geographiclib/LICENSE.txt
lib/node_modules/geographiclib/README.md
lib/node_modules/geographiclib/geographiclib.js
@ -76,6 +83,7 @@ lib/node_modules/geographiclib/test/geodesictest.js
%%PYTHON_SITELIBDIR%%/geographiclib/polygonarea.py
%%PYTHON_SITELIBDIR%%/geographiclib/test/__init__.py
%%PYTHON_SITELIBDIR%%/geographiclib/test/test_geodesic.py
libdata/pkgconfig/geographiclib.pc
man/man1/CartConvert.1.gz
man/man1/ConicProj.1.gz
man/man1/GeoConvert.1.gz
@ -93,7 +101,6 @@ man/man8/geographiclib-get-magnetic.8.gz
sbin/geographiclib-get-geoids
sbin/geographiclib-get-gravity
sbin/geographiclib-get-magnetic
share/cmake/GeographicLib/FindGeographicLib.cmake
%%GEOID_EGM2008_1%%%%DATADIR%%/geoids/egm2008-1.pgm
%%GEOID_EGM2008_1%%%%DATADIR%%/geoids/egm2008-1.pgm.aux.xml
%%GEOID_EGM2008_1%%%%DATADIR%%/geoids/egm2008-1.wld
@ -129,6 +136,8 @@ share/cmake/GeographicLib/FindGeographicLib.cmake
%%MAGNETIC_EMM2010%%%%DATADIR%%/magnetic/emm2010.wmm.cof
%%MAGNETIC_EMM2015%%%%DATADIR%%/magnetic/emm2015.wmm
%%MAGNETIC_EMM2015%%%%DATADIR%%/magnetic/emm2015.wmm.cof
%%MAGNETIC_EMM2017%%%%DATADIR%%/magnetic/emm2017.wmm
%%MAGNETIC_EMM2017%%%%DATADIR%%/magnetic/emm2017.wmm.cof
%%MAGNETIC_IGRF11%%%%DATADIR%%/magnetic/igrf11.wmm
%%MAGNETIC_IGRF11%%%%DATADIR%%/magnetic/igrf11.wmm.cof
%%MAGNETIC_IGRF12%%%%DATADIR%%/magnetic/igrf12.wmm