lang/yap: restore the port providing live sources for the same distfile

This commit is contained in:
Eugene Grosbein 2020-11-23 14:28:52 +00:00
parent 66159faf2d
commit 3417af84b1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=556108
10 changed files with 619 additions and 1 deletions

1
MOVED
View File

@ -14677,7 +14677,6 @@ lang/ohugs||2020-05-05|Has expired: Broken for more than 6 months
lang/opendylan||2020-05-05|Has expired: Broken for more than 6 months
lang/phc||2020-05-05|Has expired: Broken for more than 6 months
lang/starlogo||2020-05-05|Has expired: Broken for more than 6 months
lang/yap||2020-05-05|Has expired: Broken for more than 6 months
lang/yap-devel||2020-05-05|Has expired: Broken for more than 6 months
mail/chk4mail||2020-05-05|Has expired: Broken for more than 6 months
mail/librfc822||2020-05-05|Has expired: Broken for more than 6 months

View File

@ -362,6 +362,7 @@
SUBDIR += visualworks
SUBDIR += voc
SUBDIR += yabasic
SUBDIR += yap
SUBDIR += yorick
SUBDIR += ypsilon
SUBDIR += zig

40
lang/yap/Makefile Normal file
View File

@ -0,0 +1,40 @@
# Created by: Danilo Egea Gondolfo <danilogondolfo@gmail.com>
# $FreeBSD$
PORTNAME= yap
PORTVERSION= 6.2.2
PORTREVISION= 9
CATEGORIES= lang
MASTER_SITES= https://mirrors.dotsrc.org/mirrors/exherbo/ \
http://ftp.lyx.org/pub/minix/distfiles/backup/ \
http://tenampak.izt.uam.mx/programas/
MAINTAINER= danilo@FreeBSD.org
COMMENT= High-performance Prolog compiler
LIB_DEPENDS= libgmp.so:math/gmp
PORTSCOUT= limit:^6\.2\.
CONFLICTS= yap-6.3.*
OPTIONS_DEFINE= DOCS
DOCS_USE= TEX=formats:build,dvipsk:build
DOCS_BUILD_DEPENDS= ${LOCALBASE}/bin/texi2html:textproc/texi2html \
${LOCALBASE}/bin/texi2pdf:print/texinfo
DOCS_INSTALL_TARGET= install install_docs
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-max-performance \
--disable-myddas
USES= gmake localbase readline
DOCSDIR= ${PREFIX}/share/doc/Yap
DATADIR= ${PREFIX}/share/Yap
post-build-DOCS-off:
# prevent the instalation of three docs files
${REINPLACE_CMD} -e '559,562d' ${WRKSRC}/Makefile
.include <bsd.port.mk>

2
lang/yap/distinfo Normal file
View File

@ -0,0 +1,2 @@
SHA256 (yap-6.2.2.tar.gz) = f15f8382104443319a5883eafce5f52f4143b526c7f1cd88d19c1f63fc06d750
SIZE (yap-6.2.2.tar.gz) = 5499811

View File

@ -0,0 +1,20 @@
--- Makefile.in.orig 2015-07-23 15:33:43 UTC
+++ Makefile.in
@@ -94,7 +94,7 @@ SO=@SO@
MAKEINFO=makeinfo
TEXI2DVI=texi2dvi
TEXI2HTML=texi2html
-TEXI2PDF=texi2pdf
+TEXI2PDF=texi2pdf -b
YAPLIB=@YAPLIB@
SONAMEFLAG=@SONAMEFLAG@
@@ -776,7 +776,7 @@ yap.ps: $(YAPDOCS)
pdf: yap.pdf
yap.pdf: $(YAPDOCS)
- $(TEXI2PDF) $(srcdir)/docs/yap.tex
+ -$(TEXI2PDF) $(srcdir)/docs/yap.tex
clean_docs:
rm -f *.aux *.ca *.cas *.cn *.cns *.cp *.cps *.cy *.cys *.dvi *.fn *.fns *.ky *.log *.sa *.sas *.sn *.sns *.sy *.sys *~ *.tp *.vr *.toc *.pg

View File

@ -0,0 +1,31 @@
https://sourceforge.net/p/yap/yap-6.3/ci/139f64a45900
https://sourceforge.net/p/yap/yap-6.3/ci/da61f1c31fed
--- configure.orig 2011-10-23 22:11:24 UTC
+++ configure
@@ -4397,13 +4397,9 @@ then
C_PARSER_FLAGS="-O3 -Wall -Wstrict-prototypes -Wmissing-prototypes $CFLAGS"
CFLAGS="-O3 -fomit-frame-pointer -Wall -Wstrict-prototypes -Wmissing-prototypes $CFLAGS"
case "`$CC --version < /dev/null`" in
- *3.4*) CFLAGS="-fno-gcse -fno-crossjumping $CFLAGS" ;;
+ gcc-3.4*) CFLAGS="-fno-gcse -fno-crossjumping $CFLAGS" ;;
esac
case "$target_cpu" in
- i*86*)
- CFLAGS="-DBP_FREE $CFLAGS"
- CXXFLAGS="-DBP_FREE $CXXFLAGS"
- ;;
sparc*)
case "$target_os" in
*solaris2-9*) CFLAGS="-mno-app-regs -DOPTIMISE_ALL_REGS_FOR_SPARC=1 $CFLAGS"
@@ -4433,10 +4429,6 @@ then
i486*)
CFLAGS="-march=i486 $CFLAGS"
CXXFLAGS="-march=i486 $CXXFLAGS"
- ;;
- i386*)
- CFLAGS="-march=i386 $CFLAGS"
- CXXFLAGS="-march=i386 $CXXFLAGS"
;;
esac
fi

View File

@ -0,0 +1,10 @@
--- ./library/dialect/swi/fli/blobs.c.orig 2010-12-02 09:47:28.000000000 -0200
+++ ./library/dialect/swi/fli/blobs.c 2013-11-02 21:10:56.000000000 -0200
@@ -18,6 +18,7 @@
#include <Yap.h>
#include <Yatom.h>
+#include <stdio.h>
#include <string.h>
#include <SWI-Prolog.h>

View File

@ -0,0 +1,31 @@
https://sourceforge.net/p/yap/yap-6.3/ci/e938c1774890
https://sourceforge.net/p/yap/yap-6.3/ci/6d2e2597b183
--- packages/swi-minisat2/C/SolverTypes.h.orig 2010-10-18 08:48:21 UTC
+++ packages/swi-minisat2/C/SolverTypes.h
@@ -119,11 +119,7 @@ public:
// -- use this function instead:
template<class V>
- friend Clause* Clause_new(const V& ps, bool learnt = false) {
- assert(sizeof(Lit) == sizeof(uint32_t));
- assert(sizeof(float) == sizeof(uint32_t));
- void* mem = malloc(sizeof(Clause) + sizeof(uint32_t)*(ps.size()));
- return new (mem) Clause(ps, learnt); }
+ friend Clause* Clause_new(const V& ps, bool learnt);
int size () const { return size_etc >> 3; }
void shrink (int i) { assert(i <= size()); size_etc = (((size_etc >> 3) - i) << 3) | (size_etc & 7); }
@@ -147,6 +143,12 @@ public:
};
+template<class V>
+Clause* Clause_new(const V& ps, bool learnt) {
+ assert(sizeof(Lit) == sizeof(uint32_t));
+ assert(sizeof(float) == sizeof(uint32_t));
+ void* mem = malloc(sizeof(Clause) + sizeof(uint32_t)*(ps.size()));
+ return new (mem) Clause(ps, learnt); }
/*_________________________________________________________________________________________________
|
| subsumes : (other : const Clause&) -> Lit

8
lang/yap/pkg-descr Normal file
View File

@ -0,0 +1,8 @@
YAP is a high-performance Prolog compiler developed at
LIACC/Universidade do Porto and at COPPE Sistemas/UFRJ. Its Prolog
engine is based in the WAM (Warren Abstract Machine), with several
optimizations for better performance. YAP follows the Edinburgh
tradition, and is largely compatible with the ISO-Prolog standard and
with Quintus and SICStus Prolog.
WWW: http://www.dcc.fc.up.pt/~vsc/Yap/

476
lang/yap/pkg-plist Normal file
View File

@ -0,0 +1,476 @@
bin/yap
include/Yap/TermExt.h
include/Yap/Atoms.h
include/Yap/Tags_32bits.h
include/Yap/Tags_32Ops.h
include/Yap/Tags_32LowTag.h
include/Yap/Tags_64bits.h
include/Yap/Tags_24bits.h
include/Yap/sshift.h
include/Yap/Yap.h
include/Yap/Yatom.h
include/Yap/YapHeap.h
include/Yap/Regs.h
include/Yap/Yapproto.h
include/Yap/absmi.h
include/Yap/alloc.h
include/Yap/amidefs.h
include/Yap/amiops.h
include/Yap/arrays.h
include/Yap/arith2.h
include/Yap/attvar.h
include/Yap/clause.h
include/Yap/compile.h
include/Yap/corout.h
include/Yap/dlmalloc.h
include/Yap/dglobals.h
include/Yap/dhstruct.h
include/Yap/eval.h
include/Yap/heapgc.h
include/Yap/hglobals.h
include/Yap/hstruct.h
include/Yap/iglobals.h
include/Yap/ihstruct.h
include/Yap/index.h
include/Yap/iopreds.h
include/Yap/iswiatoms.h
include/Yap/rclause.h
include/Yap/rglobals.h
include/Yap/rheap.h
include/Yap/rhstruct.h
include/Yap/threads.h
include/Yap/tracer.h
include/Yap/trim_trail.h
include/Yap/yapio.h
include/Yap/eam.h
include/Yap/eamamasm.h
include/Yap/opt.config.h
include/Yap/opt.proto.h
include/Yap/opt.structs.h
include/Yap/opt.macros.h
include/Yap/cut_c.h
include/Yap/or.macros.h
include/Yap/or.sbaamiops.h
include/Yap/or.sbaunify.h
include/Yap/tab.structs.h
include/Yap/locks_x86.h
include/Yap/locks_sparc.h
include/Yap/locks_mips.h
include/Yap/locks_mips_funcs.h
include/Yap/locks_alpha.h
include/Yap/locks_alpha_funcs.h
include/Yap/locks_pthread.h
include/Yap/iatoms.h
include/Yap/ratoms.h
include/Yap/tatoms.h
include/Yap/swi.h
include/Yap/myddas.h
include/Yap/myddas_structs.h
include/Yap/myddas_statistics.h
include/Yap/myddas_statistics_structs.h
include/Yap/myddas_wkb.h
include/Yap/myddas_wkb2prolog.h
include/Yap/c_interface.h
include/Yap/clause_list.h
include/Yap/dswiatoms.h
include/Yap/udi.h
include/Yap/rtree_udi.h
include/Yap/yap_structs.h
include/Yap/YapInterface.h
include/Yap/SWI-Prolog.h
include/Yap/SWI-Stream.h
include/Yap/config.h
include/Yap/parms.h
lib/Yap/startup.yss
lib/Yap/libplstream.so
lib/Yap/matrix.so
lib/Yap/yap_random.so
lib/Yap/regexp.so
lib/Yap/yap_rl.so
lib/Yap/sys.so
lib/Yap/tries.so
lib/Yap/itries.so
lib/Yap/unix.so
lib/Yap/random.so
lib/Yap/socket.so
lib/Yap/cgi.so
lib/Yap/memfile.so
lib/Yap/files.so
lib/Yap/mime.so
lib/Yap/crypt.so
lib/Yap/time.so
lib/Yap/readutil.so
lib/Yap/streaminfo.so
lib/Yap/process.so
lib/Yap/sha4pl.so
lib/Yap/uri.so
lib/Yap/http_stream.so
lib/Yap/json.so
lib/Yap/sgml2pl.so
lib/Yap/rdf_db.so
lib/Yap/turtle.so
lib/Yap/pl-tai.so
lib/Yap/zlib4pl.so
lib/Yap/pl-minisat.so
lib/libYap.a
lib/web/css/dirindex.css
lib/web/css/openid.css
%%PORTDOCS%%%%DOCSDIR%%/Artistic
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/yap.html
%%PORTDOCS%%%%DOCSDIR%%/yap.pdf
%%PORTDOCS%%%%DOCSDIR%%/changes4.3.html
%%PORTDOCS%%%%DOCSDIR%%/changes-5.0.html
%%PORTDOCS%%%%DOCSDIR%%/changes-5.1.html
%%PORTDOCS%%%%DOCSDIR%%/changes-6.0.html
%%DATADIR%%/pl/arith.yap
%%DATADIR%%/pl/arrays.yap
%%DATADIR%%/pl/attributes.yap
%%DATADIR%%/pl/boot.yap
%%DATADIR%%/pl/callcount.yap
%%DATADIR%%/pl/checker.yap
%%DATADIR%%/pl/chtypes.yap
%%DATADIR%%/pl/consult.yap
%%DATADIR%%/pl/control.yap
%%DATADIR%%/pl/corout.yap
%%DATADIR%%/pl/debug.yap
%%DATADIR%%/pl/depth_bound.yap
%%DATADIR%%/pl/dialect.yap
%%DATADIR%%/pl/directives.yap
%%DATADIR%%/pl/eam.yap
%%DATADIR%%/pl/eval.yap
%%DATADIR%%/pl/errors.yap
%%DATADIR%%/pl/flags.yap
%%DATADIR%%/pl/grammar.yap
%%DATADIR%%/pl/ground.yap
%%DATADIR%%/pl/hacks.yap
%%DATADIR%%/pl/init.yap
%%DATADIR%%/pl/listing.yap
%%DATADIR%%/pl/udi.yap
%%DATADIR%%/pl/lists.yap
%%DATADIR%%/pl/messages.yap
%%DATADIR%%/pl/load_foreign.yap
%%DATADIR%%/pl/modules.yap
%%DATADIR%%/pl/preds.yap
%%DATADIR%%/pl/profile.yap
%%DATADIR%%/pl/protect.yap
%%DATADIR%%/pl/save.yap
%%DATADIR%%/pl/setof.yap
%%DATADIR%%/pl/signals.yap
%%DATADIR%%/pl/sockets.yap
%%DATADIR%%/pl/sort.yap
%%DATADIR%%/pl/statistics.yap
%%DATADIR%%/pl/strict_iso.yap
%%DATADIR%%/pl/tabling.yap
%%DATADIR%%/pl/threads.yap
%%DATADIR%%/pl/utils.yap
%%DATADIR%%/pl/yapor.yap
%%DATADIR%%/pl/yio.yap
%%DATADIR%%/unix.pl
%%DATADIR%%/random.pl
%%DATADIR%%/socket.pl
%%DATADIR%%/cgi.pl
%%DATADIR%%/memfile.pl
%%DATADIR%%/filesex.pl
%%DATADIR%%/mime.pl
%%DATADIR%%/crypt.pl
%%DATADIR%%/time.pl
%%DATADIR%%/streaminfo.pl
%%DATADIR%%/process.pl
%%DATADIR%%/prolog_server.pl
%%DATADIR%%/sha.pl
%%DATADIR%%/uri.pl
%%DATADIR%%/http/web/icons/back.png
%%DATADIR%%/http/web/icons/c.png
%%DATADIR%%/http/web/icons/compressed.png
%%DATADIR%%/http/web/icons/folder.png
%%DATADIR%%/http/web/icons/generic.png
%%DATADIR%%/http/web/icons/layout.png
%%DATADIR%%/http/web/icons/openid-logo-square.png
%%DATADIR%%/http/web/icons/openid-logo-tiny.png
%%DATADIR%%/http/html_write.pl
%%DATADIR%%/http/http_client.pl
%%DATADIR%%/http/http_header.pl
%%DATADIR%%/http/http_mime_plugin.pl
%%DATADIR%%/http/http_sgml_plugin.pl
%%DATADIR%%/http/mimepack.pl
%%DATADIR%%/http/mimetype.pl
%%DATADIR%%/http/dcg_basics.pl
%%DATADIR%%/http/thread_httpd.pl
%%DATADIR%%/http/xpce_httpd.pl
%%DATADIR%%/http/inetd_httpd.pl
%%DATADIR%%/http/http_wrapper.pl
%%DATADIR%%/http/http_open.pl
%%DATADIR%%/http/http_session.pl
%%DATADIR%%/http/http_error.pl
%%DATADIR%%/http/http_parameters.pl
%%DATADIR%%/http/http_dispatch.pl
%%DATADIR%%/http/http_authenticate.pl
%%DATADIR%%/http/http_stream.pl
%%DATADIR%%/http/http_log.pl
%%DATADIR%%/http/http_path.pl
%%DATADIR%%/http/http_hook.pl
%%DATADIR%%/http/html_head.pl
%%DATADIR%%/http/http_exception.pl
%%DATADIR%%/http/json.pl
%%DATADIR%%/http/http_json.pl
%%DATADIR%%/http/json_convert.pl
%%DATADIR%%/http/http_dirindex.pl
%%DATADIR%%/http/http_server_files.pl
%%DATADIR%%/http/http_pwp.pl
%%DATADIR%%/http/http_host.pl
%%DATADIR%%/http/http_openid.pl
%%DATADIR%%/http/js_write.pl
%%DATADIR%%/http/README
%%DATADIR%%/plunit.pl
%%DATADIR%%/test_wizard.pl
%%DATADIR%%/test_cover.pl
%%DATADIR%%/DTD/HTML4.dcl
%%DATADIR%%/DTD/HTML4.dtd
%%DATADIR%%/DTD/HTML4.soc
%%DATADIR%%/DTD/HTMLlat1.ent
%%DATADIR%%/DTD/HTMLspec.ent
%%DATADIR%%/DTD/HTMLsym.ent
%%DATADIR%%/sgml.pl
%%DATADIR%%/xsdp_types.pl
%%DATADIR%%/iso_639.pl
%%DATADIR%%/sgml_write.pl
%%DATADIR%%/xpath.pl
%%DATADIR%%/pwp.pl
%%DATADIR%%/pltotex.pl
%%DATADIR%%/rdf.pl
%%DATADIR%%/rdf_parser.pl
%%DATADIR%%/rdf_triple.pl
%%DATADIR%%/rewrite.pl
%%DATADIR%%/rdf_ntriples.pl
%%DATADIR%%/rdf_write.pl
%%DATADIR%%/semweb/rdfs.rdfs
%%DATADIR%%/semweb/dc.rdfs
%%DATADIR%%/semweb/eor.rdfs
%%DATADIR%%/semweb/owl.owl
%%DATADIR%%/semweb/rdf_library.ttl
%%DATADIR%%/semweb/rdf_db.pl
%%DATADIR%%/semweb/rdfs.pl
%%DATADIR%%/semweb/rdf_edit.pl
%%DATADIR%%/semweb/rdf_litindex.pl
%%DATADIR%%/semweb/rdf_persistency.pl
%%DATADIR%%/semweb/rdf_turtle.pl
%%DATADIR%%/semweb/rdf_cache.pl
%%DATADIR%%/semweb/rdf_http_plugin.pl
%%DATADIR%%/semweb/rdf_zlib_plugin.pl
%%DATADIR%%/semweb/rdf_portray.pl
%%DATADIR%%/semweb/rdf_compare.pl
%%DATADIR%%/semweb/turtle_base.pl
%%DATADIR%%/semweb/rdf_turtle_write.pl
%%DATADIR%%/semweb/rdf_library.pl
%%DATADIR%%/semweb/sparql_client.pl
%%DATADIR%%/semweb/README
%%DATADIR%%/zlib.pl
%%DATADIR%%/dialect/swi/INDEX.pl
%%DATADIR%%/dialect/swi/listing.pl
%%DATADIR%%/dialect/swi/readutil.pl
%%DATADIR%%/dialect/commons.yap
%%DATADIR%%/dialect/hprolog.yap
%%DATADIR%%/dialect/swi.yap
%%DATADIR%%/INDEX.pl
%%DATADIR%%/apply.yap
%%DATADIR%%/apply_macros.yap
%%DATADIR%%/arg.yap
%%DATADIR%%/assoc.yap
%%DATADIR%%/atts.yap
%%DATADIR%%/autoloader.yap
%%DATADIR%%/avl.yap
%%DATADIR%%/bhash.yap
%%DATADIR%%/charsio.yap
%%DATADIR%%/cleanup.yap
%%DATADIR%%/clpfd.pl
%%DATADIR%%/coinduction.yap
%%DATADIR%%/dbqueues.yap
%%DATADIR%%/dbusage.yap
%%DATADIR%%/dgraphs.yap
%%DATADIR%%/expand_macros.yap
%%DATADIR%%/gensym.yap
%%DATADIR%%/hacks.yap
%%DATADIR%%/heaps.yap
%%DATADIR%%/lambda.pl
%%DATADIR%%/lineutils.yap
%%DATADIR%%/lists.yap
%%DATADIR%%/nb.yap
%%DATADIR%%/ordsets.yap
%%DATADIR%%/maplist.yap
%%DATADIR%%/matlab.yap
%%DATADIR%%/matrix.yap
%%DATADIR%%/prandom.yap
%%DATADIR%%/queues.yap
%%DATADIR%%/random.yap
%%DATADIR%%/r_session.yap
%%DATADIR%%/rbtrees.yap
%%DATADIR%%/readutil.yap
%%DATADIR%%/regexp.yap
%%DATADIR%%/rltree.yap
%%DATADIR%%/splay.yap
%%DATADIR%%/stringutils.yap
%%DATADIR%%/clp/clp_events.pl
%%DATADIR%%/system.yap
%%DATADIR%%/terms.yap
%%DATADIR%%/tries.yap
%%DATADIR%%/itries.yap
%%DATADIR%%/timeout.yap
%%DATADIR%%/trees.yap
%%DATADIR%%/ugraphs.yap
%%DATADIR%%/undgraphs.yap
%%DATADIR%%/varnumbers.yap
%%DATADIR%%/wdgraphs.yap
%%DATADIR%%/wgraphs.yap
%%DATADIR%%/wundgraphs.yap
%%DATADIR%%/lam_mpi.yap
%%DATADIR%%/ypp.yap
%%DATADIR%%/c_alarms.yap
%%DATADIR%%/flags.yap
%%DATADIR%%/block_diagram.yap
%%DATADIR%%/minisat_examples/adder.pl
%%DATADIR%%/minisat_examples/pearl_examples.pl
%%DATADIR%%/cnf.pl
%%DATADIR%%/minisat.pl
%%DATADIR%%/base64.pl
%%DATADIR%%/broadcast.pl
%%DATADIR%%/date.pl
%%DATADIR%%/debug.pl
%%DATADIR%%/maplist.pl
%%DATADIR%%/nb_set.pl
%%DATADIR%%/operators.pl
%%DATADIR%%/option.pl
%%DATADIR%%/prolog_source.pl
%%DATADIR%%/prolog_xref.pl
%%DATADIR%%/quintus.pl
%%DATADIR%%/record.pl
%%DATADIR%%/settings.pl
%%DATADIR%%/shlib.pl
%%DATADIR%%/url.pl
%%DATADIR%%/utf8.pl
%%DATADIR%%/aggregate.pl
%%DATADIR%%/ctypes.pl
%%DATADIR%%/error.pl
%%DATADIR%%/occurs.yap
%%DATADIR%%/pairs.pl
%%DATADIR%%/icon_address.pl
%%DATADIR%%/pillow.pl
%%DATADIR%%/clpbn/learning/bnt_parms.yap
%%DATADIR%%/clpbn/learning/em.yap
%%DATADIR%%/clpbn/learning/learn_utils.yap
%%DATADIR%%/clpbn/learning/mle.yap
%%DATADIR%%/clpbn/examples/School/README
%%DATADIR%%/clpbn/examples/School/evidence_128.yap
%%DATADIR%%/clpbn/examples/School/schema.yap
%%DATADIR%%/clpbn/examples/School/school_128.yap
%%DATADIR%%/clpbn/examples/School/school_32.yap
%%DATADIR%%/clpbn/examples/School/school_64.yap
%%DATADIR%%/clpbn/examples/School/tables.yap
%%DATADIR%%/clpbn/examples/cg.yap
%%DATADIR%%/clpbn/examples/sprinkler.yap
%%DATADIR%%/clpbn/aggregates.yap
%%DATADIR%%/clpbn/bnt.yap
%%DATADIR%%/clpbn/bp.yap
%%DATADIR%%/clpbn/connected.yap
%%DATADIR%%/clpbn/discrete_utils.yap
%%DATADIR%%/clpbn/display.yap
%%DATADIR%%/clpbn/dists.yap
%%DATADIR%%/clpbn/evidence.yap
%%DATADIR%%/clpbn/gibbs.yap
%%DATADIR%%/clpbn/graphs.yap
%%DATADIR%%/clpbn/graphviz.yap
%%DATADIR%%/clpbn/hmm.yap
%%DATADIR%%/clpbn/jt.yap
%%DATADIR%%/clpbn/matrix_cpt_utils.yap
%%DATADIR%%/clpbn/pgrammar.yap
%%DATADIR%%/clpbn/table.yap
%%DATADIR%%/clpbn/topsort.yap
%%DATADIR%%/clpbn/utils.yap
%%DATADIR%%/clpbn/vel.yap
%%DATADIR%%/clpbn/viterbi.yap
%%DATADIR%%/clpbn/xbif.yap
%%DATADIR%%/clpbn.yap
%%DATADIR%%/problog/extlists.yap
%%DATADIR%%/problog/flags.yap
%%DATADIR%%/problog/gflags.yap
%%DATADIR%%/problog/grounder.yap
%%DATADIR%%/problog/hash_table.yap
%%DATADIR%%/problog/intervals.yap
%%DATADIR%%/problog/logger.yap
%%DATADIR%%/problog/mc_DNF_sampling.yap
%%DATADIR%%/problog/os.yap
%%DATADIR%%/problog/print.yap
%%DATADIR%%/problog/sampling.yap
%%DATADIR%%/problog/tabling.yap
%%DATADIR%%/problog/timer.yap
%%DATADIR%%/problog/ptree.yap
%%DATADIR%%/problog/variable_elimination.yap
%%DATADIR%%/problog/print_learning.yap
%%DATADIR%%/problog/utils_learning.yap
%%DATADIR%%/problog/version_control.yap
%%DATADIR%%/problog/nestedtries.yap
%%DATADIR%%/problog/utils.yap
%%DATADIR%%/problog/bdd.yap
%%DATADIR%%/problog/ad_converter.yap
%%DATADIR%%/problog/termhandling.yap
%%DATADIR%%/problog/completion.yap
%%DATADIR%%/problog/discrete.yap
%%DATADIR%%/problog/variables.yap
%%DATADIR%%/problog_examples/alarm.pl
%%DATADIR%%/problog_examples/graph.pl
%%DATADIR%%/problog_examples/graph_tabled.pl
%%DATADIR%%/problog_examples/learn_graph.pl
%%DATADIR%%/problog_examples/office.pl
%%DATADIR%%/problog_examples/viralmarketing.pl
%%DATADIR%%/problog_examples/aProbLog_examples.pl
%%DATADIR%%/problog_examples/viralmarketing_tabled.pl
%%DATADIR%%/problog.yap
%%DATADIR%%/chr/chr_runtime.pl
%%DATADIR%%/chr/chr_op.pl
%%DATADIR%%/chr/chr_translate.pl
%%DATADIR%%/chr/chr_debug.pl
%%DATADIR%%/chr/chr_messages.pl
%%DATADIR%%/chr/pairlist.pl
%%DATADIR%%/chr/clean_code.pl
%%DATADIR%%/chr/find.pl
%%DATADIR%%/chr/a_star.pl
%%DATADIR%%/chr/binomialheap.pl
%%DATADIR%%/chr/builtins.pl
%%DATADIR%%/chr/chr_hashtable_store.pl
%%DATADIR%%/chr/listmap.pl
%%DATADIR%%/chr/guard_entailment.pl
%%DATADIR%%/chr/chr_compiler_options.pl
%%DATADIR%%/chr/chr_compiler_utility.pl
%%DATADIR%%/chr/chr_compiler_errors.pl
%%DATADIR%%/chr/chr_integertable_store.pl
%%DATADIR%%/chr/README
%%DATADIR%%/problog_lfi.yap
%%DATADIR%%/dtproblog.yap
%%DATADIR%%/aproblog.yap
%%DATADIR%%/problog_learning.yap
%%DATADIR%%/chr.pl
%%DATADIR%%/clpr/bb_r.pl
%%DATADIR%%/clpr/bv_r.pl
%%DATADIR%%/clpr/fourmotz_r.pl
%%DATADIR%%/clpr/ineq_r.pl
%%DATADIR%%/clpr/itf_r.pl
%%DATADIR%%/clpr/nf_r.pl
%%DATADIR%%/clpr/store_r.pl
%%DATADIR%%/clpq/bb_q.pl
%%DATADIR%%/clpq/bv_q.pl
%%DATADIR%%/clpq/fourmotz_q.pl
%%DATADIR%%/clpq/ineq_q.pl
%%DATADIR%%/clpq/itf_q.pl
%%DATADIR%%/clpq/nf_q.pl
%%DATADIR%%/clpq/store_q.pl
%%DATADIR%%/clpqr/class.pl
%%DATADIR%%/clpqr/dump.pl
%%DATADIR%%/clpqr/geler.pl
%%DATADIR%%/clpqr/itf.pl
%%DATADIR%%/clpqr/ordering.pl
%%DATADIR%%/clpqr/project.pl
%%DATADIR%%/clpqr/redund.pl
%%DATADIR%%/clpqr/README
%%DATADIR%%/clpr.pl
%%DATADIR%%/clpq.pl