- Fix build with clang

PR:		185500
Submitted by:	Ports Fury
This commit is contained in:
Martin Wilke 2014-01-19 09:24:34 +00:00
parent a869c8fbe1
commit 33e4c2e429
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=340240
2 changed files with 28 additions and 2 deletions

View File

@ -8,12 +8,16 @@ CATEGORIES= emulators
MASTER_SITES= http://www.lcdf.org/~eddietwo/xbraitenberg/
MAINTAINER= ports@FreeBSD.org
COMMENT= A Braitenberg vehicle simulator with pseudo-physics
COMMENT= Braitenberg vehicle simulator with pseudo-physics
USE_XORG= x11 ice sm xext
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_fpermissive=no
PLIST_FILES= bin/xbraitenberg
NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
'/operator bool() const/d' ${WRKSRC}/operator.hh
.include <bsd.port.mk>

View File

@ -0,0 +1,22 @@
--- permstr.hh.orig
+++ permstr.hh
@@ -4,6 +4,10 @@
#include <cstddef>
#include <cstdarg>
+class PermString;
+
+PermString permprintf(const char *, ...);
+
class PermString { struct Doodad; public:
typedef Doodad *Capsule;
@@ -91,7 +95,7 @@
inline int
hashcode(PermString s)
{
- return (int)(s.cc());
+ return (int)(size_t)(s.cc());
}
#endif