Update to 1.6.5.2
Use PLIST_FILES PR: 80764 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
parent
24a9bb3866
commit
3398ea546b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=134862
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= xsidplay
|
||||
PORTVERSION= 1.6.5.1a
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.6.5.2
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= audio emulators
|
||||
MASTER_SITES= http://www.geocities.com/SiliconValley/Lakes/5147/sidplay/packages/
|
||||
@ -16,25 +15,20 @@ EXTRACT_SUFX= .tgz
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Graphical front end for libsidplay
|
||||
|
||||
.if defined(WITH_SIDPLAY2)
|
||||
LIB_DEPENDS= sidplay2.0:${PORTSDIR}/audio/libsidplay2
|
||||
.else
|
||||
LIB_DEPENDS= sidplay.1:${PORTSDIR}/audio/libsidplay
|
||||
.endif
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_QT_VER= 3
|
||||
USE_GNOME= gnometarget
|
||||
WANT_GNOME= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --with-qt3 --with-qt-binaries=${X11BASE}/bin
|
||||
.if defined(WITH_SIDPLAY2)
|
||||
CONFIGURE_ARGS+= --with-sidplay2
|
||||
.endif
|
||||
QTCPPFLAGS+= ${PTHREAD_CFLAGS}
|
||||
QTCFGLIBS+= ${PTHREAD_LIBS}
|
||||
USE_REINPLACE= yes
|
||||
CONFIGURE_ARGS= --with-qt3 --with-qt-binaries=${X11BASE}/bin
|
||||
|
||||
MAN1= xsidplay.1
|
||||
PLIST_FILES= bin/xsidplay
|
||||
|
||||
QTCPPFLAGS+= ${PTHREAD_CFLAGS}
|
||||
QTCFGLIBS+= ${PTHREAD_LIBS}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
@ -42,22 +36,40 @@ MAN1= xsidplay.1
|
||||
CFLAGS+= -O0
|
||||
.endif
|
||||
|
||||
pre-patch:
|
||||
.for file in configure src/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|lib-mt|libqt-mt|g' ${WRKSRC}/${file}
|
||||
.endfor
|
||||
@${REINPLACE_CMD} -e 's|-lqt|-lqt-mt|g' ${WRKSRC}/configure
|
||||
.if ${HAVE_GNOME:Mesound}!=""
|
||||
USE_GNOME+= esound
|
||||
.else
|
||||
CONFIGURE_ENV+= ac_cv_path_ESD_CONFIG=""
|
||||
.endif
|
||||
|
||||
.if defined(WITH_ARTS)
|
||||
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
|
||||
.else
|
||||
CONFIGURE_ENV+= ac_cv_path_ARTSC_CONFIG=""
|
||||
.endif
|
||||
|
||||
.if defined(WITH_SIDPLAY2)
|
||||
LIB_DEPENDS+= sidplay2.1:${PORTSDIR}/audio/libsidplay2
|
||||
CONFIGURE_ARGS+= --with-sidplay2
|
||||
QTCFGLIBS+= -Wl,--rpath,${LOCALBASE}/lib/sidplay/builders
|
||||
.else
|
||||
LIB_DEPENDS+= sidplay.1:${PORTSDIR}/audio/libsidplay
|
||||
.endif
|
||||
|
||||
.if defined(NOPORTDOCS)
|
||||
PORTDOCS= README STIL.faq hv_sids.faq
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}|g' ${WRKSRC}/xsidplay.1
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${PREFIX}/share/pixmaps
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/src/xsidplay ${PREFIX}/bin
|
||||
@${INSTALL_DATA} ${WRKSRC}/xsidplay.xpm ${PREFIX}/share/pixmaps
|
||||
@${INSTALL_MAN} ${WRKSRC}/xsidplay.1 ${MANPREFIX}/man/man1
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/xsidplay ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/xsidplay.1 ${MANPREFIX}/man/man1
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/*.faq ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/*.faq ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (xsidplay-1.6.5.1a.tgz) = abe90bc6b7d552969bdd1db38f0a449b
|
||||
SIZE (xsidplay-1.6.5.1a.tgz) = 355698
|
||||
MD5 (xsidplay-1.6.5.2.tgz) = 68669cf99904a7384a65ded5fcdd3c97
|
||||
SIZE (xsidplay-1.6.5.2.tgz) = 508860
|
||||
|
@ -1,22 +0,0 @@
|
||||
--- src/songlendb/File.cpp.orig Sun Mar 3 19:00:03 2002
|
||||
+++ src/songlendb/File.cpp Thu Feb 17 22:46:43 2005
|
||||
@@ -29,6 +29,7 @@
|
||||
#endif
|
||||
using namespace std;
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include "File.h"
|
||||
|
||||
// String comparison functor for sort function.
|
||||
@@ -126,9 +127,9 @@
|
||||
streampos fileLen = myIn.tellg();
|
||||
#endif
|
||||
#ifdef XSID_HAVE_NOTHROW
|
||||
- pDB = new(std::nothrow) char[fileLen+1L];
|
||||
+ pDB = new(std::nothrow) char[(off_t)fileLen+1L];
|
||||
#else
|
||||
- pDB = new char[fileLen+1L];
|
||||
+ pDB = new char[(off_t)fileLen+1L];
|
||||
#endif
|
||||
if ( pDB == 0 )
|
||||
{
|
@ -1,7 +0,0 @@
|
||||
bin/xsidplay
|
||||
share/pixmaps/xsidplay.xpm
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/STIL.faq
|
||||
%%PORTDOCS%%%%DOCSDIR%%/hv_sids.faq
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@unexec rmdir %D/share/pixmaps 2>/dev/null || true
|
Loading…
Reference in New Issue
Block a user