net-im/libnice update to 0.1.18
PR: 247547 Submitted by: swills Approved by: maintainer timeout
This commit is contained in:
parent
7c71de28db
commit
3367f62c42
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=556495
@ -2,37 +2,37 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libnice
|
||||
PORTVERSION= 0.1.13
|
||||
PORTVERSION= 0.1.18
|
||||
CATEGORIES= net-im devel
|
||||
MASTER_SITES= http://nice.freedesktop.org/releases/
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= Library and transmitter that implements ICE-19
|
||||
|
||||
USES= gettext gmake gnome libtool localbase:ldflags pathfix pkgconfig
|
||||
LICENSE= LGPL21 MPL11
|
||||
LICENSE_COMB= dual
|
||||
|
||||
LIB_DEPENDS= libgnutls.so:security/gnutls
|
||||
BUILD_DEPENDS= gtk-doc>0:textproc/gtk-doc
|
||||
|
||||
USES= gettext gmake gnome libtool localbase:ldflags pathfix pkgconfig meson python
|
||||
USE_LDCONFIG= yes
|
||||
USE_GNOME= glib20 introspection:build
|
||||
GNU_CONFIGURE= yes
|
||||
CPPFLAGS+= -DHAVE_GETIFADDRS
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
.if !defined(LIBNICE_SLAVE)
|
||||
OPTIONS_DEFINE= GUPNP
|
||||
GUPNP_MESON_ENABLED= gupnp
|
||||
GUPNP_DESC= UPnP IGD port mapping support
|
||||
GUPNP_LIB_DEPENDS+= libgupnp-igd-1.0.so:net/gupnp-igd
|
||||
GUPNP_CONFIGURE_ENABLE= gupnp
|
||||
.endif
|
||||
|
||||
MESON_ARGS+=-Dtests=disabled
|
||||
|
||||
.if defined(LIBNICE_SLAVE)
|
||||
USE_GSTREAMER1= yes
|
||||
CONFIGURE_ARGS+=--with-gstreamer --without-gstreamer-0.10
|
||||
MESON_ARGS+=-Dgstreamer=enabled -Dgst_version=1.0
|
||||
.else
|
||||
CONFIGURE_ARGS= --without-gstreamer --without-gstreamer-0.10
|
||||
MESON_ARGS+=-Dgstreamer=disabled -Dgtk_doc=enabled
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|-Wno-missing-field-initializers|#|g'
|
||||
@${REINPLACE_CMD} -e 's|-Werror||g' ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (libnice-0.1.13.tar.gz) = 61112d9f3be933a827c8365f20551563953af6718057928f51f487bfe88419e1
|
||||
SIZE (libnice-0.1.13.tar.gz) = 912374
|
||||
TIMESTAMP = 1605918969
|
||||
SHA256 (libnice-0.1.18.tar.gz) = 5eabd25ba2b54e817699832826269241abaa1cf78f9b240d1435f936569273f4
|
||||
SIZE (libnice-0.1.18.tar.gz) = 439791
|
||||
|
@ -1,16 +0,0 @@
|
||||
--- configure.ac.orig 2015-08-08 16:29:47.571735000 +0200
|
||||
+++ configure.ac 2015-08-08 16:33:23.011860000 +0200
|
||||
@@ -231,11 +231,10 @@
|
||||
[
|
||||
have_gst_check=no
|
||||
])
|
||||
-
|
||||
- AM_CONDITIONAL(HAVE_GST_CHECK, test "$have_gst_check" = yes)
|
||||
-
|
||||
])
|
||||
|
||||
+AM_CONDITIONAL(HAVE_GST_CHECK, test "$have_gst_check" = yes)
|
||||
+
|
||||
AS_IF([test "$with_gstreamer010" != no], [
|
||||
|
||||
PKG_CHECK_MODULES(GST010, [
|
@ -1,13 +0,0 @@
|
||||
--- Makefile.in.orig 2013-05-22 07:47:08.000000000 +0000
|
||||
+++ Makefile.in 2013-05-22 07:47:23.000000000 +0000
|
||||
@@ -311,9 +311,7 @@
|
||||
agent \
|
||||
nice \
|
||||
gst \
|
||||
- docs \
|
||||
- tests \
|
||||
- examples
|
||||
+ docs
|
||||
|
||||
DISTCHECK_CONFIGURE_FLAGS = --disable-assert -enable-gtk-doc
|
||||
EXTRA_DIST = \
|
@ -1,23 +0,0 @@
|
||||
--- configure.orig 2015-08-08 16:33:30.121861000 +0200
|
||||
+++ configure 2015-08-08 16:33:52.533583000 +0200
|
||||
@@ -15751,7 +15751,9 @@
|
||||
|
||||
fi
|
||||
|
||||
- if test "$have_gst_check" = yes; then
|
||||
+fi
|
||||
+
|
||||
+ if test "$have_gst_check" = yes; then
|
||||
HAVE_GST_CHECK_TRUE=
|
||||
HAVE_GST_CHECK_FALSE='#'
|
||||
else
|
||||
@@ -15760,9 +15762,6 @@
|
||||
fi
|
||||
|
||||
|
||||
-
|
||||
-fi
|
||||
-
|
||||
if test "$with_gstreamer010" != no; then :
|
||||
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- docs/reference/libnice/meson.build.orig 2020-11-25 16:39:27 UTC
|
||||
+++ docs/reference/libnice/meson.build
|
||||
@@ -26,7 +26,7 @@ ignore_headers = [
|
||||
]
|
||||
|
||||
if dependency('gtk-doc', version: '<1.30', required: false).found()
|
||||
- prog_python = import('python').find_installation('python3')
|
||||
+ prog_python = import('python').find_installation()
|
||||
fake_makefile = custom_target ('libnice-docs-test-Makefile',
|
||||
output: 'Makefile',
|
||||
command: [
|
@ -1,11 +0,0 @@
|
||||
--- gst/Makefile.in.orig 2013-05-22 07:56:38.000000000 +0000
|
||||
+++ gst/Makefile.in 2013-05-22 07:58:56.000000000 +0000
|
||||
@@ -319,7 +319,7 @@
|
||||
-I $(top_srcdir)/stun
|
||||
|
||||
COMMON_LIBADD = \
|
||||
- $(top_builddir)/nice/libnice.la
|
||||
+ -lnice
|
||||
|
||||
|
||||
# libgstnice
|
@ -19,7 +19,7 @@ include/stun/win32_common.h
|
||||
lib/girepository-1.0/Nice-0.1.typelib
|
||||
lib/libnice.so
|
||||
lib/libnice.so.10
|
||||
lib/libnice.so.10.6.2
|
||||
lib/libnice.so.10.11.0
|
||||
libdata/pkgconfig/nice.pc
|
||||
share/gir-1.0/Nice-0.1.gir
|
||||
share/gtk-doc/html/libnice/NiceAgent.html
|
||||
@ -34,7 +34,6 @@ share/gtk-doc/html/libnice/ch04.html
|
||||
share/gtk-doc/html/libnice/ch05.html
|
||||
share/gtk-doc/html/libnice/home.png
|
||||
share/gtk-doc/html/libnice/index.html
|
||||
share/gtk-doc/html/libnice/index.sgml
|
||||
share/gtk-doc/html/libnice/ix03.html
|
||||
share/gtk-doc/html/libnice/ix04.html
|
||||
share/gtk-doc/html/libnice/ix05.html
|
||||
@ -45,6 +44,11 @@ share/gtk-doc/html/libnice/ix09.html
|
||||
share/gtk-doc/html/libnice/ix10.html
|
||||
share/gtk-doc/html/libnice/ix11.html
|
||||
share/gtk-doc/html/libnice/ix12.html
|
||||
share/gtk-doc/html/libnice/ix13.html
|
||||
share/gtk-doc/html/libnice/ix14.html
|
||||
share/gtk-doc/html/libnice/ix15.html
|
||||
share/gtk-doc/html/libnice/ix16.html
|
||||
share/gtk-doc/html/libnice/ix17.html
|
||||
share/gtk-doc/html/libnice/left-insensitive.png
|
||||
share/gtk-doc/html/libnice/left.png
|
||||
share/gtk-doc/html/libnice/libnice-Bind.html
|
||||
@ -65,6 +69,7 @@ share/gtk-doc/html/libnice/pt03.html
|
||||
share/gtk-doc/html/libnice/pt04.html
|
||||
share/gtk-doc/html/libnice/right-insensitive.png
|
||||
share/gtk-doc/html/libnice/right.png
|
||||
share/gtk-doc/html/libnice/states.png
|
||||
share/gtk-doc/html/libnice/style.css
|
||||
share/gtk-doc/html/libnice/up-insensitive.png
|
||||
share/gtk-doc/html/libnice/up.png
|
||||
|
Loading…
Reference in New Issue
Block a user