As advertised, remove the electricsheep port. The project has had

numerous "issues" over the last couple of years, and the most recent
incarnation has no source tarball available for download. Additionally,
the "Linux" version of the code is not currently maintained, and some
of the features do not work.
This commit is contained in:
Doug Barton 2009-10-02 18:54:33 +00:00
parent f94e70331e
commit 3346a9a9e4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=242388
7 changed files with 1 additions and 156 deletions

1
MOVED
View File

@ -4182,3 +4182,4 @@ audio/gmpc-stopbutton||2009-09-24|Unmaintained upstream
mail/wanderlust-devel||2009-09-28|Port addition canceled
sysutils/zccron|sysutils/p5-ZConf-Cron|2009-09-27|Please use sysutils/p5-ZConf-Cron
devel/p5-Cwd|devel/p5-PathTools|2009-09-30|Please use devel/p5-PathTools
x11/electricsheep||2009-10-02|No source tarball, Unix code unmaintained

View File

@ -67,7 +67,6 @@
SUBDIR += ecore-x11
SUBDIR += editres
SUBDIR += efreet
SUBDIR += electricsheep
SUBDIR += elicit
SUBDIR += emprint
SUBDIR += emu

View File

@ -1,69 +0,0 @@
# New ports collection makefile for: electricsheep
# Date created: 11 Feb 2002
# Whom: David Yeske <dyeske@gmail.com>
#
# $FreeBSD$
#
PORTNAME= electricsheep
PORTVERSION= 2.6.8
PORTREVISION= 7
PORTEPOCH= 1
CATEGORIES= x11
MASTER_SITES= http://electricsheep.org/
MAINTAINER= dougb@FreeBSD.org
COMMENT= A nice distributed screensaver
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
jpeg.10:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
RUN_DEPENDS= xloadimage:${PORTSDIR}/x11/xloadimage \
xsetbg:${PORTSDIR}/x11/xloadimage \
curl:${PORTSDIR}/ftp/curl
DEPRECATED= No tarball for new versions, sheep server is gone
EXPIRATION_DATE= 2009-10-01
MAKE_JOBS_SAFE= yes
USE_SDL= sdl
GNU_CONFIGURE= yes
USE_XORG= x11 xau xdmcp xext xi xrandr xv sm ice
MAN1= electricsheep.1
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
LIBTOOLFILES= configure mpeg2dec/configure flam3/configure
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -e \
's|/usr/X11R6/lib/xscreensaver/config|${LOCALBASE}/share/xscreensaver/config|' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \
's|/usr/local/share|${DATADIR}|' \
${WRKSRC}/electricsheep.c
@${REINPLACE_CMD} -e \
's|-Wall||; \
s|CFLAGS=\$$OPT_CFLAGS|#CFLAGS=\$$OPT_CFLAGS|' \
${WRKSRC}/mpeg2dec/configure
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/electricsheep ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/electricsheep-voter ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/flam3/flam3-animate ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/flam3/flam3-convert ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/flam3/flam3-genome ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/flam3/flam3-render ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/mpeg2dec/src/mpeg2dec_onroot ${PREFIX}/bin
@${INSTALL} -d -m 0755 ${DATADIR}
@${INSTALL_DATA} ${WRKSRC}/*.png ${DATADIR}
@${INSTALL_MAN} ${WRKSRC}/electricsheep.man ${PREFIX}/man/man1/electricsheep.1
.include <bsd.port.post.mk>

View File

@ -1,3 +0,0 @@
MD5 (electricsheep-2.6.8.tar.gz) = 5c3535a7c679d67d460c1d9e259a5d38
SHA256 (electricsheep-2.6.8.tar.gz) = c593e4be3fc6674bfd77277e7e3326d48885b8b105f19221398f97a31d6698ba
SIZE (electricsheep-2.6.8.tar.gz) = 1355274

View File

@ -1,65 +0,0 @@
--- mpeg2dec/libvo/video_out_x11.c.orig 2006-06-27 01:28:08.000000000 +0600
+++ mpeg2dec/libvo/video_out_x11.c 2008-06-20 18:26:01.000000000 +0600
@@ -531,14 +531,18 @@
if (window_id == -3) {
/* display zoomed on the (virtual) root window */
instance->window = DefaultRootWindow (instance->display);
- instance->displaywidth = DisplayWidth(instance->display, DefaultScreen (instance->display));
- instance->displayheight = DisplayHeight(instance->display, DefaultScreen (instance->display));
+ XWindowAttributes xgwa;
+ XGetWindowAttributes (instance->display, instance->window, &xgwa);
+ instance->displaywidth = xgwa.width;
+ instance->displayheight = xgwa.height;
} else if (window_id == -2) {
/* display non-zoomed on the (virtual) root window */
int w, h;
- w = DisplayWidth(instance->display, DefaultScreen (instance->display));
- h = DisplayHeight(instance->display, DefaultScreen (instance->display));
instance->window = DefaultRootWindow (instance->display);
+ XWindowAttributes xgwa;
+ XGetWindowAttributes (instance->display, instance->window, &xgwa);
+ w = xgwa.width;
+ h = xgwa.height;
instance->corner_x = (w - instance->width)/2;
instance->corner_y = (h - instance->height)/2;
} else if (window_id == -1) {
@@ -593,7 +597,9 @@
/* this would break the solaris port though :-/ */
/* fuck solaris, plug the leak! */
+#ifndef __FreeBSD__
shmctl(instance->shminfo.shmid, IPC_RMID, 0);
+#endif
/* XShmAttach fails on remote displays, so we have to catch this event */
@@ -612,6 +618,9 @@
return NULL;
}
+#ifdef __FreeBSD__
+ shmctl(instance->shminfo.shmid, IPC_RMID, 0);
+#endif
return instance->shminfo.shmaddr;
}
@@ -1006,6 +1015,9 @@
if (instance == NULL)
return NULL;
+#ifdef __FreeBSD__
+ memset(instance, 0, sizeof(*instance));
+#endif
instance->vo.setup = x11_setup;
return (vo_instance_t *) instance;
}
@@ -1024,6 +1036,9 @@
if (instance == NULL)
return NULL;
+#ifdef __FreeBSD__
+ memset(instance, 0, sizeof(*instance));
+#endif
instance->vo.setup = xv_setup;
return (vo_instance_t *) instance;
}

View File

@ -1,8 +0,0 @@
Electricsheep is a distributed screensaver. It realizes the
collective dream of sleeping computers from all over the internet.
When the screen-saver is activated, the screen goes black and an
animated 'sheep' appears. Behind the scenes, the screen-saver
contacts an internet server and joins the parallel computation of
new sheep.
WWW: http://www.electricsheep.org/

View File

@ -1,10 +0,0 @@
bin/electricsheep
bin/electricsheep-voter
bin/mpeg2dec_onroot
bin/flam3-animate
bin/flam3-convert
bin/flam3-genome
bin/flam3-render
%%DATADIR%%/electricsheep-frown.png
%%DATADIR%%/electricsheep-smile.png
@dirrm %%DATADIR%%