- Update to 0.9.6
- Unbreak with ruby 1.9 <=0.9.5 doesn't build with ruby 1.9 - Development of ruby's termios has moved - Name changed to termios -> ruby-termios - Bump PORTREVISION on ports with dependency changes With Hat: ruby@ Sponsored by: RideCharge Inc. / TaxiMagic Checked by: make index
This commit is contained in:
parent
46452a19b5
commit
333962fb94
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=276410
1
MOVED
1
MOVED
@ -2233,3 +2233,4 @@ www/mod_layout2||2011-06-25|Has expired: will be unsupported by ASF when 2.4.0 i
|
||||
www/mod_macro2||2011-06-25|Has expired: will be unsupported by ASF when 2.4.0 is release, migrate to 2.2.x+ now
|
||||
www/mod_traf_thief||2011-06-25|Has expired: will be unsupported by ASF when 2.4.0 is release, migrate to 2.2.x+ now
|
||||
www/mod_transform||2011-06-25|Has expired: will be unsupported by ASF when 2.4.0 is release, migrate to 2.2.x+ now
|
||||
comms/ruby-termios|comms/rubygem-ruby-termios|2011-06-25|Development has moved, <=0.9.5 doesn't work with ruby 1.9.x
|
||||
|
@ -118,8 +118,8 @@
|
||||
SUBDIR += qsstv
|
||||
SUBDIR += remserial
|
||||
SUBDIR += ruby-serialport
|
||||
SUBDIR += ruby-termios
|
||||
SUBDIR += rubygem-callsign
|
||||
SUBDIR += rubygem-ruby-termios
|
||||
SUBDIR += rxtx
|
||||
SUBDIR += scmxx
|
||||
SUBDIR += scud
|
||||
|
@ -1,56 +0,0 @@
|
||||
# New ports collection makefile for: ruby-termios
|
||||
# Date created: 30 August 2001
|
||||
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= termios
|
||||
PORTVERSION= 0.9.5
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= comms ruby
|
||||
MASTER_SITES= http://arika.org/archive/
|
||||
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
|
||||
DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
|
||||
DIST_SUBDIR= ruby
|
||||
|
||||
MAINTAINER= ruby@FreeBSD.org
|
||||
COMMENT= A Ruby interface to termios
|
||||
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
USE_RUBY= yes
|
||||
USE_RUBY_EXTCONF= yes
|
||||
|
||||
INSTALL_TARGET= site-install
|
||||
|
||||
RUBY_RD_FILES= termios.rd
|
||||
|
||||
DOCS= ChangeLog README \
|
||||
${RUBY_RD_FILES} \
|
||||
${RUBY_RD_HTML_FILES}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${RUBY_VER} == 1.9
|
||||
BROKEN= does not compile with ruby 1.9
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
${RUBY} -i -pe 'gsub(/ttyS\d/, "cuaa0")' ${WRKSRC}/examples/*.rb
|
||||
${RUBY} -i -pe 'gsub(/\.c_/, ".")' ${WRKSRC}/examples/*.rb
|
||||
|
||||
post-install: doc-install
|
||||
|
||||
doc-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${RUBY_MODEXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/*.rb ${RUBY_MODEXAMPLESDIR}/
|
||||
${MKDIR} ${RUBY_MODDOCDIR}
|
||||
.for f in ${DOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
@ -1,2 +0,0 @@
|
||||
SHA256 (ruby/ruby-termios-0.9.5.tar.gz) = 75068c1c48c3f2bffa092dca079b97111a02c11914e3b0d43b4b42027459879c
|
||||
SIZE (ruby/ruby-termios-0.9.5.tar.gz) = 10927
|
@ -1,11 +0,0 @@
|
||||
--- extconf.rb.orig 2009-02-13 23:17:58.000000000 +0300
|
||||
+++ extconf.rb 2009-02-13 23:18:05.000000000 +0300
|
||||
@@ -3,7 +3,7 @@
|
||||
if have_header('termios.h') &&
|
||||
have_header('unistd.h')
|
||||
|
||||
- unless RUBY_VERSION < '1.7' || have_type("rb_io_t", ["ruby.h", "rubyio.h"])
|
||||
+ unless RUBY_VERSION < '1.7'
|
||||
have_struct_member("OpenFile", "fd", ["ruby.h", "rubyio.h"])
|
||||
end
|
||||
|
@ -1,5 +0,0 @@
|
||||
Ruby-termios is a Ruby interface to termios.
|
||||
|
||||
Authors: Akira Yamada <akira@arika.org>,
|
||||
Goto Kentaro <gotoken@math.sci.hokudai.ac.jp>
|
||||
WWW: http://www.ruby-lang.org/raa/list.rhtml?name=ruby-termios
|
@ -1,13 +0,0 @@
|
||||
%%RUBY_SITEARCHLIBDIR%%/termios.so
|
||||
%%RUBY_SITELIBDIR%%/termios.rb
|
||||
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
|
||||
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
|
||||
%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/termios.html
|
||||
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/termios.rd
|
||||
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
|
||||
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/modem_check0.rb
|
||||
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/modem_check1.rb
|
||||
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/modem_check2.rb
|
||||
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/secret_input1.rb
|
||||
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/secret_input2.rb
|
||||
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
|
19
comms/rubygem-ruby-termios/Makefile
Normal file
19
comms/rubygem-ruby-termios/Makefile
Normal file
@ -0,0 +1,19 @@
|
||||
# Ports collection makefile for: rubygem-ruby-termios
|
||||
# Date created: June 25, 2011
|
||||
# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ruby-termios
|
||||
PORTVERSION= 0.9.6
|
||||
CATEGORIES= comms rubygems
|
||||
MASTER_SITES= RG
|
||||
|
||||
MAINTAINER= ruby@FreeBSD.org
|
||||
COMMENT= A Ruby interface to termios
|
||||
|
||||
USE_RUBY= yes
|
||||
USE_RUBYGEMS= yes
|
||||
RUBYGEM_AUTOPLIST= yes
|
||||
|
||||
.include <bsd.port.mk>
|
2
comms/rubygem-ruby-termios/distinfo
Normal file
2
comms/rubygem-ruby-termios/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
SHA256 (rubygem/ruby-termios-0.9.6.gem) = 1ca5f258535db66613de6bbf04a1c34894972a0dd1e6e475a9adba5a74e1a2c3
|
||||
SIZE (rubygem/ruby-termios-0.9.6.gem) = 15360
|
3
comms/rubygem-ruby-termios/pkg-descr
Normal file
3
comms/rubygem-ruby-termios/pkg-descr
Normal file
@ -0,0 +1,3 @@
|
||||
Ruby-termios is a Ruby interface to termios.
|
||||
|
||||
WWW: https://github.com/arika/ruby-termios
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= rabbit
|
||||
PORTVERSION= 0.9.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= misc ruby
|
||||
MASTER_SITES= http://www.cozmixng.org/~kou/download/ \
|
||||
${MASTER_SITE_LOCAL:S|%SUBDIR%|tota/rabbit|}
|
||||
|
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= password
|
||||
PORTVERSION= 0.5.3
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= security ruby
|
||||
MASTER_SITES= http://www.caliban.org/files/ruby/
|
||||
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
|
||||
@ -18,7 +18,7 @@ MAINTAINER= stas@FreeBSD.org
|
||||
COMMENT= A Ruby library to create, verify and manipulate passwords
|
||||
|
||||
LIB_DEPENDS= crack:${PORTSDIR}/security/cracklib
|
||||
RUN_DEPENDS= ${LOCALBASE}/${SADIR}/termios.so:${PORTSDIR}/comms/ruby-termios
|
||||
RUN_DEPENDS= rubygem-ruby-termios>=0:${PORTSDIR}/comms/rubygem-ruby-termios
|
||||
|
||||
USE_RUBY= yes
|
||||
USE_RUBY_EXTCONF= yes
|
||||
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= net-scp
|
||||
PORTVERSION= 1.0.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= security rubygems
|
||||
MASTER_SITES= RG
|
||||
|
||||
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= net-sftp
|
||||
PORTVERSION= 2.0.5
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= security rubygems
|
||||
MASTER_SITES= RG
|
||||
|
||||
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= net-ssh-gateway
|
||||
PORTVERSION= 1.1.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= security rubygems
|
||||
MASTER_SITES= RG
|
||||
|
||||
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= net-ssh-multi
|
||||
PORTVERSION= 1.0.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= security rubygems
|
||||
MASTER_SITES= RG
|
||||
|
||||
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= net-ssh
|
||||
PORTVERSION= 2.1.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= security rubygems
|
||||
MASTER_SITES= RG
|
||||
|
||||
@ -22,7 +23,7 @@ USE_RUBYGEMS= yes
|
||||
RUBYGEM_AUTOPLIST= yes
|
||||
|
||||
.if !defined(WITHOUT_PROMPT_PASSPHRASES)
|
||||
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/termios.so:${PORTSDIR}/comms/ruby-termios
|
||||
RUN_DEPENDS+= rubygem-ruby-termios>=0:${PORTSDIR}/comms/rubygem-ruby-termios
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= capistrano
|
||||
PORTVERSION= 2.5.21
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= sysutils rubygems
|
||||
MASTER_SITES= RG
|
||||
|
||||
|
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= chef
|
||||
PORTVERSION= 0.10.0
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= RG
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user