- Update to 1.12.0
This commit is contained in:
parent
a024db8e65
commit
33040a4bdf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=485381
@ -1,20 +1,17 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ldc
|
||||
PORTVERSION= 1.9.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.12.0
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= https://github.com/ldc-developers/ldc/releases/download/v${PORTVERSION}/:source \
|
||||
https://github.com/ldc-developers/ldc/releases/download/v${BOOTVER}/:bootstrap
|
||||
DISTFILES= ${DISTNAME:S/$/-src/}${EXTRACT_SUFX}:source
|
||||
|
||||
MAINTAINER= acm@FreeBSD.org
|
||||
COMMENT= The LLVM-based D compiler
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
|
||||
BUILD_DEPENDS= llvm40>0:devel/llvm40
|
||||
RUN_DEPENDS= llvm40>0:devel/llvm40
|
||||
BUILD_DEPENDS= llvm60>0:devel/llvm60
|
||||
RUN_DEPENDS= llvm60>0:devel/llvm60
|
||||
LIB_DEPENDS= libconfig.so:devel/libconfig
|
||||
|
||||
BROKEN_aarch64= fails to compile: Error: undefined identifier _jmp_buf, did you mean alias jmp_buf?
|
||||
@ -23,18 +20,24 @@ BROKEN_armv7= fails to compile: Error: undefined identifier _jmp_buf, did you m
|
||||
BROKEN_powerpc64= fails to compile: cc1plus: error: unrecognized command line option "-std=c++11"
|
||||
|
||||
USES= cmake
|
||||
CMAKE_ARGS+= -DD_COMPILER:STRING="${WRKDIR}/${PORTNAME}-${BOOTVER:S/$/-src/}/bin/ldmd2" \
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= ldc-developers
|
||||
GH_PROJECT= ldc
|
||||
GH_TUPLE= ldc-developers:ldc:911589c:tree/ltsmaster \
|
||||
ldc-developers:druntime:694089c:druntimelts/ltsmaster/runtime/druntime \
|
||||
ldc-developers:phobos:1d758b2:phoboslts/ltsmaster/runtime/phobos \
|
||||
ldc-developers:druntime:b96540e:druntime/runtime/druntime \
|
||||
ldc-developers:phobos:1c8a152:phobos/runtime/phobos
|
||||
|
||||
CMAKE_ARGS+= -DD_COMPILER:STRING="${WRKSRC}/ltsmaster/bin/ldmd2" \
|
||||
-DBUILD_SHARED_LIBS:STRING="BOTH"
|
||||
|
||||
CC= clang40
|
||||
CXX= clang++40
|
||||
CC= clang60
|
||||
CXX= clang++60
|
||||
|
||||
BOOTVER= 0.17.5
|
||||
LLVM_CONFIG= llvm-config40
|
||||
BOOTVER= 0.17.6
|
||||
LLVM_CONFIG= llvm-config60
|
||||
LDCVER= ${PORTVERSION}
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/$/-src/}
|
||||
|
||||
DISTFILES+= ${PORTNAME}-${BOOTVER}-src.tar.gz:bootstrap
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
@ -44,13 +47,13 @@ CFLAGS+= -fPIC
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|$${llvm_config_names}|${LLVM_CONFIG}|g' \
|
||||
${WRKDIR}/${PORTNAME}-${BOOTVER:S/$/-src/}/cmake/Modules/FindLLVM.cmake \
|
||||
${WRKSRC}/ltsmaster/cmake/Modules/FindLLVM.cmake \
|
||||
${WRKSRC}/cmake/Modules/FindLLVM.cmake
|
||||
|
||||
pre-configure:
|
||||
@cd ${WRKDIR}/${PORTNAME}-${BOOTVER:S/$/-src/} && \
|
||||
@cd ${WRKSRC}/ltsmaster && \
|
||||
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} .
|
||||
@cd ${WRKDIR}/${PORTNAME}-${BOOTVER:S/$/-src/} && \
|
||||
@cd ${WRKSRC}/ltsmaster && \
|
||||
${SETENV} ${MAKE_ENV} ${MAKE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,5 +1,13 @@
|
||||
TIMESTAMP = 1525807496
|
||||
SHA256 (ldc-1.9.0-src.tar.gz) = e3f32a4dfcaae12f434e0e23638684faa83765827e7f2deb2df059dccc3169b9
|
||||
SIZE (ldc-1.9.0-src.tar.gz) = 6560330
|
||||
SHA256 (ldc-0.17.5-src.tar.gz) = 7aa540a135f9fa1ee9722cad73100a8f3600a07f9a11d199d8be68887cc90008
|
||||
SIZE (ldc-0.17.5-src.tar.gz) = 5006161
|
||||
TIMESTAMP = 1541394246
|
||||
SHA256 (ldc-developers-ldc-v1.12.0_GH0.tar.gz) = cfa31cd1606b709c918d5e3d780e8a8e2912313e79b2d532174a14bebc3c1266
|
||||
SIZE (ldc-developers-ldc-v1.12.0_GH0.tar.gz) = 1646050
|
||||
SHA256 (ldc-developers-ldc-911589c_GH0.tar.gz) = c10ee47d857358ea97eccd14b49b4152c7b2621c0129eee1e8f98988f1d13f5e
|
||||
SIZE (ldc-developers-ldc-911589c_GH0.tar.gz) = 1231073
|
||||
SHA256 (ldc-developers-druntime-694089c_GH0.tar.gz) = 29b1a27f767ac9c8a0c30926991d9abcda119aaf923b05caa686a6c396ac0a83
|
||||
SIZE (ldc-developers-druntime-694089c_GH0.tar.gz) = 953726
|
||||
SHA256 (ldc-developers-phobos-1d758b2_GH0.tar.gz) = af70f2d4b09e0062ba986e215677f484c1cec2977a74ca1a73d3534a120992e9
|
||||
SIZE (ldc-developers-phobos-1d758b2_GH0.tar.gz) = 1923043
|
||||
SHA256 (ldc-developers-druntime-b96540e_GH0.tar.gz) = dbfadf3fa8790fe1c952c685103f08c8d995ce8d0253fa0b900553b462be55a9
|
||||
SIZE (ldc-developers-druntime-b96540e_GH0.tar.gz) = 1643696
|
||||
SHA256 (ldc-developers-phobos-1c8a152_GH0.tar.gz) = 7f630f36326687d2881935d0a8cbd05e03bf02c0f55ed8966a60f3b15b5bdf24
|
||||
SIZE (ldc-developers-phobos-1c8a152_GH0.tar.gz) = 2344413
|
||||
|
@ -1,9 +1,9 @@
|
||||
--- runtime/CMakeLists.txt.orig 2018-01-05 23:42:10 UTC
|
||||
+++ runtime/CMakeLists.txt
|
||||
@@ -430,10 +430,13 @@ endmacro()
|
||||
--- runtime/CMakeLists.txt 2018-11-05 00:21:57.581109000 -0500
|
||||
+++ runtime/CMakeLists.txt 2018-11-05 00:24:29.799281000 -0500
|
||||
@@ -436,10 +436,13 @@
|
||||
# Sets up the targets for building the Phobos D object files, appending the
|
||||
# names of the (bitcode) files to link into the library to outlist_o (outlist_bc).
|
||||
macro(compile_phobos2 d_flags lib_suffix path_suffix all_at_once outlist_o outlist_bc)
|
||||
macro(compile_phobos2 d_flags lib_suffix path_suffix emit_bc all_at_once outlist_o outlist_bc)
|
||||
+ if(NOT ${BUILD_SHARED_LIBS} STREQUAL "OFF")
|
||||
+ set(RELOCATION_FLAGS -relocation-model=pic)
|
||||
+ endif()
|
||||
@ -13,5 +13,5 @@
|
||||
- "-conf=;${d_flags};-I${RUNTIME_DIR}/src;-I${PHOBOS2_DIR}"
|
||||
+ "-conf=;${d_flags};${RELOCATION_FLAGS};-I${RUNTIME_DIR}/src;-I${PHOBOS2_DIR}"
|
||||
"${PROJECT_BINARY_DIR}/objects${target_suffix}"
|
||||
"${emit_bc}"
|
||||
"${all_at_once}"
|
||||
${outlist_o}
|
||||
|
@ -100,6 +100,7 @@ include/d/core/sys/freebsd/sys/elf_common.d
|
||||
include/d/core/sys/freebsd/sys/event.d
|
||||
include/d/core/sys/freebsd/sys/link_elf.d
|
||||
include/d/core/sys/freebsd/sys/mman.d
|
||||
include/d/core/sys/freebsd/sys/mount.d
|
||||
include/d/core/sys/freebsd/time.d
|
||||
include/d/core/sys/linux/config.d
|
||||
include/d/core/sys/linux/dlfcn.d
|
||||
@ -155,6 +156,7 @@ include/d/core/sys/osx/pthread.d
|
||||
include/d/core/sys/osx/sys/cdefs.d
|
||||
include/d/core/sys/osx/sys/event.d
|
||||
include/d/core/sys/osx/sys/mman.d
|
||||
include/d/core/sys/posix/aio.d
|
||||
include/d/core/sys/posix/arpa/inet.d
|
||||
include/d/core/sys/posix/config.d
|
||||
include/d/core/sys/posix/dirent.d
|
||||
@ -401,6 +403,7 @@ include/d/ldc/arrayinit.d
|
||||
include/d/ldc/asan.d
|
||||
include/d/ldc/attributes.d
|
||||
include/d/ldc/dcompute.d
|
||||
include/d/ldc/dynamic_compile.d
|
||||
include/d/ldc/eh_asm.S
|
||||
include/d/ldc/eh_msvc.d
|
||||
include/d/ldc/gccbuiltins_aarch64.di
|
||||
@ -430,29 +433,6 @@ include/d/std/ascii.d
|
||||
include/d/std/base64.d
|
||||
include/d/std/bigint.d
|
||||
include/d/std/bitmanip.d
|
||||
include/d/std/c/fenv.d
|
||||
include/d/std/c/freebsd/socket.d
|
||||
include/d/std/c/linux/linux.d
|
||||
include/d/std/c/linux/linuxextern.d
|
||||
include/d/std/c/linux/pthread.d
|
||||
include/d/std/c/linux/socket.d
|
||||
include/d/std/c/linux/termios.d
|
||||
include/d/std/c/linux/tipc.d
|
||||
include/d/std/c/locale.d
|
||||
include/d/std/c/math.d
|
||||
include/d/std/c/osx/socket.d
|
||||
include/d/std/c/process.d
|
||||
include/d/std/c/stdarg.d
|
||||
include/d/std/c/stddef.d
|
||||
include/d/std/c/stdio.d
|
||||
include/d/std/c/stdlib.d
|
||||
include/d/std/c/string.d
|
||||
include/d/std/c/time.d
|
||||
include/d/std/c/wcharh.d
|
||||
include/d/std/c/windows/com.d
|
||||
include/d/std/c/windows/stat.d
|
||||
include/d/std/c/windows/windows.d
|
||||
include/d/std/c/windows/winsock.d
|
||||
include/d/std/compiler.d
|
||||
include/d/std/complex.d
|
||||
include/d/std/concurrency.d
|
||||
@ -484,6 +464,7 @@ include/d/std/encoding.d
|
||||
include/d/std/exception.d
|
||||
include/d/std/experimental/all.d
|
||||
include/d/std/experimental/allocator/building_blocks/affix_allocator.d
|
||||
include/d/std/experimental/allocator/building_blocks/aligned_block_list.d
|
||||
include/d/std/experimental/allocator/building_blocks/allocator_list.d
|
||||
include/d/std/experimental/allocator/building_blocks/ascending_page_allocator.d
|
||||
include/d/std/experimental/allocator/building_blocks/bitmapped_block.d
|
||||
@ -581,19 +562,23 @@ include/d/std/xml.d
|
||||
include/d/std/zip.d
|
||||
include/d/std/zlib.d
|
||||
lib/libdruntime-ldc-debug-shared.so
|
||||
lib/libdruntime-ldc-debug-shared.so.2.0.79
|
||||
lib/libdruntime-ldc-debug-shared.so.79
|
||||
lib/libdruntime-ldc-debug-shared.so.2.0.82
|
||||
lib/libdruntime-ldc-debug-shared.so.82
|
||||
lib/libdruntime-ldc-debug.a
|
||||
lib/libdruntime-ldc-shared.so
|
||||
lib/libdruntime-ldc-shared.so.2.0.79
|
||||
lib/libdruntime-ldc-shared.so.79
|
||||
lib/libdruntime-ldc-shared.so.2.0.82
|
||||
lib/libdruntime-ldc-shared.so.82
|
||||
lib/libdruntime-ldc.a
|
||||
lib/libldc-jit-rt.a
|
||||
lib/libldc-jit.so
|
||||
lib/libldc-jit.so.2.0.82
|
||||
lib/libldc-jit.so.82
|
||||
lib/libphobos2-ldc-debug-shared.so
|
||||
lib/libphobos2-ldc-debug-shared.so.2.0.79
|
||||
lib/libphobos2-ldc-debug-shared.so.79
|
||||
lib/libphobos2-ldc-debug-shared.so.2.0.82
|
||||
lib/libphobos2-ldc-debug-shared.so.82
|
||||
lib/libphobos2-ldc-debug.a
|
||||
lib/libphobos2-ldc-shared.so
|
||||
lib/libphobos2-ldc-shared.so.2.0.79
|
||||
lib/libphobos2-ldc-shared.so.79
|
||||
lib/libphobos2-ldc-shared.so.2.0.82
|
||||
lib/libphobos2-ldc-shared.so.82
|
||||
lib/libphobos2-ldc.a
|
||||
@dir include/d/etc/c/zlib
|
||||
|
Loading…
Reference in New Issue
Block a user