math/petanque: New port: Library that helps manipulate symbolic boolean expressions

This commit is contained in:
Yuri Victorovich 2021-09-28 22:30:35 -07:00
parent 4989cee174
commit 3300bf124c
6 changed files with 57 additions and 0 deletions

View File

@ -752,6 +752,7 @@
SUBDIR += pecl-bitset
SUBDIR += pecl-stats2
SUBDIR += permlib
SUBDIR += petanque
SUBDIR += petiga
SUBDIR += php73-bcmath
SUBDIR += php73-gmp

24
math/petanque/Makefile Normal file
View File

@ -0,0 +1,24 @@
PORTNAME= petanque
DISTVERSIONPREFIX= release-
DISTVERSION= 1.1.0
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
COMMENT= Library that helps manipulate symbolic boolean expressions
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
USES= cmake:testing compiler:c++14-lang
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= quarkslab
GH_PROJECT= arybo
WRKSRC_SUBDIR= ${PORTNAME}
CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_TESTING_ON= WITH_TESTS # tests fail to find TBB, see https://github.com/quarkslab/arybo/issues/29
.include <bsd.port.mk>

3
math/petanque/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1632891698
SHA256 (quarkslab-arybo-release-1.1.0_GH0.tar.gz) = 96749f152e366c16803c9239e05d15cc9d3f1c156203064519c325be66a57acb
SIZE (quarkslab-arybo-release-1.1.0_GH0.tar.gz) = 940821

View File

@ -0,0 +1,13 @@
--- CMakeLists.txt.orig 2020-03-28 18:16:21 UTC
+++ CMakeLists.txt
@@ -16,8 +16,8 @@ include_directories(${Boost_INCLUDE_DIRS})
include_directories(${CMAKE_SOURCE_DIR}/third-party)
add_subdirectory(src)
-add_subdirectory(bindings)
-if (NOT (DEFINED NO_TESTS OR NO_TESTS))
+#add_subdirectory(bindings)
+if (WITH_TESTS)
add_subdirectory(tests)
endif()
if (NOT (DEFINED NO_TOOLS OR NO_TOOLS))

3
math/petanque/pkg-descr Normal file
View File

@ -0,0 +1,3 @@
petanque is a library that helps manipulate symbolic boolean expressions.
WWW: https://github.com/quarkslab/arybo/tree/master/petanque

13
math/petanque/pkg-plist Normal file
View File

@ -0,0 +1,13 @@
include/pa/analyses.h
include/pa/app.h
include/pa/bitfield.h
include/pa/exprs.h
include/pa/matrix.h
include/pa/prettyprinter.h
include/pa/subs.h
include/pa/symbols.h
include/pa/syms_hist.h
include/pa/syms_set.h
include/pa/traits.h
include/pa/vector.h
lib/libpetanque.so