graphics/libGLw: Remove deprecated port
Remove graphics/libGLw, since it is deprecated. Dependent ports have already been resolved. Unhook it from the infrastructure in Mk/Uses/gl.mk
This commit is contained in:
parent
640f5371b6
commit
32f028ef29
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=516226
1
MOVED
1
MOVED
@ -13436,3 +13436,4 @@ games/xpilot-ng-client||2019-11-01|Has expired: Depends on deprecated libXxf86mi
|
||||
science/xmakemol||2019-11-01|Has expired: Depends on expiring graphics/libGLw
|
||||
x11/libXp||2019-11-01|Deprecated upstream
|
||||
x11/libXxf86misc||2019-11-01|Deprecated upstream
|
||||
graphics/libGLw||2019-11-01|Deprecated upstream
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
# Feature: gl
|
||||
# Usage: USES=gl
|
||||
# USE_GL=egl gbm gl glesv2 glew glu glut glw
|
||||
# USE_GL=egl gbm gl glesv2 glew glu glut
|
||||
#
|
||||
# USE_GL specifies which GL components to add as dependencies.
|
||||
# Not specifying USE_GL with USES=gl is an error.
|
||||
@ -24,7 +24,6 @@ _GL_glew_LIB_DEPENDS= libGLEW.so:graphics/glew
|
||||
_GL_glu_LIB_DEPENDS= libGLU.so:graphics/libGLU
|
||||
_GL_glu_USE_XORG= xorgproto
|
||||
_GL_glut_LIB_DEPENDS= libglut.so:graphics/freeglut
|
||||
_GL_glw_LIB_DEPENDS= libGLw.so:graphics/libGLw
|
||||
|
||||
.if !empty(gl_ARGS)
|
||||
IGNORE= USES=gl takes no arguments
|
||||
|
@ -413,7 +413,6 @@
|
||||
SUBDIR += lfview
|
||||
SUBDIR += lib3ds
|
||||
SUBDIR += libGLU
|
||||
SUBDIR += libGLw
|
||||
SUBDIR += libQGLViewer
|
||||
SUBDIR += libafterimage
|
||||
SUBDIR += libansilove
|
||||
|
@ -1,28 +0,0 @@
|
||||
# Created by: Eric Anholt <anholt@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libGLw
|
||||
PORTVERSION= 8.0.0
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ftp://ftp.freedesktop.org/pub/mesa/glw/
|
||||
DISTNAME= glw-${PORTVERSION}
|
||||
DIST_SUBDIR= GL
|
||||
|
||||
MAINTAINER= x11@FreeBSD.org
|
||||
COMMENT= OpenGL widgets library
|
||||
|
||||
DEPRECATED= Deprecated upstream
|
||||
EXPIRATION_DATE= 2019-11-01
|
||||
|
||||
USES= motif libtool pathfix pkgconfig tar:bzip2
|
||||
USE_LDCONFIG= yes
|
||||
USE_GL= gl
|
||||
USE_XORG= x11 xt xext
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-static --enable-motif
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LIBS+= -L${LOCALBASE}/lib
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,2 +0,0 @@
|
||||
SHA256 (GL/glw-8.0.0.tar.bz2) = 2da1d06e825f073dcbad264aec7b45c649100e5bcde688ac3035b34c8dbc8597
|
||||
SIZE (GL/glw-8.0.0.tar.bz2) = 221136
|
@ -1,55 +0,0 @@
|
||||
diff --git a/GLwDrawA.h b/GLwDrawA.h
|
||||
index b9711c216bc458f7ec2d2055495045efef8903f0..316a70d5d2061af67d8307c74706208907c3ac6a 100644
|
||||
--- GLwDrawA.h
|
||||
+++ GLwDrawA.h
|
||||
@@ -131,12 +131,18 @@
|
||||
#define GLwNaccumAlphaSize "accumAlphaSize"
|
||||
#define GLwCAccumAlphaSize "AccumAlphaSize"
|
||||
|
||||
+#if (defined(__GNUC__) && __GNUC__ >= 4) || (defined(__SUNPRO_C) && (__SUNPRO_C >= 0x590))
|
||||
+# define GLAPIVAR extern __attribute__((visibility("default")))
|
||||
+#else
|
||||
+# define GLAPIVAR extern
|
||||
+#endif
|
||||
+
|
||||
#ifdef __GLX_MOTIF
|
||||
|
||||
typedef struct _GLwMDrawingAreaClassRec *GLwMDrawingAreaWidgetClass;
|
||||
typedef struct _GLwMDrawingAreaRec *GLwMDrawingAreaWidget;
|
||||
|
||||
-GLAPI WidgetClass glwMDrawingAreaWidgetClass;
|
||||
+GLAPIVAR WidgetClass glwMDrawingAreaWidgetClass;
|
||||
|
||||
|
||||
#else
|
||||
@@ -144,7 +150,7 @@ GLAPI WidgetClass glwMDrawingAreaWidgetClass;
|
||||
typedef struct _GLwDrawingAreaClassRec *GLwDrawingAreaWidgetClass;
|
||||
typedef struct _GLwDrawingAreaRec *GLwDrawingAreaWidget;
|
||||
|
||||
-GLAPI WidgetClass glwDrawingAreaWidgetClass;
|
||||
+GLAPIVAR WidgetClass glwDrawingAreaWidgetClass;
|
||||
|
||||
|
||||
#endif
|
||||
diff --git a/GLwDrawAP.h b/GLwDrawAP.h
|
||||
index 4ff21b426dd5912e007356160ef6fe5a41536c24..6d29849d4288f4affaa5ed3f5d5d5bc1668d4cd3 100644
|
||||
--- GLwDrawAP.h
|
||||
+++ GLwDrawAP.h
|
||||
@@ -59,7 +59,7 @@ typedef struct _GLwMDrawingAreaClassRec {
|
||||
} GLwMDrawingAreaClassRec;
|
||||
|
||||
|
||||
-GLAPI GLwMDrawingAreaClassRec glwMDrawingAreaClassRec;
|
||||
+GLAPIVAR GLwMDrawingAreaClassRec glwMDrawingAreaClassRec;
|
||||
|
||||
|
||||
/* XT */
|
||||
@@ -70,7 +70,7 @@ typedef struct _GLwDrawingAreaClassRec {
|
||||
GLwDrawingAreaClassPart glwDrawingArea_class;
|
||||
} GLwDrawingAreaClassRec;
|
||||
|
||||
-GLAPI GLwDrawingAreaClassRec glwDrawingAreaClassRec;
|
||||
+GLAPIVAR GLwDrawingAreaClassRec glwDrawingAreaClassRec;
|
||||
|
||||
|
||||
#endif
|
@ -1,13 +0,0 @@
|
||||
diff --git a/GLwDrawA.c b/GLwDrawA.c
|
||||
index b9ef47b1ce505553120fa7556693b97e5d91b3c5..8ce12fba0f6ef4b092837ca0c2e6aa44f5de2dfa 100644
|
||||
--- GLwDrawA.c
|
||||
+++ GLwDrawA.c
|
||||
@@ -474,7 +474,7 @@ static void Initialize(GLwDrawingAreaWidget req,GLwDrawingAreaWidget neww,ArgLis
|
||||
|
||||
/* fix size */
|
||||
if(req->core.width==0) neww->core.width=100;
|
||||
- if(req->core.height==0) neww->core.width=100;
|
||||
+ if(req->core.height==0) neww->core.height=100;
|
||||
|
||||
/* create the attribute list if needed */
|
||||
neww->glwDrawingArea.myList=FALSE;
|
@ -1,3 +0,0 @@
|
||||
This package contains the OpenGL widgets library.
|
||||
|
||||
WWW: http://www.mesa3d.org/
|
@ -1,8 +0,0 @@
|
||||
include/GL/GLwDrawA.h
|
||||
include/GL/GLwDrawAP.h
|
||||
include/GL/GLwMDrawA.h
|
||||
include/GL/GLwMDrawAP.h
|
||||
lib/libGLw.so
|
||||
lib/libGLw.so.1
|
||||
lib/libGLw.so.1.0.0
|
||||
libdata/pkgconfig/glw.pc
|
Loading…
Reference in New Issue
Block a user