Update to 0.5
now suPHP supports apache2. Approved by: erwin (mentor) (implicitly)
This commit is contained in:
parent
a2f3809140
commit
32db161a56
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=97930
@ -6,29 +6,32 @@
|
||||
#
|
||||
|
||||
PORTNAME= suphp
|
||||
PORTVERSION= 0.3.1
|
||||
PORTVERSION= 0.5
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.suphp.org/download/
|
||||
|
||||
MAINTAINER= sheepkiller@cultdeadsheep.org
|
||||
COMMENT= A combination which provides a wrapper for PHP
|
||||
|
||||
BUILD_DEPENDS= ${APXS}:${PORTSDIR}/${APACHE_PORT}
|
||||
RUN_DEPENDS= ${LOCALBASE}/bin/php:${PORTSDIR}/www/php4-cgi
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
CONFLICTS= mod_php4-4*
|
||||
USE_APACHE= yes
|
||||
CONFLICTS= mod_php4-4* php-4.*
|
||||
|
||||
LOG_PATH?= /var/log
|
||||
PHP_PATH?= ${LOCALBASE}/bin/php
|
||||
APACHE_USER?= www
|
||||
APACHE_USER?= ${WWWOWN}
|
||||
MIN_UID?= ${WWWOWN}
|
||||
MIN_GID?= ${WWWGRP}
|
||||
WITH_SETID_MODE?= owner
|
||||
|
||||
CONFIGURE_ARGS+= --with-php=${PHP_PATH} \
|
||||
--with-logfile=${LOG_PATH}/suphp.log \
|
||||
--with-apache-user=${APACHE_USER} \
|
||||
--with-min-gid=80 \
|
||||
--with-min-uid=80 \
|
||||
--with-min-gid=${MIN_UID} \
|
||||
--with-min-uid=${MIN_GID} \
|
||||
--with-apxs=${APXS}
|
||||
|
||||
## Available knobs:
|
||||
@ -44,22 +47,24 @@ CONFIGURE_ARGS+= --disable-checkuid
|
||||
.if defined(WITHOUT_CHECKGID)
|
||||
CONFIGURE_ARGS+= --disable-checkgid
|
||||
.endif
|
||||
## WITH_SETID_MODE: Mode to use for setting UID/GID.
|
||||
CONFIGURE_ARGS+= --enable-setid=${WITH_SETID_MODE}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if exists(${LOCALBASE}/include/apache2/apr.h)
|
||||
BROKEN= "Doesn't work with Apache 2"
|
||||
.if exists(${LOCALBASE}/include/apache2/apr.h) || defined(WITH_APACHE2)
|
||||
APACHE_PORT= www/apache2
|
||||
PLIST_SUB+= MODULEDIR="libexec/apache2/"
|
||||
.else
|
||||
PLIST_SUB+= MODULEDIR="libexec/apache/"
|
||||
.endif
|
||||
|
||||
show-options:
|
||||
@${EGREP} '^##' ${.CURDIR}/Makefile | ${SED} 's/##//'
|
||||
@${SED} -ne 's/^##//p' ${.CURDIR}/Makefile
|
||||
|
||||
pre-everything::
|
||||
@${MAKE} show-options
|
||||
|
||||
post-extract:
|
||||
@${CHMOD} 755 ${WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
|
@ -1 +1 @@
|
||||
MD5 (suphp-0.3.1.tar.gz) = edf3063432da532a398d08cc8a48b668
|
||||
MD5 (suphp-0.5.tar.gz) = a17b2f7bec0db326ee10d28460f34fe4
|
||||
|
20
www/suphp/files/patch-configure
Normal file
20
www/suphp/files/patch-configure
Normal file
@ -0,0 +1,20 @@
|
||||
--- configure.orig Sun Jan 11 15:21:53 2004
|
||||
+++ configure Sun Jan 11 15:22:19 2004
|
||||
@@ -2253,7 +2253,7 @@
|
||||
if test $withval; then
|
||||
|
||||
cat >>confdefs.h <<_ACEOF
|
||||
-#define OPT_MIN_UID $withval
|
||||
+#define OPT_MIN_UID "$withval"
|
||||
_ACEOF
|
||||
|
||||
fi
|
||||
@@ -2276,7 +2276,7 @@
|
||||
if test $withval; then
|
||||
|
||||
cat >>confdefs.h <<_ACEOF
|
||||
-#define OPT_MIN_GID $withval
|
||||
+#define OPT_MIN_GID "$withval"
|
||||
_ACEOF
|
||||
|
||||
fi
|
@ -1,5 +1,5 @@
|
||||
sbin/suphp
|
||||
libexec/apache/mod_suphp.so
|
||||
%%MODULEDIR%%/mod_suphp.so
|
||||
@exec %D/sbin/apxs -e -a -n suphp %D/%f
|
||||
@unexec echo "===> If you do not plan on reinstalling suphp, you must manually remove"; echo "===> references to it in httpd.conf."
|
||||
%%PORTDOCS%%%%DOCSDIR%%/en/INSTALL
|
||||
|
Loading…
Reference in New Issue
Block a user