- Update to 0.4.5

- Convert to new options framework

Changes:	https://github.com/libming/libming/blob/master/NEWS
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2013-08-22 15:21:03 +00:00
parent 35cbf0976f
commit 32d1ac699e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=325205
3 changed files with 8 additions and 41 deletions

View File

@ -1,18 +1,16 @@
# New ports collection makefile for: p5-ming
# Date created: 18 September 2001
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
# $FreeBSD$
#
PORTNAME= ming
PORTREVISION= 1
PORTREVISION= 0
CATEGORIES= graphics perl5
PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Perl5 module for Ming which allows you to create Flash 4/5 movies
OPTIONS_DEFINE= EXAMPLES
CONFIGURE_ARGS= --enable-perl
INSTALL_WRKSRC= ${WRKSRC}/perl_ext
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VER}
@ -59,8 +57,10 @@ MAN3= SWF.3 \
SWF::TextField.3 \
SWF::VideoStream.3
.include <bsd.port.options.mk>
post-install:
.if !defined(NOPORTEXAMPLES)
.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}/
cd ${INSTALL_WRKSRC}/examples/ && ${INSTALL_DATA} *.cgi ${EXAMPLESDIR}/
.endif

View File

@ -1,33 +0,0 @@
--- Makefile.PL.orig 2011-10-26 14:33:18.000000000 +0800
+++ Makefile.PL 2011-11-20 17:28:21.555225857 +0800
@@ -146,11 +146,9 @@
clean => {
FILES => "@do_clean",
},
- 'MYEXTLIB' => $MING_TOP_BUILDDIR . '/src/.libs/libming.a',
'OBJECT' => "$XS_OBJECTS",
'LDFROM' => "$LD_OBJECTS",
'INC' => "-I$MING_TOP_SRCDIR/src -I$BUILDDIR -I$MING_TOP_BUILDDIR/src -I$SRCDIR",
- 'LIBS' => [ $libs ],
'PM' => $PM_HASH,
'MAN3PODS' => $MAN3_HASH,
'TYPEMAPS' => ["$SRCDIR/typemap"],
@@ -164,17 +162,7 @@
sub ming_is_compiled
{
- my $libming = $MING_TOP_BUILDDIR."/src/.libs/libming.a";
-
- if ( -e $libming )
- {
- return 1;
- }
- else
- {
- print "$libming doesn't exist.\n";
- return undef;
- }
+ return 1;
}
# unused. At least it should take into account the configure flags by

View File

@ -1,4 +1,4 @@
This is a Perl5 module for the Ming library.
This is the Perl 5 module for the Ming library.
Ming allows you to create Flash 4/5 (TM) movies.
WWW: http://www.libming.org/