databases/foundationdb*: upbreak after boost upgrade (+)

While here, replace hardcoded /usr/local by %%LOCALBASE%% macro

PR:	246106
This commit is contained in:
Dima Panov 2022-05-22 21:33:24 +03:00
parent a1b52b8e4e
commit 32bfbcbbca
6 changed files with 30 additions and 2 deletions

View File

@ -1,5 +1,6 @@
PORTNAME= foundationdb-devel
DISTVERSION= 7.0.0
PORTREVISION= 1
CATEGORIES= databases
# PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/pull/
@ -52,6 +53,8 @@ PLIST_SUB+= ${SUB_FDB}
post-patch:
${REINPLACE_CMD} 's/OPENSSL_USE_STATIC_LIBS TRUE/OPENSSL_USE_STATIC_LIBS FALSE/' \
${WRKSRC}/cmake/FDBComponents.cmake
${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/bindings/c/test/unit/third_party/CMakeLists.txt
do-install:
# commands on first line, dev tools on next two

View File

@ -19,4 +19,4 @@
-
-ExternalProject_Get_Property(doctest source_dir)
-set(DOCTEST_INCLUDE_DIR ${source_dir}/doctest CACHE INTERNAL "Path to include folder for doctest")
+set(DOCTEST_INCLUDE_DIR /usr/local/include/doctest CACHE INTERNAL "Path to include folder for doctest")
+set(DOCTEST_INCLUDE_DIR %%LOCALBASE%%/include/doctest CACHE INTERNAL "Path to include folder for doctest")

View File

@ -0,0 +1,11 @@
--- cmake/CompileBoost.cmake.orig 2022-04-19 01:08:48 UTC
+++ cmake/CompileBoost.cmake
@@ -113,7 +113,7 @@ endif()
return()
endif()
-find_package(Boost 1.72.0 EXACT QUIET COMPONENTS context CONFIG PATHS ${BOOST_HINT_PATHS})
+find_package(Boost 1.72.0 COMPONENTS context CONFIG PATHS ${BOOST_HINT_PATHS})
set(FORCE_BOOST_BUILD OFF CACHE BOOL "Forces cmake to build boost and ignores any installed boost")
if(Boost_FOUND AND NOT FORCE_BOOST_BUILD)

View File

@ -1,5 +1,6 @@
PORTNAME= foundationdb
DISTVERSION= 7.0.0
PORTREVISION= 1
CATEGORIES= databases
MAINTAINER= dch@FreeBSD.org
@ -50,6 +51,8 @@ PLIST_SUB+= ${SUB_FDB}
post-patch:
${REINPLACE_CMD} 's/OPENSSL_USE_STATIC_LIBS TRUE/OPENSSL_USE_STATIC_LIBS FALSE/' \
${WRKSRC}/cmake/FDBComponents.cmake
${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/bindings/c/test/unit/third_party/CMakeLists.txt
do-install:
# commands on first line, dev tools on next two

View File

@ -19,4 +19,4 @@
-
-ExternalProject_Get_Property(doctest source_dir)
-set(DOCTEST_INCLUDE_DIR ${source_dir}/doctest CACHE INTERNAL "Path to include folder for doctest")
+set(DOCTEST_INCLUDE_DIR /usr/local/include/doctest CACHE INTERNAL "Path to include folder for doctest")
+set(DOCTEST_INCLUDE_DIR %%LOCALBASE%%/include/doctest CACHE INTERNAL "Path to include folder for doctest")

View File

@ -0,0 +1,11 @@
--- cmake/CompileBoost.cmake.orig 2022-04-19 01:08:48 UTC
+++ cmake/CompileBoost.cmake
@@ -113,7 +113,7 @@ endif()
return()
endif()
-find_package(Boost 1.72.0 EXACT QUIET COMPONENTS context CONFIG PATHS ${BOOST_HINT_PATHS})
+find_package(Boost 1.72.0 COMPONENTS context CONFIG PATHS ${BOOST_HINT_PATHS})
set(FORCE_BOOST_BUILD OFF CACHE BOOL "Forces cmake to build boost and ignores any installed boost")
if(Boost_FOUND AND NOT FORCE_BOOST_BUILD)