Update to 0.82.
PR: 36134 Submitted by: maintainer
This commit is contained in:
parent
299f5a9a60
commit
32a8a313ac
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=56395
@ -7,23 +7,22 @@
|
||||
#
|
||||
|
||||
PORTNAME= rotix
|
||||
PORTVERSION= 0.8
|
||||
PORTVERSION= 0.82
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://elektron.its.tudelft.nl/~hemmin98/
|
||||
MASTER_SITES= http://elektron.its.tudelft.nl/~hemmin98/rotix_releases/
|
||||
|
||||
MAINTAINER= lintux@debian.org
|
||||
|
||||
LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext-old
|
||||
|
||||
USE_GMAKE= yes
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${PREFIX}/man --i18n=1
|
||||
|
||||
MAN1= rotix.1
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s,%%CFLAGS%%,${CFLAGS},g ; \
|
||||
s,%%LOCALBASE%%,${LOCALBASE},g ; \
|
||||
s,%%INSTALL_PROGRAM%%,${INSTALL_PROGRAM},g ; \
|
||||
s,%%INSTALL_MAN%%,${INSTALL_MAN},g ; \
|
||||
s,%%INSTALL_DATA%%,${INSTALL_DATA},g" ${WRKSRC}/Makefile
|
||||
@${PERL} -pi -e 's,%%CFLAGS%%,${CFLAGS},; s,%%LOCALBASE%%,${LOCALBASE},;' \
|
||||
${WRKSRC}/Makefile
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (rotix-0.8.tar.gz) = 76c7a5ce1b2bd416076600cdc7db20b6
|
||||
MD5 (rotix-0.82.tar.gz) = f9616b20f3f2de148105fe86cb1d5fd3
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- Makefile.orig Sat Nov 10 22:57:10 2001
|
||||
+++ Makefile Wed Dec 12 14:03:34 2001
|
||||
@@ -33,17 +33,17 @@
|
||||
--- Makefile.orig Thu Jan 17 16:43:08 2002
|
||||
+++ Makefile Wed Mar 20 04:43:31 2002
|
||||
@@ -25,11 +25,11 @@
|
||||
ifdef DEBUG
|
||||
CFLAGS = -g3
|
||||
else
|
||||
@ -9,29 +9,17 @@
|
||||
endif
|
||||
|
||||
ifdef I18N
|
||||
-CFLAGS += -DPACKAGE=\"${PACKAGE}\" -D LOCALEDIR=\"${LOCALEDIR}\"
|
||||
+CFLAGS += -DPACKAGE=\"${PACKAGE}\" -D LOCALEDIR=\"${LOCALEDIR}\" -I%%LOCALBASE%%/include
|
||||
-CFLAGS += -DPACKAGE=\"${PACKAGE}\" -D LOCALEDIR=\"${LOCALE}\"
|
||||
+CFLAGS += -DPACKAGE=\"${PACKAGE}\" -D LOCALEDIR=\"${LOCALE}\" -I%%LOCALBASE%%/include
|
||||
endif
|
||||
|
||||
ifdef NO_GETOPT_LONG
|
||||
@@ -39,7 +39,7 @@
|
||||
all : rotix po
|
||||
|
||||
rotix : rot.o help.o rotix.o
|
||||
- gcc -Wall $(CFLAGS) -o rotix rot.o help.o rotix.o
|
||||
+ gcc -Wall $(CFLAGS) -o rotix rot.o help.o rotix.o -L%%LOCALBASE%%/lib -lintl
|
||||
- $(CC) -Wall $(CFLAGS) -o rotix rot.o help.o rotix.o
|
||||
+ $(CC) -Wall $(CFLAGS) -o rotix rot.o help.o rotix.o -L%%LOCALBASE%%/lib -lintl
|
||||
ifdef STRIP
|
||||
ifndef DEBUG
|
||||
strip rotix
|
||||
@@ -78,10 +78,10 @@
|
||||
rm -f po/*.mo
|
||||
|
||||
install: rotix po
|
||||
- install -D --mode=0755 rotix $(DESTDIR)$(BINDIR)/rotix
|
||||
- install -D --mode=0644 rotix.1 $(DESTDIR)$(MANDIR)/man1/rotix.1
|
||||
+ %%INSTALL_PROGRAM%% rotix $(DESTDIR)$(BINDIR)
|
||||
+ %%INSTALL_MAN%% rotix.1 $(DESTDIR)$(MANDIR)/man1
|
||||
ifdef I18N
|
||||
- install -D --mode=0644 po/NL.mo $(DESTDIR)$(LOCALEDIR)/nl/LC_MESSAGES/rotix.mo
|
||||
+ %%INSTALL_DATA%% po/NL.mo $(DESTDIR)$(LOCALEDIR)/nl/LC_MESSAGES/rotix.mo
|
||||
endif
|
||||
|
||||
uninstall:
|
||||
$(STRIP) rotix
|
||||
|
@ -1,19 +0,0 @@
|
||||
--- Makefile.settings.orig Wed Dec 12 13:47:06 2001
|
||||
+++ Makefile.settings Wed Dec 12 13:48:46 2001
|
||||
@@ -13,7 +13,7 @@
|
||||
|
||||
# PREFIX: This is the prefix for installing Rotix. Default is /usr/local.
|
||||
# Alternative could be /usr.
|
||||
-PREFIX=/usr/local
|
||||
+#PREFIX=/usr/local
|
||||
|
||||
# DESTDIR: Used when creating packages.
|
||||
DESTDIR=
|
||||
@@ -27,5 +27,5 @@
|
||||
PACKAGE=rotix
|
||||
|
||||
# LOCALEDIR: If your LOCALEDIR is somewhere else, change the path.
|
||||
-LOCALEDIR=/usr/share/locale
|
||||
-
|
||||
+LOCALEDIR=${PREFIX}/share/locale
|
||||
+
|
@ -1,33 +0,0 @@
|
||||
--- rotix.c Fri Nov 9 17:39:12 2001
|
||||
+++ rotix.c Fri Dec 7 15:35:26 2001
|
||||
@@ -26,9 +26,11 @@
|
||||
/* System includes. */
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
-#include <getopt.h>
|
||||
+#include <unistd.h>
|
||||
#include <string.h>
|
||||
|
||||
+#define getopt_long( a, b, c, d, e ) getopt( a, b, c )
|
||||
+
|
||||
/* I18N */
|
||||
#include <libintl.h>
|
||||
#define _(String) gettext (String)
|
||||
@@ -46,7 +47,7 @@
|
||||
int i = 1, rotor = 13, option = 0;
|
||||
char *arg = NULL, option_flags = 0, rotate_flags = 0;
|
||||
|
||||
- /* The struct used to determine which options are called. */
|
||||
+ /* The struct used to determine which options are called.
|
||||
static struct option rotix_options[] = {
|
||||
{ "file", 1, NULL, 'f' },
|
||||
{ "rot", 1, NULL, 'r' },
|
||||
@@ -57,7 +58,7 @@
|
||||
{ "help", 0, NULL, 'h' },
|
||||
{ "version", 0, NULL, 'v' },
|
||||
{ NULL, 0, NULL, 0 }
|
||||
- };
|
||||
+ }; */
|
||||
|
||||
|
||||
/* A 2-bit character array, to obfuscate a character */
|
Loading…
Reference in New Issue
Block a user