- Remove useless REINPLACE
- Use @sample for highscore handling - Support highscore patch longer than 32 bytes - Don't use PTHREAD_LIBS - Add LICENSE - Drop @dirrm* from plist
This commit is contained in:
parent
5f9ab5f5f3
commit
32a70a32ed
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=377859
@ -3,25 +3,29 @@
|
||||
|
||||
PORTNAME= lbreakout
|
||||
PORTVERSION= 010315
|
||||
PORTREVISION= 8
|
||||
PORTREVISION= 9
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/lgames/${PORTNAME}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Nice clone of classical Breakout game
|
||||
|
||||
LICENSE= GPLv2 # or later
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USE_SDL= sdl
|
||||
USES= gmake
|
||||
GNU_CONFIGURE= yes
|
||||
LIBS+= -lcompat
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
|
||||
@${GREP} -lR "SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|"SDL/SDL|"SDL|g ; \
|
||||
s|<SDL/SDL|<SDL|g'
|
||||
@${REINPLACE_CMD} -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
|
||||
|
||||
pre-install:
|
||||
${MKDIR} ${STAGEDIR}/var/games/${PORTNAME}
|
||||
|
||||
post-install:
|
||||
${MV} ${STAGEDIR}/var/games/${PORTNAME}/lbreakout.hscr \
|
||||
${STAGEDIR}/var/games/${PORTNAME}/lbreakout.hscr.sample
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
20
games/lbreakout/files/patch-lbreakout__hiscore.h
Normal file
20
games/lbreakout/files/patch-lbreakout__hiscore.h
Normal file
@ -0,0 +1,20 @@
|
||||
--- lbreakout/hiscore.h.orig 2001-02-24 22:00:24.000000000 +0300
|
||||
+++ lbreakout/hiscore.h 2015-01-25 05:37:12.000000000 +0300
|
||||
@@ -60,7 +60,7 @@
|
||||
protected:
|
||||
HiScoreEntry *entries;
|
||||
int entry_num;
|
||||
- char filename[32];
|
||||
+ char filename[1024];
|
||||
public:
|
||||
StandardHiScore(char* f);
|
||||
StandardHiScore(FILE* f);
|
||||
@@ -88,7 +88,7 @@
|
||||
// maintains two tables: one per score, the other per level
|
||||
class CompositeHiScore : public HiScore {
|
||||
private:
|
||||
- char filename[32];
|
||||
+ char filename[1024];
|
||||
LevelHiScore* pLevel;
|
||||
StandardHiScore* pStandard;
|
||||
|
@ -43,6 +43,5 @@ share/lbreakout/wall.wav
|
||||
share/lbreakout/weapon.bmp
|
||||
share/lbreakout/weapon.wav
|
||||
share/lbreakout/wontgiveup.wav
|
||||
@dirrm share/lbreakout
|
||||
@(root,games,664) /var/games/lbreakout/lbreakout.hscr
|
||||
@dirrm /var/games/lbreakout
|
||||
@sample(root,games,664) /var/games/lbreakout/lbreakout.hscr.sample
|
||||
@dir /var/games/lbreakout
|
||||
|
Loading…
Reference in New Issue
Block a user