- Update to 3.20110707
- Cabalize port PR: ports/159348 Submitted by: pgj Approved by: maintainer (timeout) Obtained from: FreeBSD Haskell
This commit is contained in:
parent
4b2f4a61d4
commit
32843232af
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=282436
1
MOVED
1
MOVED
@ -2664,3 +2664,4 @@ net-mgmt/aguri||2011-09-23|Has expired: No more public distfiles
|
||||
games/senso||2011-09-23|Has expired: No more public distfiles
|
||||
net-im/jabber-users-agent||2011-09-23|Has expired: No more public distfiles
|
||||
games/cchess||2011-09-23|Has expired: No more public distfiles
|
||||
devel/git-annex|devel/hs-git-annex|2011-09-26|It has become a Cabal transcript
|
||||
|
@ -473,7 +473,6 @@
|
||||
SUBDIR += gio-fam-backend
|
||||
SUBDIR += gio-sharp
|
||||
SUBDIR += git
|
||||
SUBDIR += git-annex
|
||||
SUBDIR += git-merge-changelog
|
||||
SUBDIR += git-subversion
|
||||
SUBDIR += gitg
|
||||
@ -611,6 +610,7 @@
|
||||
SUBDIR += hs-ghc-paths
|
||||
SUBDIR += hs-ghc-paths-docs
|
||||
SUBDIR += hs-gio
|
||||
SUBDIR += hs-git-annex
|
||||
SUBDIR += hs-glade
|
||||
SUBDIR += hs-glib
|
||||
SUBDIR += hs-gtk2hs-buildtools
|
||||
|
@ -1,52 +0,0 @@
|
||||
# New ports collection makefile for: git-annex
|
||||
# Date created: 8 June 2011
|
||||
# Whom: frase@frase.id.au
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= git-annex
|
||||
PORTVERSION= 3.20110702
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel haskell
|
||||
MASTER_SITES= http://git.kitenet.net/?p=git-annex.git;a=snapshot;sf=tgz;h=refs/tags/
|
||||
DISTFILES= ${PORTVERSION}
|
||||
DIST_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= frase@frase.id.au
|
||||
COMMENT= Manage file hierarchies with git
|
||||
|
||||
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
|
||||
hs-MissingH>=0:${PORTSDIR}/devel/hs-MissingH \
|
||||
hs-pcre-light>=0:${PORTSDIR}/devel/hs-pcre-light \
|
||||
hs-utf8-string>=0:${PORTSDIR}/devel/hs-utf8-string \
|
||||
hs-SHA>=0:${PORTSDIR}/security/hs-SHA \
|
||||
hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc \
|
||||
hs-curl>0:${PORTSDIR}/ftp/hs-curl \
|
||||
git:${PORTSDIR}/devel/git \
|
||||
rsync:${PORTSDIR}/net/rsync
|
||||
|
||||
RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
|
||||
hs-MissingH>=0:${PORTSDIR}/devel/hs-MissingH \
|
||||
hs-pcre-light>=0:${PORTSDIR}/devel/hs-pcre-light \
|
||||
hs-utf8-string>=0:${PORTSDIR}/devel/hs-utf8-string \
|
||||
hs-SHA>=0:${PORTSDIR}/security/hs-SHA \
|
||||
hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc \
|
||||
hs-curl>0:${PORTSDIR}/ftp/hs-curl \
|
||||
git:${PORTSDIR}/devel/git \
|
||||
rsync:${PORTSDIR}/net/rsync
|
||||
|
||||
USE_PERL5= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
MAN1= git-annex.1 \
|
||||
git-annex-shell.1 \
|
||||
git-union-merge.1
|
||||
|
||||
LICENSE= GPLv3
|
||||
|
||||
PLIST_FILES= bin/git-annex \
|
||||
bin/git-annex-shell \
|
||||
bin/git-union-merge
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,2 +0,0 @@
|
||||
SHA256 (git-annex/3.20110702) = 66d633bcbd49d4a34b241222bf83f35e85af3207454de3fde4afaf1dd1409580
|
||||
SIZE (git-annex/3.20110702) = 378351
|
@ -1,45 +0,0 @@
|
||||
--- ./Makefile.orig 2011-07-02 21:08:05.000000000 +0200
|
||||
+++ ./Makefile 2011-08-01 09:35:21.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-PREFIX=/usr
|
||||
+PREFIX?=/usr/local
|
||||
IGNORE=-ignore-package monads-fd
|
||||
GHCFLAGS=-O2 -Wall $(IGNORE) -fspec-constr-count=5
|
||||
ifdef PROFILE
|
||||
@@ -43,12 +43,8 @@
|
||||
install: all
|
||||
install -d $(DESTDIR)$(PREFIX)/bin
|
||||
install $(bins) $(DESTDIR)$(PREFIX)/bin
|
||||
- install -d $(DESTDIR)$(PREFIX)/share/man/man1
|
||||
- install -m 0644 $(mans) $(DESTDIR)$(PREFIX)/share/man/man1
|
||||
- install -d $(DESTDIR)$(PREFIX)/share/doc/git-annex
|
||||
- if [ -d html ]; then \
|
||||
- rsync -a --delete html/ $(DESTDIR)$(PREFIX)/share/doc/git-annex/html/; \
|
||||
- fi
|
||||
+ install -d $(DESTDIR)$(PREFIX)/man/man1
|
||||
+ install -m 0644 $(mans) $(DESTDIR)$(PREFIX)/man/man1
|
||||
|
||||
test: $(bins)
|
||||
@if ! $(GHCMAKE) -O0 test; then \
|
||||
@@ -65,21 +61,7 @@
|
||||
@hpc report test --exclude=Main --exclude=QC
|
||||
@hpc markup test --exclude=Main --exclude=QC --destdir=.hpc >/dev/null
|
||||
|
||||
-# If ikiwiki is available, build static html docs suitable for being
|
||||
-# shipped in the software package.
|
||||
-ifeq ($(shell which ikiwiki),)
|
||||
-IKIWIKI=@echo "** ikiwiki not found, skipping building docs" >&2; true
|
||||
-else
|
||||
-IKIWIKI=ikiwiki
|
||||
-endif
|
||||
-
|
||||
docs: $(mans)
|
||||
- $(IKIWIKI) doc html -v --wikiname git-annex --plugin=goodstuff \
|
||||
- --no-usedirs --disable-plugin=openid --plugin=sidebar \
|
||||
- --underlaydir=/dev/null --disable-plugin=shortcut \
|
||||
- --disable-plugin=smiley \
|
||||
- --plugin=comments --set comments_pagespec="*" \
|
||||
- --exclude='news/.*'
|
||||
|
||||
clean:
|
||||
rm -rf build $(bins) $(mans) test configure *.tix .hpc \
|
@ -1,14 +0,0 @@
|
||||
git-annex allows managing files with git, without checking the file
|
||||
contents into git. While that may seem paradoxical, it is useful when
|
||||
dealing with files larger than git can currently easily handle, whether
|
||||
due to limitations in memory, checksumming time, or disk space.
|
||||
|
||||
Even without file content tracking, being able to manage files with git,
|
||||
move files around and delete files with versioned directory trees, and use
|
||||
branches and distributed clones, are all very handy reasons to use git.
|
||||
And annexed files can co-exist in the same git repository with regularly
|
||||
versioned files, which is convenient for maintaining documents, Makefiles,
|
||||
etc that are associated with annexed files but that benefit from full
|
||||
revision control.
|
||||
|
||||
WWW: http://git-annex.branchable.com/
|
@ -6,47 +6,33 @@
|
||||
#
|
||||
|
||||
PORTNAME= git-annex
|
||||
PORTVERSION= 3.20110702
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 3.20110707
|
||||
CATEGORIES= devel haskell
|
||||
MASTER_SITES= http://git.kitenet.net/?p=git-annex.git;a=snapshot;sf=tgz;h=refs/tags/
|
||||
DISTFILES= ${PORTVERSION}
|
||||
DIST_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= frase@frase.id.au
|
||||
COMMENT= Manage file hierarchies with git
|
||||
|
||||
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
|
||||
hs-MissingH>=0:${PORTSDIR}/devel/hs-MissingH \
|
||||
hs-pcre-light>=0:${PORTSDIR}/devel/hs-pcre-light \
|
||||
hs-utf8-string>=0:${PORTSDIR}/devel/hs-utf8-string \
|
||||
hs-SHA>=0:${PORTSDIR}/security/hs-SHA \
|
||||
hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc \
|
||||
hs-curl>0:${PORTSDIR}/ftp/hs-curl \
|
||||
git:${PORTSDIR}/devel/git \
|
||||
rsync:${PORTSDIR}/net/rsync
|
||||
|
||||
RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
|
||||
hs-MissingH>=0:${PORTSDIR}/devel/hs-MissingH \
|
||||
hs-pcre-light>=0:${PORTSDIR}/devel/hs-pcre-light \
|
||||
hs-utf8-string>=0:${PORTSDIR}/devel/hs-utf8-string \
|
||||
hs-SHA>=0:${PORTSDIR}/security/hs-SHA \
|
||||
hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc \
|
||||
hs-curl>0:${PORTSDIR}/ftp/hs-curl \
|
||||
git:${PORTSDIR}/devel/git \
|
||||
rsync:${PORTSDIR}/net/rsync
|
||||
|
||||
USE_PERL5= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
MAN1= git-annex.1 \
|
||||
git-annex-shell.1 \
|
||||
git-union-merge.1
|
||||
COMMENT= Manage files with git, without checking their contents into git
|
||||
|
||||
LICENSE= GPLv3
|
||||
FILE_LICENSE= GPL
|
||||
|
||||
PLIST_FILES= bin/git-annex \
|
||||
bin/git-annex-shell \
|
||||
bin/git-union-merge
|
||||
USE_CABAL= dataenc hS3 hslogger HTTP MissingH mtl network pcre-light \
|
||||
SHA utf8-string
|
||||
CABAL_SETUP= Setup.hs
|
||||
|
||||
.include <bsd.port.mk>
|
||||
USE_GMAKE= yes
|
||||
USE_PERL5_BUILD= yes
|
||||
|
||||
BUILD_DEPENDS+= rsync:${PORTSDIR}/net/rsync \
|
||||
git:${PORTSDIR}/devel/git
|
||||
|
||||
RUN_DEPENDS+= rsync:${PORTSDIR}/net/rsync \
|
||||
git:${PORTSDIR}/devel/git
|
||||
|
||||
EXECUTABLE= git-union-merge git-annex-shell git-annex
|
||||
STANDALONE= yes
|
||||
|
||||
MAN1SRC= .
|
||||
MAN1= git-union-merge.1 git-annex-shell.1 git-annex.1
|
||||
|
||||
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (git-annex/3.20110702) = 66d633bcbd49d4a34b241222bf83f35e85af3207454de3fde4afaf1dd1409580
|
||||
SIZE (git-annex/3.20110702) = 378351
|
||||
SHA256 (cabal/git-annex-3.20110707.tar.gz) = 174713eb7af035d10f90b8189ed1dc241ce379f70eba9ca416ac2c66089a0461
|
||||
SIZE (cabal/git-annex-3.20110707.tar.gz) = 374279
|
||||
|
@ -1,45 +1,11 @@
|
||||
--- ./Makefile.orig 2011-07-02 21:08:05.000000000 +0200
|
||||
+++ ./Makefile 2011-08-01 09:35:21.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-PREFIX=/usr
|
||||
+PREFIX?=/usr/local
|
||||
IGNORE=-ignore-package monads-fd
|
||||
GHCFLAGS=-O2 -Wall $(IGNORE) -fspec-constr-count=5
|
||||
ifdef PROFILE
|
||||
@@ -43,12 +43,8 @@
|
||||
install: all
|
||||
install -d $(DESTDIR)$(PREFIX)/bin
|
||||
install $(bins) $(DESTDIR)$(PREFIX)/bin
|
||||
- install -d $(DESTDIR)$(PREFIX)/share/man/man1
|
||||
- install -m 0644 $(mans) $(DESTDIR)$(PREFIX)/share/man/man1
|
||||
- install -d $(DESTDIR)$(PREFIX)/share/doc/git-annex
|
||||
- if [ -d html ]; then \
|
||||
- rsync -a --delete html/ $(DESTDIR)$(PREFIX)/share/doc/git-annex/html/; \
|
||||
- fi
|
||||
+ install -d $(DESTDIR)$(PREFIX)/man/man1
|
||||
+ install -m 0644 $(mans) $(DESTDIR)$(PREFIX)/man/man1
|
||||
--- ./Makefile.orig 2011-07-02 23:11:38.000000000 +0200
|
||||
+++ ./Makefile 2011-07-08 23:10:32.979799493 +0200
|
||||
@@ -73,6 +73,8 @@
|
||||
IKIWIKI=ikiwiki
|
||||
endif
|
||||
|
||||
test: $(bins)
|
||||
@if ! $(GHCMAKE) -O0 test; then \
|
||||
@@ -65,21 +61,7 @@
|
||||
@hpc report test --exclude=Main --exclude=QC
|
||||
@hpc markup test --exclude=Main --exclude=QC --destdir=.hpc >/dev/null
|
||||
|
||||
-# If ikiwiki is available, build static html docs suitable for being
|
||||
-# shipped in the software package.
|
||||
-ifeq ($(shell which ikiwiki),)
|
||||
-IKIWIKI=@echo "** ikiwiki not found, skipping building docs" >&2; true
|
||||
-else
|
||||
-IKIWIKI=ikiwiki
|
||||
-endif
|
||||
-
|
||||
+manuals: $(mans)
|
||||
+
|
||||
docs: $(mans)
|
||||
- $(IKIWIKI) doc html -v --wikiname git-annex --plugin=goodstuff \
|
||||
- --no-usedirs --disable-plugin=openid --plugin=sidebar \
|
||||
- --underlaydir=/dev/null --disable-plugin=shortcut \
|
||||
- --disable-plugin=smiley \
|
||||
- --plugin=comments --set comments_pagespec="*" \
|
||||
- --exclude='news/.*'
|
||||
|
||||
clean:
|
||||
rm -rf build $(bins) $(mans) test configure *.tix .hpc \
|
||||
$(IKIWIKI) doc html -v --wikiname git-annex --plugin=goodstuff \
|
||||
--no-usedirs --disable-plugin=openid --plugin=sidebar \
|
||||
|
14
devel/hs-git-annex/files/patch-Setup.hs
Normal file
14
devel/hs-git-annex/files/patch-Setup.hs
Normal file
@ -0,0 +1,14 @@
|
||||
--- ./Setup.hs.orig 2011-07-02 23:11:40.000000000 +0200
|
||||
+++ ./Setup.hs 2011-07-08 23:11:28.256484379 +0200
|
||||
@@ -9,9 +9,9 @@
|
||||
}
|
||||
|
||||
makeSources _ _ = do
|
||||
- system "make sources"
|
||||
+ system "gmake sources manuals"
|
||||
return (Nothing, [])
|
||||
|
||||
makeClean _ _ _ _ = do
|
||||
- system "make clean"
|
||||
+ system "gmake clean"
|
||||
return ()
|
@ -1,14 +1,14 @@
|
||||
git-annex allows managing files with git, without checking the file
|
||||
The git-annex allows managing files with git, without checking the file
|
||||
contents into git. While that may seem paradoxical, it is useful when
|
||||
dealing with files larger than git can currently easily handle, whether
|
||||
due to limitations in memory, checksumming time, or disk space.
|
||||
|
||||
Even without file content tracking, being able to manage files with git,
|
||||
move files around and delete files with versioned directory trees, and use
|
||||
branches and distributed clones, are all very handy reasons to use git.
|
||||
And annexed files can co-exist in the same git repository with regularly
|
||||
versioned files, which is convenient for maintaining documents, Makefiles,
|
||||
etc that are associated with annexed files but that benefit from full
|
||||
revision control.
|
||||
move files around and delete files with versioned directory trees, and
|
||||
use branches and distributed clones, are all very handy reasons to use
|
||||
git. And annexed files can co-exist in the same git repository with
|
||||
regularly versioned files, which is convenient for maintaining
|
||||
documents, Makefiles, etc that are associated with annexed files but
|
||||
that benefit from full revision control.
|
||||
|
||||
WWW: http://git-annex.branchable.com/
|
||||
WWW: http://git-annex.branchable.com/
|
||||
|
@ -75,6 +75,7 @@ gconf_port= devel/hs-gconf
|
||||
ghc-mtl_port= devel/hs-ghc-mtl
|
||||
ghc-paths_port= devel/hs-ghc-paths
|
||||
gio_port= devel/hs-gio
|
||||
git-annex_port= devel/hs-git-annex # executable
|
||||
glade_port= devel/hs-glade
|
||||
glib_port= devel/hs-glib
|
||||
GLUT_port= x11-toolkits/hs-GLUT
|
||||
|
Loading…
Reference in New Issue
Block a user