flvtool++ is a tool for hinting and manipulating the metadata of FLV

files. It was originally created for Facebook's Video project
(http://facebook.com/video/) for fast video hinting. It is loosely
based on the Ruby FLVTool2, but is written in C++ for performance
reasons.

WWW:	http://mirror.facebook.com/facebook/flvtool++/

PR:		ports/126336
Submitted by:	Gea-Suan Lin <gslin at gslin dot org>
This commit is contained in:
Dmitry Marakasov 2008-08-21 19:25:33 +00:00
parent 96454e5450
commit 3273e46b7c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=218966
7 changed files with 76 additions and 0 deletions

View File

@ -41,6 +41,7 @@
SUBDIR += ffmpeg
SUBDIR += ffmpegthumbnailer
SUBDIR += flv2mpeg4
SUBDIR += flvtool++
SUBDIR += freevo
SUBDIR += fxtv
SUBDIR += gaupol

View File

@ -0,0 +1,31 @@
# New ports collection makefile for: flvtool++
# Date created: 2008-08-07
# Whom: Gea-Suan Lin <gslin@gslin.org>
#
# $FreeBSD$
#
PORTNAME= flvtool++
PORTVERSION= 1.1
CATEGORIES= multimedia
MASTER_SITES= http://mirror.facebook.com/facebook/flvtool++/
MAINTAINER= gslin@gslin.org
COMMENT= Tool for hinting and manipulating the metadata of FLV files
LIB_DEPENDS= boost_iostreams:${PORTSDIR}/devel/boost
CFLAGS+= -I${LOCALBASE}/include/boost
NO_WRKSUBDIR= yes
PLIST_FILES= bin/flvtool++
USE_SCONS= yes
SCONS_BUILDENV= ${SCONS_ENV}
post-patch:
${REINPLACE_CMD} -e 's|/usr/local/include/boost-1_33_1|${LOCALBASE}/include|' \
${WRKSRC}/SConscript
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/flvtool++ ${PREFIX}/bin
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (flvtool++-1.1.tar.gz) = 817e94b46270dd09ae1e88289c38fb7d
SHA256 (flvtool++-1.1.tar.gz) = 12729726d870edc3c2130837a12a51249f928a6c2bbf11c8d8d5bc7a003d0f90
SIZE (flvtool++-1.1.tar.gz) = 11071

View File

@ -0,0 +1,10 @@
--- AMFData.h.orig 2008-08-07 21:59:28.000000000 +0800
+++ AMFData.h 2008-08-07 21:59:34.000000000 +0800
@@ -8,7 +8,6 @@
#pragma once
#include "common.h"
-#include <byteswap.h>
#include <float.h>
#include <math.h>
#include <netinet/in.h>

View File

@ -0,0 +1,11 @@
--- SConstruct.orig 2007-09-08 03:24:22.000000000 +0400
+++ SConstruct 2008-08-21 20:38:10.000000000 +0400
@@ -1,5 +1,7 @@
+import os
+
libd = '#lib/'
-env = Environment(CPPFLAGS='-ggdb -O3 -Wall', LINKFLAGS='-ggdb')
+env = Environment(CXX=os.environ['CXX'], CXXFLAGS=os.environ['CXXFLAGS'], ENV=os.environ)
env.TargetSignatures('content')
Export('env libd')

View File

@ -0,0 +1,13 @@
--- common.h.orig 2008-08-07 21:56:41.000000000 +0800
+++ common.h 2008-08-07 21:58:29.000000000 +0800
@@ -19,6 +19,10 @@
#include <boost/shared_ptr.hpp>
#include <stdexcept>
+#include <sys/endian.h>
+
+#define bswap_64 bswap64
+
using std::map;
using std::vector;
using std::string;

View File

@ -0,0 +1,7 @@
flvtool++ is a tool for hinting and manipulating the metadata of FLV
files. It was originally created for Facebook's Video project
(http://facebook.com/video/) for fast video hinting. It is loosely
based on the Ruby FLVTool2, but is written in C++ for performance
reasons.
WWW: http://mirror.facebook.com/facebook/flvtool++/