Upgrade to 3.2.

This commit is contained in:
Thomas Gellekum 2001-03-15 12:31:08 +00:00
parent 5a0b78e544
commit 3261eff2ee
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=39882
18 changed files with 336 additions and 378 deletions

View File

@ -6,17 +6,18 @@
#
PORTNAME= vtk
PORTVERSION= 3.1.2
PORTVERSION= 3.2
CATEGORIES= math
MASTER_SITES= ftp://public.kitware.com/pub/vtk/
DISTNAME= vtk312Unix
MASTER_SITES= ftp://public.kitware.com/pub/vtk/vtk${PORTVERSION}/
DISTNAME= vtk32-src-unix
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
USE_MESA= yes
WRKSRC= ${WRKDIR}/vtk31
WRKSRC= ${WRKDIR}/vtk${PORTVERSION}
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-mesa --with-shared --with-tcl --with-bsdmake
@ -25,8 +26,7 @@ CONFIGURE_ARGS+= --with-contrib --with-tkwidget
# Support for Python is compiled in by default.
.if !defined(WITHOUT_PYTHON)
CONFIGURE_ARGS+= --with-python
BUILD_DEPENDS+= python:${PORTSDIR}/lang/python
RUN_DEPENDS+= python:${PORTSDIR}/lang/python
USE_PYTHON= yes
.endif
.if defined(WITH_PATENTED)
@ -34,10 +34,14 @@ CONFIGURE_ARGS+= --with-patented
PLIST= ${PKGDIR}/pkg-plist.with_patented
.endif
post-patch:
${PERL} -pi -e "s|%%PYTHON_INCLUDEDIR%%|${PYTHON_INCLUDEDIR}|g" \
${WRKSRC}/user.make
post-install:
.if !defined(WITHOUT_PYTHON)
${PREFIX}/bin/python -c "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
${PREFIX}/bin/python -Oc "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
${PYTHON_CMD} -c "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
${PYTHON_CMD} -Oc "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (vtk312Unix.tar.gz) = ee61d8157412fce41d00d2a0690c647c
MD5 (vtk32-src-unix.tgz) = 11dc58c1c75a5be1d9c622386e87eb73

View File

@ -1,18 +1,18 @@
--- user.make.orig Thu Nov 13 09:25:29 1997
+++ user.make Sat Mar 25 20:36:54 2000
@@ -2,31 +2,32 @@
--- user.make.orig Wed Jul 12 14:22:11 2000
+++ user.make Wed Mar 14 16:07:25 2001
@@ -2,22 +2,23 @@
# by configure in system.make. At a minimum you should set
# the following Tcl/Tk values if you are planning to use Tcl/Tk
-TCL_INCLUDE=-I/home/ausable/software/src/tcl7.6/tcl7.6/generic
-TCL_LIB=/common/software/tcl7.6/sun4/5.4/lib/libtcl7.6.a
+TCL_INCLUDE=-I${PREFIX}/include/tcl8.2/generic
+TCL_LIB=${PREFIX}/lib/libtcl82.so
+TCL_INCLUDE=-I${PREFIX}/include/tcl8.3/generic
+TCL_LIB=${PREFIX}/lib/libtcl83.so
-TK_INCLUDE=-I/home/ausable/software/src/tcl7.6/tk4.2/generic
-TK_LIB=/common/software/tk4.2/sun4/5.4/lib/libtk4.2.a
+TK_INCLUDE=-I${PREFIX}/include/tk8.2/generic
+TK_LIB=${PREFIX}/lib/libtk82.so
+TK_INCLUDE=-I${PREFIX}/include/tk8.3/generic
+TK_LIB=${PREFIX}/lib/libtk83.so
-MESA_INCLUDE=-I/home/martink/storage/Mesa-1.2.6/include
-MESA_LIB=/home/martink/storage/Mesa-1.2.6/lib-sun4-solaris/libMesaGL.a
@ -21,7 +21,7 @@
# for python you must set this
-PYTHON_INCLUDES=-I/home/schroede/montnaro/Python-1.4/Include
+PYTHON_INCLUDES=-I${PREFIX}/include/python1.5
+PYTHON_INCLUDES=-I%%PYTHON_INCLUDEDIR%%
# Add additional CFLAGS and CXXFLAGS for compilation
# uncomment the following two lines to set your own flags
@ -29,19 +29,7 @@
-#USER_CXXFLAGS =
+USER_CFLAGS = -O2 -D__NO_MATH_INLINES
+USER_CXXFLAGS = -O2 -D__NO_MATH_INLINES
+X_EXTRA_LIBS = -lstdc++ -lgcc # Req'd for vtkpython.so to import
+X_EXTRA_LIBS = -lstdc++ -lgcc
# if you want to try the java support you'll need to set the following
# variables to match your environment and uncomment them
#
-#JDKHOME=/home/calvin/content/ITL/java-packages/dev-kits/JDK/jdk1.1
+#JDKHOME=$(PREFIX)/jdk1.1*
#JAVAC=${JDKHOME}/bin/javac
-#JAVA_CLASS_HOME=/home/martink/java
+#JAVA_CLASS_HOME=${JDKHOME}/lib
#JAVAH=${JDKHOME}/bin/javah
-#JAVA_INCLUDES=-I${JDKHOME}/include -I${JDKHOME}/include/solaris
+#JAVA_INCLUDES=-I${JDKHOME}/include -I${JDKHOME}/include/freebsd
#JAVA_CXX_LIB=/common/software/g++-2.7.1/sun4/5.4/lib/libiberty.a /common/software/g++-2.7.1/sun4/5.4/lib/libstdc++.a /common/software/g++-2.7.1/sun4/5.4/lib/gcc-lib/sparc-sun-solaris2.4/2.7.1/libgcc.a

View File

@ -1,74 +1,62 @@
*** configure.orig Mon Nov 2 13:23:46 1998
--- configure Sun Jan 31 18:45:59 1999
***************
*** 2744,2753 ****
# Not available on all versions: check for include file.
if test -f /usr/include/dlfcn.h; then
SHLIB_CFLAGS="-fpic"
! SHLIB_LD_LIBS=""
SHLIB_SUFFIX=".so"
DL_LIBS=""
! VTK_SHLIB_LINK_FLAGS="-shared"
else
SHLIB_CFLAGS=""
SHLIB_LD_LIBS=""
--- 2744,2753 ----
# Not available on all versions: check for include file.
if test -f /usr/include/dlfcn.h; then
SHLIB_CFLAGS="-fpic"
! SHLIB_LD_LIBS="${LIBS}"
SHLIB_SUFFIX=".so"
DL_LIBS=""
! VTK_SHLIB_BUILD_FLAGS="-shared"
else
SHLIB_CFLAGS=""
SHLIB_LD_LIBS=""
***************
*** 3084,3089 ****
--- 3084,3129 ----
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
THREAD_LIBS="-lpthread"
+ else
+ echo "$ac_t""no" 1>&6
+ fi
+
+ echo $ac_n "checking for pthread_create in -lc_r""... $ac_c" 1>&6
+ echo "configure:3191: checking for pthread_create in -lc_r" >&5
+ ac_lib_var=`echo c_r'_'pthread_create | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+ LIBS="-lc_r $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 3199 "configure"
+ #include "confdefs.h"
+ /* Override any gcc2 internal prototype to avoid an error. */
+ /* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+ char pthread_create();
+
+ int main() {
+ pthread_create()
+ ; return 0; }
+ EOF
+ if { (eval echo configure:3210: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
+ rm -rf conftest*
+ eval "ac_cv_lib_$ac_lib_var=yes"
+ else
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+ rm -rf conftest*
+ eval "ac_cv_lib_$ac_lib_var=no"
+ fi
+ rm -f conftest*
+ LIBS="$ac_save_LIBS"
+
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+ THREAD_LIBS="-lc_r"
else
echo "$ac_t""no" 1>&6
fi
--- configure.orig Tue Dec 5 19:32:37 2000
+++ configure Wed Mar 14 16:09:46 2001
@@ -2973,10 +2973,10 @@
# Not available on all versions: check for include file.
if test -f /usr/include/dlfcn.h; then
SHLIB_CFLAGS="-fpic"
- SHLIB_LD_LIBS=""
+ SHLIB_LD_LIBS="${LIBS}"
SHLIB_SUFFIX=".so"
DL_LIBS=""
- VTK_SHLIB_LINK_FLAGS="-shared"
+ VTK_SHLIB_BUILD_FLAGS="-shared"
else
SHLIB_CFLAGS=""
SHLIB_LD_LIBS=""
@@ -3393,6 +3393,46 @@
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
THREAD_LIBS="-lpthread"
+else
+ echo "$ac_t""no" 1>&6
+fi
+
+ echo $ac_n "checking for pthread_create in -lc_r""... $ac_c" 1>&6
+echo "configure:3191: checking for pthread_create in -lc_r" >&5
+ac_lib_var=`echo c_r'_'pthread_create | sed 'y%./+-%__p_%'`
+if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+else
+ ac_save_LIBS="$LIBS"
+LIBS="-lc_r $LIBS"
+cat > conftest.$ac_ext <<EOF
+#line 3199 "configure"
+#include "confdefs.h"
+/* Override any gcc2 internal prototype to avoid an error. */
+/* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+char pthread_create();
+
+int main() {
+pthread_create()
+; return 0; }
+EOF
+if { (eval echo configure:3210: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
+ rm -rf conftest*
+ eval "ac_cv_lib_$ac_lib_var=yes"
+else
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+ rm -rf conftest*
+ eval "ac_cv_lib_$ac_lib_var=no"
+fi
+rm -f conftest*
+LIBS="$ac_save_LIBS"
+
+fi
+if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+ THREAD_LIBS="-lc_r"
else
echo "$ac_t""no" 1>&6
fi

View File

@ -1,16 +1,16 @@
bin/vtk
lib/libVTKCommon.so
lib/libVTKCommonTcl.so
lib/libVTKCommonPython.so
lib/libVTKGraphics.so
lib/libVTKGraphicsTcl.so
lib/libVTKGraphicsPython.so
lib/libVTKImaging.so
lib/libVTKImagingTcl.so
lib/libVTKImagingPython.so
lib/libVTKCommonTcl.so
lib/libVTKContrib.so
lib/libVTKContribTcl.so
lib/libVTKContribPython.so
lib/libVTKContribTcl.so
lib/libVTKGraphics.so
lib/libVTKGraphicsPython.so
lib/libVTKGraphicsTcl.so
lib/libVTKImaging.so
lib/libVTKImagingPython.so
lib/libVTKImagingTcl.so
lib/vtk/python/VTK.py
lib/vtk/python/VTK.pyc
lib/vtk/python/VTK.pyo
@ -50,9 +50,12 @@ lib/vtk/python/vtkImageWindowWidget.pyo
lib/vtk/python/vtkRenderWidget.py
lib/vtk/python/vtkRenderWidget.pyc
lib/vtk/python/vtkRenderWidget.pyo
lib/vtk/python/vtkpython.so
lib/vtk/python/vtkTkImageViewerWidget
lib/vtk/python/vtkTkImageWindowWidget
lib/vtk/python/vtkTkRenderWidget
lib/vtk/python/vtkpython.so
lib/vtkTkImageViewerWidget
lib/vtkTkImageWindowWidget
lib/vtkTkRenderWidget
@dirrm lib/vtk/python
@dirrm lib/vtk

View File

@ -1,19 +1,19 @@
bin/vtk
lib/libVTKCommon.so
lib/libVTKCommonTcl.so
lib/libVTKCommonPython.so
lib/libVTKGraphics.so
lib/libVTKGraphicsTcl.so
lib/libVTKGraphicsPython.so
lib/libVTKImaging.so
lib/libVTKImagingTcl.so
lib/libVTKImagingPython.so
lib/libVTKPatented.so
lib/libVTKPatentedTcl.so
lib/libVTKPatentedPython.so
lib/libVTKCommonTcl.so
lib/libVTKContrib.so
lib/libVTKContribTcl.so
lib/libVTKContribPython.so
lib/libVTKContribTcl.so
lib/libVTKGraphics.so
lib/libVTKGraphicsPython.so
lib/libVTKGraphicsTcl.so
lib/libVTKImaging.so
lib/libVTKImagingPython.so
lib/libVTKImagingTcl.so
lib/libVTKPatented.so
lib/libVTKPatentedPython.so
lib/libVTKPatentedTcl.so
lib/vtk/python/VTK.py
lib/vtk/python/VTK.pyc
lib/vtk/python/VTK.pyo
@ -53,9 +53,12 @@ lib/vtk/python/vtkImageWindowWidget.pyo
lib/vtk/python/vtkRenderWidget.py
lib/vtk/python/vtkRenderWidget.pyc
lib/vtk/python/vtkRenderWidget.pyo
lib/vtk/python/vtkpython.so
lib/vtk/python/vtkTkImageViewerWidget
lib/vtk/python/vtkTkImageWindowWidget
lib/vtk/python/vtkTkRenderWidget
lib/vtk/python/vtkpython.so
lib/vtkTkImageViewerWidget
lib/vtkTkImageWindowWidget
lib/vtkTkRenderWidget
@dirrm lib/vtk/python
@dirrm lib/vtk

View File

@ -6,17 +6,18 @@
#
PORTNAME= vtk
PORTVERSION= 3.1.2
PORTVERSION= 3.2
CATEGORIES= math
MASTER_SITES= ftp://public.kitware.com/pub/vtk/
DISTNAME= vtk312Unix
MASTER_SITES= ftp://public.kitware.com/pub/vtk/vtk${PORTVERSION}/
DISTNAME= vtk32-src-unix
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
USE_MESA= yes
WRKSRC= ${WRKDIR}/vtk31
WRKSRC= ${WRKDIR}/vtk${PORTVERSION}
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-mesa --with-shared --with-tcl --with-bsdmake
@ -25,8 +26,7 @@ CONFIGURE_ARGS+= --with-contrib --with-tkwidget
# Support for Python is compiled in by default.
.if !defined(WITHOUT_PYTHON)
CONFIGURE_ARGS+= --with-python
BUILD_DEPENDS+= python:${PORTSDIR}/lang/python
RUN_DEPENDS+= python:${PORTSDIR}/lang/python
USE_PYTHON= yes
.endif
.if defined(WITH_PATENTED)
@ -34,10 +34,14 @@ CONFIGURE_ARGS+= --with-patented
PLIST= ${PKGDIR}/pkg-plist.with_patented
.endif
post-patch:
${PERL} -pi -e "s|%%PYTHON_INCLUDEDIR%%|${PYTHON_INCLUDEDIR}|g" \
${WRKSRC}/user.make
post-install:
.if !defined(WITHOUT_PYTHON)
${PREFIX}/bin/python -c "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
${PREFIX}/bin/python -Oc "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
${PYTHON_CMD} -c "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
${PYTHON_CMD} -Oc "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (vtk312Unix.tar.gz) = ee61d8157412fce41d00d2a0690c647c
MD5 (vtk32-src-unix.tgz) = 11dc58c1c75a5be1d9c622386e87eb73

View File

@ -1,18 +1,18 @@
--- user.make.orig Thu Nov 13 09:25:29 1997
+++ user.make Sat Mar 25 20:36:54 2000
@@ -2,31 +2,32 @@
--- user.make.orig Wed Jul 12 14:22:11 2000
+++ user.make Wed Mar 14 16:07:25 2001
@@ -2,22 +2,23 @@
# by configure in system.make. At a minimum you should set
# the following Tcl/Tk values if you are planning to use Tcl/Tk
-TCL_INCLUDE=-I/home/ausable/software/src/tcl7.6/tcl7.6/generic
-TCL_LIB=/common/software/tcl7.6/sun4/5.4/lib/libtcl7.6.a
+TCL_INCLUDE=-I${PREFIX}/include/tcl8.2/generic
+TCL_LIB=${PREFIX}/lib/libtcl82.so
+TCL_INCLUDE=-I${PREFIX}/include/tcl8.3/generic
+TCL_LIB=${PREFIX}/lib/libtcl83.so
-TK_INCLUDE=-I/home/ausable/software/src/tcl7.6/tk4.2/generic
-TK_LIB=/common/software/tk4.2/sun4/5.4/lib/libtk4.2.a
+TK_INCLUDE=-I${PREFIX}/include/tk8.2/generic
+TK_LIB=${PREFIX}/lib/libtk82.so
+TK_INCLUDE=-I${PREFIX}/include/tk8.3/generic
+TK_LIB=${PREFIX}/lib/libtk83.so
-MESA_INCLUDE=-I/home/martink/storage/Mesa-1.2.6/include
-MESA_LIB=/home/martink/storage/Mesa-1.2.6/lib-sun4-solaris/libMesaGL.a
@ -21,7 +21,7 @@
# for python you must set this
-PYTHON_INCLUDES=-I/home/schroede/montnaro/Python-1.4/Include
+PYTHON_INCLUDES=-I${PREFIX}/include/python1.5
+PYTHON_INCLUDES=-I%%PYTHON_INCLUDEDIR%%
# Add additional CFLAGS and CXXFLAGS for compilation
# uncomment the following two lines to set your own flags
@ -29,19 +29,7 @@
-#USER_CXXFLAGS =
+USER_CFLAGS = -O2 -D__NO_MATH_INLINES
+USER_CXXFLAGS = -O2 -D__NO_MATH_INLINES
+X_EXTRA_LIBS = -lstdc++ -lgcc # Req'd for vtkpython.so to import
+X_EXTRA_LIBS = -lstdc++ -lgcc
# if you want to try the java support you'll need to set the following
# variables to match your environment and uncomment them
#
-#JDKHOME=/home/calvin/content/ITL/java-packages/dev-kits/JDK/jdk1.1
+#JDKHOME=$(PREFIX)/jdk1.1*
#JAVAC=${JDKHOME}/bin/javac
-#JAVA_CLASS_HOME=/home/martink/java
+#JAVA_CLASS_HOME=${JDKHOME}/lib
#JAVAH=${JDKHOME}/bin/javah
-#JAVA_INCLUDES=-I${JDKHOME}/include -I${JDKHOME}/include/solaris
+#JAVA_INCLUDES=-I${JDKHOME}/include -I${JDKHOME}/include/freebsd
#JAVA_CXX_LIB=/common/software/g++-2.7.1/sun4/5.4/lib/libiberty.a /common/software/g++-2.7.1/sun4/5.4/lib/libstdc++.a /common/software/g++-2.7.1/sun4/5.4/lib/gcc-lib/sparc-sun-solaris2.4/2.7.1/libgcc.a

View File

@ -1,74 +1,62 @@
*** configure.orig Mon Nov 2 13:23:46 1998
--- configure Sun Jan 31 18:45:59 1999
***************
*** 2744,2753 ****
# Not available on all versions: check for include file.
if test -f /usr/include/dlfcn.h; then
SHLIB_CFLAGS="-fpic"
! SHLIB_LD_LIBS=""
SHLIB_SUFFIX=".so"
DL_LIBS=""
! VTK_SHLIB_LINK_FLAGS="-shared"
else
SHLIB_CFLAGS=""
SHLIB_LD_LIBS=""
--- 2744,2753 ----
# Not available on all versions: check for include file.
if test -f /usr/include/dlfcn.h; then
SHLIB_CFLAGS="-fpic"
! SHLIB_LD_LIBS="${LIBS}"
SHLIB_SUFFIX=".so"
DL_LIBS=""
! VTK_SHLIB_BUILD_FLAGS="-shared"
else
SHLIB_CFLAGS=""
SHLIB_LD_LIBS=""
***************
*** 3084,3089 ****
--- 3084,3129 ----
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
THREAD_LIBS="-lpthread"
+ else
+ echo "$ac_t""no" 1>&6
+ fi
+
+ echo $ac_n "checking for pthread_create in -lc_r""... $ac_c" 1>&6
+ echo "configure:3191: checking for pthread_create in -lc_r" >&5
+ ac_lib_var=`echo c_r'_'pthread_create | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+ LIBS="-lc_r $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 3199 "configure"
+ #include "confdefs.h"
+ /* Override any gcc2 internal prototype to avoid an error. */
+ /* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+ char pthread_create();
+
+ int main() {
+ pthread_create()
+ ; return 0; }
+ EOF
+ if { (eval echo configure:3210: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
+ rm -rf conftest*
+ eval "ac_cv_lib_$ac_lib_var=yes"
+ else
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+ rm -rf conftest*
+ eval "ac_cv_lib_$ac_lib_var=no"
+ fi
+ rm -f conftest*
+ LIBS="$ac_save_LIBS"
+
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+ THREAD_LIBS="-lc_r"
else
echo "$ac_t""no" 1>&6
fi
--- configure.orig Tue Dec 5 19:32:37 2000
+++ configure Wed Mar 14 16:09:46 2001
@@ -2973,10 +2973,10 @@
# Not available on all versions: check for include file.
if test -f /usr/include/dlfcn.h; then
SHLIB_CFLAGS="-fpic"
- SHLIB_LD_LIBS=""
+ SHLIB_LD_LIBS="${LIBS}"
SHLIB_SUFFIX=".so"
DL_LIBS=""
- VTK_SHLIB_LINK_FLAGS="-shared"
+ VTK_SHLIB_BUILD_FLAGS="-shared"
else
SHLIB_CFLAGS=""
SHLIB_LD_LIBS=""
@@ -3393,6 +3393,46 @@
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
THREAD_LIBS="-lpthread"
+else
+ echo "$ac_t""no" 1>&6
+fi
+
+ echo $ac_n "checking for pthread_create in -lc_r""... $ac_c" 1>&6
+echo "configure:3191: checking for pthread_create in -lc_r" >&5
+ac_lib_var=`echo c_r'_'pthread_create | sed 'y%./+-%__p_%'`
+if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+else
+ ac_save_LIBS="$LIBS"
+LIBS="-lc_r $LIBS"
+cat > conftest.$ac_ext <<EOF
+#line 3199 "configure"
+#include "confdefs.h"
+/* Override any gcc2 internal prototype to avoid an error. */
+/* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+char pthread_create();
+
+int main() {
+pthread_create()
+; return 0; }
+EOF
+if { (eval echo configure:3210: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
+ rm -rf conftest*
+ eval "ac_cv_lib_$ac_lib_var=yes"
+else
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+ rm -rf conftest*
+ eval "ac_cv_lib_$ac_lib_var=no"
+fi
+rm -f conftest*
+LIBS="$ac_save_LIBS"
+
+fi
+if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+ THREAD_LIBS="-lc_r"
else
echo "$ac_t""no" 1>&6
fi

View File

@ -1,16 +1,16 @@
bin/vtk
lib/libVTKCommon.so
lib/libVTKCommonTcl.so
lib/libVTKCommonPython.so
lib/libVTKGraphics.so
lib/libVTKGraphicsTcl.so
lib/libVTKGraphicsPython.so
lib/libVTKImaging.so
lib/libVTKImagingTcl.so
lib/libVTKImagingPython.so
lib/libVTKCommonTcl.so
lib/libVTKContrib.so
lib/libVTKContribTcl.so
lib/libVTKContribPython.so
lib/libVTKContribTcl.so
lib/libVTKGraphics.so
lib/libVTKGraphicsPython.so
lib/libVTKGraphicsTcl.so
lib/libVTKImaging.so
lib/libVTKImagingPython.so
lib/libVTKImagingTcl.so
lib/vtk/python/VTK.py
lib/vtk/python/VTK.pyc
lib/vtk/python/VTK.pyo
@ -50,9 +50,12 @@ lib/vtk/python/vtkImageWindowWidget.pyo
lib/vtk/python/vtkRenderWidget.py
lib/vtk/python/vtkRenderWidget.pyc
lib/vtk/python/vtkRenderWidget.pyo
lib/vtk/python/vtkpython.so
lib/vtk/python/vtkTkImageViewerWidget
lib/vtk/python/vtkTkImageWindowWidget
lib/vtk/python/vtkTkRenderWidget
lib/vtk/python/vtkpython.so
lib/vtkTkImageViewerWidget
lib/vtkTkImageWindowWidget
lib/vtkTkRenderWidget
@dirrm lib/vtk/python
@dirrm lib/vtk

View File

@ -1,19 +1,19 @@
bin/vtk
lib/libVTKCommon.so
lib/libVTKCommonTcl.so
lib/libVTKCommonPython.so
lib/libVTKGraphics.so
lib/libVTKGraphicsTcl.so
lib/libVTKGraphicsPython.so
lib/libVTKImaging.so
lib/libVTKImagingTcl.so
lib/libVTKImagingPython.so
lib/libVTKPatented.so
lib/libVTKPatentedTcl.so
lib/libVTKPatentedPython.so
lib/libVTKCommonTcl.so
lib/libVTKContrib.so
lib/libVTKContribTcl.so
lib/libVTKContribPython.so
lib/libVTKContribTcl.so
lib/libVTKGraphics.so
lib/libVTKGraphicsPython.so
lib/libVTKGraphicsTcl.so
lib/libVTKImaging.so
lib/libVTKImagingPython.so
lib/libVTKImagingTcl.so
lib/libVTKPatented.so
lib/libVTKPatentedPython.so
lib/libVTKPatentedTcl.so
lib/vtk/python/VTK.py
lib/vtk/python/VTK.pyc
lib/vtk/python/VTK.pyo
@ -53,9 +53,12 @@ lib/vtk/python/vtkImageWindowWidget.pyo
lib/vtk/python/vtkRenderWidget.py
lib/vtk/python/vtkRenderWidget.pyc
lib/vtk/python/vtkRenderWidget.pyo
lib/vtk/python/vtkpython.so
lib/vtk/python/vtkTkImageViewerWidget
lib/vtk/python/vtkTkImageWindowWidget
lib/vtk/python/vtkTkRenderWidget
lib/vtk/python/vtkpython.so
lib/vtkTkImageViewerWidget
lib/vtkTkImageWindowWidget
lib/vtkTkRenderWidget
@dirrm lib/vtk/python
@dirrm lib/vtk

View File

@ -6,17 +6,18 @@
#
PORTNAME= vtk
PORTVERSION= 3.1.2
PORTVERSION= 3.2
CATEGORIES= math
MASTER_SITES= ftp://public.kitware.com/pub/vtk/
DISTNAME= vtk312Unix
MASTER_SITES= ftp://public.kitware.com/pub/vtk/vtk${PORTVERSION}/
DISTNAME= vtk32-src-unix
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
USE_MESA= yes
WRKSRC= ${WRKDIR}/vtk31
WRKSRC= ${WRKDIR}/vtk${PORTVERSION}
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-mesa --with-shared --with-tcl --with-bsdmake
@ -25,8 +26,7 @@ CONFIGURE_ARGS+= --with-contrib --with-tkwidget
# Support for Python is compiled in by default.
.if !defined(WITHOUT_PYTHON)
CONFIGURE_ARGS+= --with-python
BUILD_DEPENDS+= python:${PORTSDIR}/lang/python
RUN_DEPENDS+= python:${PORTSDIR}/lang/python
USE_PYTHON= yes
.endif
.if defined(WITH_PATENTED)
@ -34,10 +34,14 @@ CONFIGURE_ARGS+= --with-patented
PLIST= ${PKGDIR}/pkg-plist.with_patented
.endif
post-patch:
${PERL} -pi -e "s|%%PYTHON_INCLUDEDIR%%|${PYTHON_INCLUDEDIR}|g" \
${WRKSRC}/user.make
post-install:
.if !defined(WITHOUT_PYTHON)
${PREFIX}/bin/python -c "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
${PREFIX}/bin/python -Oc "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
${PYTHON_CMD} -c "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
${PYTHON_CMD} -Oc "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (vtk312Unix.tar.gz) = ee61d8157412fce41d00d2a0690c647c
MD5 (vtk32-src-unix.tgz) = 11dc58c1c75a5be1d9c622386e87eb73

View File

@ -1,18 +1,18 @@
--- user.make.orig Thu Nov 13 09:25:29 1997
+++ user.make Sat Mar 25 20:36:54 2000
@@ -2,31 +2,32 @@
--- user.make.orig Wed Jul 12 14:22:11 2000
+++ user.make Wed Mar 14 16:07:25 2001
@@ -2,22 +2,23 @@
# by configure in system.make. At a minimum you should set
# the following Tcl/Tk values if you are planning to use Tcl/Tk
-TCL_INCLUDE=-I/home/ausable/software/src/tcl7.6/tcl7.6/generic
-TCL_LIB=/common/software/tcl7.6/sun4/5.4/lib/libtcl7.6.a
+TCL_INCLUDE=-I${PREFIX}/include/tcl8.2/generic
+TCL_LIB=${PREFIX}/lib/libtcl82.so
+TCL_INCLUDE=-I${PREFIX}/include/tcl8.3/generic
+TCL_LIB=${PREFIX}/lib/libtcl83.so
-TK_INCLUDE=-I/home/ausable/software/src/tcl7.6/tk4.2/generic
-TK_LIB=/common/software/tk4.2/sun4/5.4/lib/libtk4.2.a
+TK_INCLUDE=-I${PREFIX}/include/tk8.2/generic
+TK_LIB=${PREFIX}/lib/libtk82.so
+TK_INCLUDE=-I${PREFIX}/include/tk8.3/generic
+TK_LIB=${PREFIX}/lib/libtk83.so
-MESA_INCLUDE=-I/home/martink/storage/Mesa-1.2.6/include
-MESA_LIB=/home/martink/storage/Mesa-1.2.6/lib-sun4-solaris/libMesaGL.a
@ -21,7 +21,7 @@
# for python you must set this
-PYTHON_INCLUDES=-I/home/schroede/montnaro/Python-1.4/Include
+PYTHON_INCLUDES=-I${PREFIX}/include/python1.5
+PYTHON_INCLUDES=-I%%PYTHON_INCLUDEDIR%%
# Add additional CFLAGS and CXXFLAGS for compilation
# uncomment the following two lines to set your own flags
@ -29,19 +29,7 @@
-#USER_CXXFLAGS =
+USER_CFLAGS = -O2 -D__NO_MATH_INLINES
+USER_CXXFLAGS = -O2 -D__NO_MATH_INLINES
+X_EXTRA_LIBS = -lstdc++ -lgcc # Req'd for vtkpython.so to import
+X_EXTRA_LIBS = -lstdc++ -lgcc
# if you want to try the java support you'll need to set the following
# variables to match your environment and uncomment them
#
-#JDKHOME=/home/calvin/content/ITL/java-packages/dev-kits/JDK/jdk1.1
+#JDKHOME=$(PREFIX)/jdk1.1*
#JAVAC=${JDKHOME}/bin/javac
-#JAVA_CLASS_HOME=/home/martink/java
+#JAVA_CLASS_HOME=${JDKHOME}/lib
#JAVAH=${JDKHOME}/bin/javah
-#JAVA_INCLUDES=-I${JDKHOME}/include -I${JDKHOME}/include/solaris
+#JAVA_INCLUDES=-I${JDKHOME}/include -I${JDKHOME}/include/freebsd
#JAVA_CXX_LIB=/common/software/g++-2.7.1/sun4/5.4/lib/libiberty.a /common/software/g++-2.7.1/sun4/5.4/lib/libstdc++.a /common/software/g++-2.7.1/sun4/5.4/lib/gcc-lib/sparc-sun-solaris2.4/2.7.1/libgcc.a

View File

@ -1,74 +1,62 @@
*** configure.orig Mon Nov 2 13:23:46 1998
--- configure Sun Jan 31 18:45:59 1999
***************
*** 2744,2753 ****
# Not available on all versions: check for include file.
if test -f /usr/include/dlfcn.h; then
SHLIB_CFLAGS="-fpic"
! SHLIB_LD_LIBS=""
SHLIB_SUFFIX=".so"
DL_LIBS=""
! VTK_SHLIB_LINK_FLAGS="-shared"
else
SHLIB_CFLAGS=""
SHLIB_LD_LIBS=""
--- 2744,2753 ----
# Not available on all versions: check for include file.
if test -f /usr/include/dlfcn.h; then
SHLIB_CFLAGS="-fpic"
! SHLIB_LD_LIBS="${LIBS}"
SHLIB_SUFFIX=".so"
DL_LIBS=""
! VTK_SHLIB_BUILD_FLAGS="-shared"
else
SHLIB_CFLAGS=""
SHLIB_LD_LIBS=""
***************
*** 3084,3089 ****
--- 3084,3129 ----
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
THREAD_LIBS="-lpthread"
+ else
+ echo "$ac_t""no" 1>&6
+ fi
+
+ echo $ac_n "checking for pthread_create in -lc_r""... $ac_c" 1>&6
+ echo "configure:3191: checking for pthread_create in -lc_r" >&5
+ ac_lib_var=`echo c_r'_'pthread_create | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+ LIBS="-lc_r $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 3199 "configure"
+ #include "confdefs.h"
+ /* Override any gcc2 internal prototype to avoid an error. */
+ /* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+ char pthread_create();
+
+ int main() {
+ pthread_create()
+ ; return 0; }
+ EOF
+ if { (eval echo configure:3210: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
+ rm -rf conftest*
+ eval "ac_cv_lib_$ac_lib_var=yes"
+ else
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+ rm -rf conftest*
+ eval "ac_cv_lib_$ac_lib_var=no"
+ fi
+ rm -f conftest*
+ LIBS="$ac_save_LIBS"
+
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+ THREAD_LIBS="-lc_r"
else
echo "$ac_t""no" 1>&6
fi
--- configure.orig Tue Dec 5 19:32:37 2000
+++ configure Wed Mar 14 16:09:46 2001
@@ -2973,10 +2973,10 @@
# Not available on all versions: check for include file.
if test -f /usr/include/dlfcn.h; then
SHLIB_CFLAGS="-fpic"
- SHLIB_LD_LIBS=""
+ SHLIB_LD_LIBS="${LIBS}"
SHLIB_SUFFIX=".so"
DL_LIBS=""
- VTK_SHLIB_LINK_FLAGS="-shared"
+ VTK_SHLIB_BUILD_FLAGS="-shared"
else
SHLIB_CFLAGS=""
SHLIB_LD_LIBS=""
@@ -3393,6 +3393,46 @@
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
THREAD_LIBS="-lpthread"
+else
+ echo "$ac_t""no" 1>&6
+fi
+
+ echo $ac_n "checking for pthread_create in -lc_r""... $ac_c" 1>&6
+echo "configure:3191: checking for pthread_create in -lc_r" >&5
+ac_lib_var=`echo c_r'_'pthread_create | sed 'y%./+-%__p_%'`
+if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+else
+ ac_save_LIBS="$LIBS"
+LIBS="-lc_r $LIBS"
+cat > conftest.$ac_ext <<EOF
+#line 3199 "configure"
+#include "confdefs.h"
+/* Override any gcc2 internal prototype to avoid an error. */
+/* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+char pthread_create();
+
+int main() {
+pthread_create()
+; return 0; }
+EOF
+if { (eval echo configure:3210: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
+ rm -rf conftest*
+ eval "ac_cv_lib_$ac_lib_var=yes"
+else
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+ rm -rf conftest*
+ eval "ac_cv_lib_$ac_lib_var=no"
+fi
+rm -f conftest*
+LIBS="$ac_save_LIBS"
+
+fi
+if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+ THREAD_LIBS="-lc_r"
else
echo "$ac_t""no" 1>&6
fi

View File

@ -1,16 +1,16 @@
bin/vtk
lib/libVTKCommon.so
lib/libVTKCommonTcl.so
lib/libVTKCommonPython.so
lib/libVTKGraphics.so
lib/libVTKGraphicsTcl.so
lib/libVTKGraphicsPython.so
lib/libVTKImaging.so
lib/libVTKImagingTcl.so
lib/libVTKImagingPython.so
lib/libVTKCommonTcl.so
lib/libVTKContrib.so
lib/libVTKContribTcl.so
lib/libVTKContribPython.so
lib/libVTKContribTcl.so
lib/libVTKGraphics.so
lib/libVTKGraphicsPython.so
lib/libVTKGraphicsTcl.so
lib/libVTKImaging.so
lib/libVTKImagingPython.so
lib/libVTKImagingTcl.so
lib/vtk/python/VTK.py
lib/vtk/python/VTK.pyc
lib/vtk/python/VTK.pyo
@ -50,9 +50,12 @@ lib/vtk/python/vtkImageWindowWidget.pyo
lib/vtk/python/vtkRenderWidget.py
lib/vtk/python/vtkRenderWidget.pyc
lib/vtk/python/vtkRenderWidget.pyo
lib/vtk/python/vtkpython.so
lib/vtk/python/vtkTkImageViewerWidget
lib/vtk/python/vtkTkImageWindowWidget
lib/vtk/python/vtkTkRenderWidget
lib/vtk/python/vtkpython.so
lib/vtkTkImageViewerWidget
lib/vtkTkImageWindowWidget
lib/vtkTkRenderWidget
@dirrm lib/vtk/python
@dirrm lib/vtk

View File

@ -1,19 +1,19 @@
bin/vtk
lib/libVTKCommon.so
lib/libVTKCommonTcl.so
lib/libVTKCommonPython.so
lib/libVTKGraphics.so
lib/libVTKGraphicsTcl.so
lib/libVTKGraphicsPython.so
lib/libVTKImaging.so
lib/libVTKImagingTcl.so
lib/libVTKImagingPython.so
lib/libVTKPatented.so
lib/libVTKPatentedTcl.so
lib/libVTKPatentedPython.so
lib/libVTKCommonTcl.so
lib/libVTKContrib.so
lib/libVTKContribTcl.so
lib/libVTKContribPython.so
lib/libVTKContribTcl.so
lib/libVTKGraphics.so
lib/libVTKGraphicsPython.so
lib/libVTKGraphicsTcl.so
lib/libVTKImaging.so
lib/libVTKImagingPython.so
lib/libVTKImagingTcl.so
lib/libVTKPatented.so
lib/libVTKPatentedPython.so
lib/libVTKPatentedTcl.so
lib/vtk/python/VTK.py
lib/vtk/python/VTK.pyc
lib/vtk/python/VTK.pyo
@ -53,9 +53,12 @@ lib/vtk/python/vtkImageWindowWidget.pyo
lib/vtk/python/vtkRenderWidget.py
lib/vtk/python/vtkRenderWidget.pyc
lib/vtk/python/vtkRenderWidget.pyo
lib/vtk/python/vtkpython.so
lib/vtk/python/vtkTkImageViewerWidget
lib/vtk/python/vtkTkImageWindowWidget
lib/vtk/python/vtkTkRenderWidget
lib/vtk/python/vtkpython.so
lib/vtkTkImageViewerWidget
lib/vtkTkImageWindowWidget
lib/vtkTkRenderWidget
@dirrm lib/vtk/python
@dirrm lib/vtk