Adding m4ri. M4RI is a library for fast arithmetic with dense matrices over F2.

It can be used by SageMath.
This commit is contained in:
Thierry Thomas 2020-03-26 16:25:42 +00:00
parent 5ffb8ad723
commit 325cdfb849
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=529200
6 changed files with 81 additions and 0 deletions

View File

@ -370,6 +370,7 @@
SUBDIR += lrslib
SUBDIR += ltl
SUBDIR += ltl2ba
SUBDIR += m4ri
SUBDIR += mate-calc
SUBDIR += math77
SUBDIR += mathgl

31
math/m4ri/Makefile Normal file
View File

@ -0,0 +1,31 @@
# Created by: thierry@pompo.net
# $FreeBSD$
PORTNAME= M4RI
PORTVERSION= 20200125
DISTVERSIONPREFIX= release-
CATEGORIES= math
MAINTAINER= thierry@FreeBSD.org
COMMENT= Library for fast arithmetic with dense matrices over F2
LICENSE= GPLv2+
LIB_DEPENDS= libpng.so:graphics/png
USE_GITHUB= yes
GH_ACCOUNT= malb
GH_PROJECT= ${PORTNAME:tl}
USES= autoreconf libtool localbase pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
.if defined(MAINTAINER_MODE)
TEST_TARGET= check
# Only needed for tests
USES+= gmake
.endif
.include <bsd.port.mk>

3
math/m4ri/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1582997748
SHA256 (malb-m4ri-release-20200125_GH0.tar.gz) = 7369adcecb72d4dacfb23fd437a6b59a956f76b26dee07f32558cb915a9d6e9d
SIZE (malb-m4ri-release-20200125_GH0.tar.gz) = 178089

View File

@ -0,0 +1,11 @@
--- Makefile.am.orig 2020-01-25 04:35:59 UTC
+++ Makefile.am
@@ -57,7 +57,7 @@ EXTRA_DIST=m4ri/Doxyfile
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = m4ri.pc
-libm4ri_la_LDFLAGS = -release 0.0.$(RELEASE) -no-undefined
+libm4ri_la_LDFLAGS = -no-undefined
libm4ri_la_LIBADD = $(LIBPNG_LIBADD) $(LIBM)
SUBDIRS = . tests

7
math/m4ri/pkg-descr Normal file
View File

@ -0,0 +1,7 @@
M4RI is a library for fast arithmetic with dense matrices over F2. The name M4RI
comes from the first implemented algorithm: The "Method of the Four Russians"
inversion algorithm published by Gregory Bard. This algorithm in turn is named
after the "Method of the Four Russians" multiplication algorithm which is
probably better referred to as Kronrod's method.
WWW: https://bitbucket.org/malb/m4ri/src/master/

28
math/m4ri/pkg-plist Normal file
View File

@ -0,0 +1,28 @@
include/m4ri/brilliantrussian.h
include/m4ri/debug_dump.h
include/m4ri/djb.h
include/m4ri/echelonform.h
include/m4ri/graycode.h
include/m4ri/io.h
include/m4ri/m4ri.h
include/m4ri/m4ri_config.h
include/m4ri/misc.h
include/m4ri/mmc.h
include/m4ri/mp.h
include/m4ri/mzd.h
include/m4ri/mzp.h
include/m4ri/parity.h
include/m4ri/ple.h
include/m4ri/ple_russian.h
include/m4ri/ple_russian_template.h
include/m4ri/solve.h
include/m4ri/strassen.h
include/m4ri/triangular.h
include/m4ri/triangular_russian.h
include/m4ri/xor.h
include/m4ri/xor_template.h
lib/libm4ri.a
lib/libm4ri.so
lib/libm4ri.so.0
lib/libm4ri.so.0.0.0
libdata/pkgconfig/m4ri.pc