comms/aldo: Update 0.7.5 -> 0.7.7
Port changes: * Change to DISTVERSION * Add LICENSE/LICENSE_FILE * Remove USE_GCC * Add USES=localbase instead of CPPFLAGS/LIBS PR: 226349 Submitted by: Dmitri Goutnik <dg@syrec.org> Approved by: lambert@lambertfam.org (maintainer timeout; 19 days)
This commit is contained in:
parent
6117bae7c3
commit
321e6555c0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=465407
@ -2,21 +2,20 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= aldo
|
||||
PORTVERSION= 0.7.5
|
||||
PORTREVISION= 6
|
||||
DISTVERSION= 0.7.7
|
||||
CATEGORIES= comms hamradio
|
||||
MASTER_SITES= SAVANNAH
|
||||
|
||||
MAINTAINER= lambert@lambertfam.org
|
||||
COMMENT= Morse code training program
|
||||
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libao.so:audio/libao
|
||||
|
||||
USES= compiler:c++0x gmake localbase tar:bzip2
|
||||
GNU_CONFIGURE= yes
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LIBS+= -L${LOCALBASE}/lib
|
||||
USES= gmake libtool tar:bzip2
|
||||
USE_GCC= any
|
||||
|
||||
PLIST_FILES= bin/aldo \
|
||||
man/man1/aldo.1.gz
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (aldo-0.7.5.tar.bz2) = 15f9dbcab48c6ba3fba6a4d3e9a030bad3255d4a4b47677388a1e46782aa84ea
|
||||
SIZE (aldo-0.7.5.tar.bz2) = 98612
|
||||
TIMESTAMP = 1521837318
|
||||
SHA256 (aldo-0.7.7.tar.bz2) = f1b8849d09267fff3c1f5122097d90fec261291f51b1e075f37fad8f1b7d9f92
|
||||
SIZE (aldo-0.7.7.tar.bz2) = 112000
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- configure.orig 2007-11-05 09:22:11 UTC
|
||||
--- configure.orig 2012-03-31 11:55:36 UTC
|
||||
+++ configure
|
||||
@@ -2220,9 +2220,6 @@ am__tar='${AMTAR} chof - "$$tardir"'; am
|
||||
@@ -2725,9 +2725,6 @@ am__tar='$${TAR-tar} chof - "$$tardir"'
|
||||
|
||||
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- include/Makefile.in.orig 2017-03-24 13:33:28 UTC
|
||||
--- include/Makefile.in.orig 2012-03-31 11:55:36 UTC
|
||||
+++ include/Makefile.in
|
||||
@@ -101,7 +101,7 @@ PATH_SEPARATOR = @PATH_SEPARATOR@
|
||||
@@ -105,7 +105,7 @@ PATH_SEPARATOR = @PATH_SEPARATOR@
|
||||
SET_MAKE = @SET_MAKE@
|
||||
SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- src/audioworkspace.cc.orig 2007-11-05 08:58:46 UTC
|
||||
+++ src/audioworkspace.cc
|
||||
@@ -31,7 +31,8 @@
|
||||
#include <cmath>
|
||||
#include <iostream>
|
||||
#include <limits>
|
||||
-
|
||||
+#include <string.h>
|
||||
+
|
||||
using namespace std;
|
||||
using namespace libaudiostream;
|
||||
|
||||
@@ -104,6 +105,7 @@ oastream AudioWorkSpace::create_output_s
|
||||
{
|
||||
ao_sample_format format;
|
||||
|
||||
+ memset(&format, 0, sizeof(format));
|
||||
format.bits = m_bits;
|
||||
format.channels = m_channels;
|
||||
format.rate = m_sample_rate;
|
25
comms/aldo/files/patch-src_menu.cc
Normal file
25
comms/aldo/files/patch-src_menu.cc
Normal file
@ -0,0 +1,25 @@
|
||||
--- src/menu.cc.orig 2012-03-31 11:32:34 UTC
|
||||
+++ src/menu.cc
|
||||
@@ -112,19 +112,19 @@ void Menu::add_item(id_type id, std::str
|
||||
|
||||
void Menu::add_item_at(unsigned int pos, id_type id, std::string c, Function1 f)
|
||||
{
|
||||
- IT it(&m_its[pos]);
|
||||
+ IT it(m_its.begin() + pos);
|
||||
m_its.insert(it, Item(id,c,f) );
|
||||
}
|
||||
|
||||
void Menu::add_item_at(unsigned int pos, id_type id, std::string c, Function2 f)
|
||||
{
|
||||
- IT it(&m_its[pos]);
|
||||
+ IT it(m_its.begin() + pos);
|
||||
m_its.insert(it, Item(id,c,f) );
|
||||
}
|
||||
|
||||
void Menu::delete_item_at(unsigned int pos)
|
||||
{
|
||||
- IT it(&m_its[pos]);
|
||||
+ IT it(m_its.begin() + pos);
|
||||
m_its.erase(it);
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user