- Update to 0.9.7 aka BETA4

This commit is contained in:
Pav Lucistnik 2007-06-06 23:12:06 +00:00
parent 6f65a6b3e0
commit 321d12c185
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=192956
18 changed files with 1154 additions and 1162 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= daimonin_client
DISTVERSION= BETA3-0967
PORTREVISION= 1
PORTVERSION= 0.9.7
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= daimonin
@ -17,18 +16,18 @@ MAINTAINER= pav@FreeBSD.org
COMMENT= Free open source Massively Multiplayer On-line Role-playing Game (MMORPG)
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}/share/${PORTNAME}
CONFIGURE_ARGS= --prefix=${PREFIX}/share
CONFIGURE_ENV= CFLAGS="-pipe"
USE_SDL= mixer image
USE_X_PREFIX= yes
USE_XLIB= yes
SUB_FILES= daimonin.sh
SUB_LIST= PORTVERSION=${PORTVERSION}
PLIST_SUB= PORTVERSION=${PORTVERSION}
WRKSRC= ${WRKDIR}/daimonin/client/make/linux
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/make/linux
post-patch:
@${CHMOD} a+x ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|daimonin-beta03-0\.966|daimonin-beta03-0\.967|' \
${WRKSRC}/Makefile.in
@${CHMOD} a+x ${WRKSRC}/configure ${WRKSRC}/make_utils/install-sh
@${CP} ${PORTSDIR}/Templates/config.guess ${PORTSDIR}/Templates/config.sub \
${WRKSRC}/make_utils/

View File

@ -1,3 +1,3 @@
MD5 (daimonin_client-BETA3-0967.tgz) = 6f632b4d15434de01c953fde22f7256f
SHA256 (daimonin_client-BETA3-0967.tgz) = ae5168f617fc1c23fc2b06044c154e5282f972606d3d9724801ee621391c95d7
SIZE (daimonin_client-BETA3-0967.tgz) = 15277607
MD5 (daimonin_client-0.9.7.tgz) = 0479673dc12eed0764d95b82a68807a4
SHA256 (daimonin_client-0.9.7.tgz) = 54d3f4439c16ea02be8d778bd586101ccab98e0b8e66b5740a14378f24f06b2d
SIZE (daimonin_client-0.9.7.tgz) = 24794225

View File

@ -1,3 +1,4 @@
#!/bin/sh
cp -R %%PREFIX%%/share/daimonin_client ~/.daimonin
chmod -R +w ~/.daimonin
cp -R %%PREFIX%%/share/daimonin-%%PORTVERSION%%/ ~/.daimonin
cd ~/.daimonin && ./daimonin $*

View File

@ -0,0 +1,17 @@
--- Makefile.in.orig Sun May 20 02:10:22 2007
+++ Makefile.in Mon Jun 4 12:13:40 2007
@@ -787,14 +787,12 @@
$(MKDIR) -p $(d_datadir)/gfx_user
$(MKDIR) -p $(d_datadir)/srv_files
$(MKDIR) -p $(d_datadir)/icons
- $(MKDIR) -p $(d_datadir)/tools
$(MKDIR) -p $(d_datadir)/update
$(CP) ../../sfx/*.* $(d_datadir)/sfx
$(CP) ../../media/*.* $(d_datadir)/media
$(CP) ../../cache/*.* $(d_datadir)/cache
$(CP) ../../icons/*.* $(d_datadir)/icons
$(CP) ../../srv_files/*.* $(d_datadir)/srv_files
- $(CP) -R ../../tools/*.* $(d_datadir)/tools
$(CP) ../../update/version $(d_datadir)/update
$(CP) ../../gfx_user/*.* $(d_datadir)/gfx_user
$(CP) ../../bitmaps/*.* $(d_datadir)/bitmaps

View File

@ -1,10 +0,0 @@
--- ../../src/Makefile.in.orig Fri Aug 4 22:06:02 2006
+++ ../../src/Makefile.in Mon Sep 4 09:51:49 2006
@@ -96,6 +96,6 @@
$(RM) -f Makefile ./include/define.h
.c.o:
- $(CC) $(CFLAGS) $(INCLUDES) -c $*.c
+ $(CC) $(INCLUDES) $(CFLAGS) -c $*.c
all: daimonin

View File

@ -0,0 +1,11 @@
--- ../../src/socket.c.orig Sun May 20 02:10:22 2007
+++ ../../src/socket.c Thu Jun 7 01:09:08 2007
@@ -706,6 +706,8 @@
start_timer = SDL_GetTicks();
while (connect(*socket_temp, (struct sockaddr *) &insock, sizeof(insock)) == -1)
{
+ // EINPROGRESS leads to EALREADY over few iterations
+ if (errno == EALREADY) break;
SDL_Delay(3);
/* timeout.... without connect will REALLY hang a long time */
if (start_timer + SOCKET_TIMEOUT_MS < SDL_GetTicks())

View File

@ -1,11 +1,11 @@
--- ../../src/uncompr.c.orig Sun Nov 30 22:59:30 2003
+++ ../../src/uncompr.c Wed Feb 16 22:11:32 2005
@@ -39,7 +39,7 @@
--- ../../src/uncompr.c.orig Sun May 20 02:10:22 2007
+++ ../../src/uncompr.c Mon Jun 4 11:40:00 2007
@@ -60,7 +60,7 @@
stream.next_out = dest;
stream.avail_out = (uInt)*destLen;
- if ((uLong)stream.avail_out != *destLen) return Z_BUF_ERROR;
+ if ((uLong)stream.avail_out != (uInt)*destLen) return Z_BUF_ERROR;
stream.avail_out = (uInt) * destLen;
- if ((uLong) stream.avail_out != *destLen)
+ if ((uLong) stream.avail_out != (uInt) *destLen)
return Z_BUF_ERROR;
stream.zalloc = (alloc_func)0;
stream.zfree = (free_func)0;
stream.zalloc = (alloc_func) 0;

View File

@ -1,20 +0,0 @@
--- ../../src/wrapper.c.orig Thu Dec 18 22:43:08 2003
+++ ../../src/wrapper.c Wed Feb 16 10:09:17 2005
@@ -44,13 +44,15 @@
}
if(!logstream) /* secure: we have no open stream*/
flag = FALSE;
- va_start(ap, format);
if(flag)
{
+ va_start(ap, format);
vfprintf(stdout, format, ap);
+ va_end(ap);
+ va_start(ap, format);
vfprintf(logstream, format, ap);
+ va_end(ap);
}
- va_end(ap);
fflush(logstream);
#endif

File diff suppressed because it is too large Load Diff

View File

@ -6,8 +6,7 @@
#
PORTNAME= daimonin_client
DISTVERSION= BETA3-0967
PORTREVISION= 1
PORTVERSION= 0.9.7
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= daimonin
@ -17,18 +16,18 @@ MAINTAINER= pav@FreeBSD.org
COMMENT= Free open source Massively Multiplayer On-line Role-playing Game (MMORPG)
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}/share/${PORTNAME}
CONFIGURE_ARGS= --prefix=${PREFIX}/share
CONFIGURE_ENV= CFLAGS="-pipe"
USE_SDL= mixer image
USE_X_PREFIX= yes
USE_XLIB= yes
SUB_FILES= daimonin.sh
SUB_LIST= PORTVERSION=${PORTVERSION}
PLIST_SUB= PORTVERSION=${PORTVERSION}
WRKSRC= ${WRKDIR}/daimonin/client/make/linux
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/make/linux
post-patch:
@${CHMOD} a+x ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|daimonin-beta03-0\.966|daimonin-beta03-0\.967|' \
${WRKSRC}/Makefile.in
@${CHMOD} a+x ${WRKSRC}/configure ${WRKSRC}/make_utils/install-sh
@${CP} ${PORTSDIR}/Templates/config.guess ${PORTSDIR}/Templates/config.sub \
${WRKSRC}/make_utils/

View File

@ -1,3 +1,3 @@
MD5 (daimonin_client-BETA3-0967.tgz) = 6f632b4d15434de01c953fde22f7256f
SHA256 (daimonin_client-BETA3-0967.tgz) = ae5168f617fc1c23fc2b06044c154e5282f972606d3d9724801ee621391c95d7
SIZE (daimonin_client-BETA3-0967.tgz) = 15277607
MD5 (daimonin_client-0.9.7.tgz) = 0479673dc12eed0764d95b82a68807a4
SHA256 (daimonin_client-0.9.7.tgz) = 54d3f4439c16ea02be8d778bd586101ccab98e0b8e66b5740a14378f24f06b2d
SIZE (daimonin_client-0.9.7.tgz) = 24794225

View File

@ -1,3 +1,4 @@
#!/bin/sh
cp -R %%PREFIX%%/share/daimonin_client ~/.daimonin
chmod -R +w ~/.daimonin
cp -R %%PREFIX%%/share/daimonin-%%PORTVERSION%%/ ~/.daimonin
cd ~/.daimonin && ./daimonin $*

View File

@ -0,0 +1,17 @@
--- Makefile.in.orig Sun May 20 02:10:22 2007
+++ Makefile.in Mon Jun 4 12:13:40 2007
@@ -787,14 +787,12 @@
$(MKDIR) -p $(d_datadir)/gfx_user
$(MKDIR) -p $(d_datadir)/srv_files
$(MKDIR) -p $(d_datadir)/icons
- $(MKDIR) -p $(d_datadir)/tools
$(MKDIR) -p $(d_datadir)/update
$(CP) ../../sfx/*.* $(d_datadir)/sfx
$(CP) ../../media/*.* $(d_datadir)/media
$(CP) ../../cache/*.* $(d_datadir)/cache
$(CP) ../../icons/*.* $(d_datadir)/icons
$(CP) ../../srv_files/*.* $(d_datadir)/srv_files
- $(CP) -R ../../tools/*.* $(d_datadir)/tools
$(CP) ../../update/version $(d_datadir)/update
$(CP) ../../gfx_user/*.* $(d_datadir)/gfx_user
$(CP) ../../bitmaps/*.* $(d_datadir)/bitmaps

View File

@ -1,10 +0,0 @@
--- ../../src/Makefile.in.orig Fri Aug 4 22:06:02 2006
+++ ../../src/Makefile.in Mon Sep 4 09:51:49 2006
@@ -96,6 +96,6 @@
$(RM) -f Makefile ./include/define.h
.c.o:
- $(CC) $(CFLAGS) $(INCLUDES) -c $*.c
+ $(CC) $(INCLUDES) $(CFLAGS) -c $*.c
all: daimonin

View File

@ -0,0 +1,11 @@
--- ../../src/socket.c.orig Sun May 20 02:10:22 2007
+++ ../../src/socket.c Thu Jun 7 01:09:08 2007
@@ -706,6 +706,8 @@
start_timer = SDL_GetTicks();
while (connect(*socket_temp, (struct sockaddr *) &insock, sizeof(insock)) == -1)
{
+ // EINPROGRESS leads to EALREADY over few iterations
+ if (errno == EALREADY) break;
SDL_Delay(3);
/* timeout.... without connect will REALLY hang a long time */
if (start_timer + SOCKET_TIMEOUT_MS < SDL_GetTicks())

View File

@ -1,11 +1,11 @@
--- ../../src/uncompr.c.orig Sun Nov 30 22:59:30 2003
+++ ../../src/uncompr.c Wed Feb 16 22:11:32 2005
@@ -39,7 +39,7 @@
--- ../../src/uncompr.c.orig Sun May 20 02:10:22 2007
+++ ../../src/uncompr.c Mon Jun 4 11:40:00 2007
@@ -60,7 +60,7 @@
stream.next_out = dest;
stream.avail_out = (uInt)*destLen;
- if ((uLong)stream.avail_out != *destLen) return Z_BUF_ERROR;
+ if ((uLong)stream.avail_out != (uInt)*destLen) return Z_BUF_ERROR;
stream.avail_out = (uInt) * destLen;
- if ((uLong) stream.avail_out != *destLen)
+ if ((uLong) stream.avail_out != (uInt) *destLen)
return Z_BUF_ERROR;
stream.zalloc = (alloc_func)0;
stream.zfree = (free_func)0;
stream.zalloc = (alloc_func) 0;

View File

@ -1,20 +0,0 @@
--- ../../src/wrapper.c.orig Thu Dec 18 22:43:08 2003
+++ ../../src/wrapper.c Wed Feb 16 10:09:17 2005
@@ -44,13 +44,15 @@
}
if(!logstream) /* secure: we have no open stream*/
flag = FALSE;
- va_start(ap, format);
if(flag)
{
+ va_start(ap, format);
vfprintf(stdout, format, ap);
+ va_end(ap);
+ va_start(ap, format);
vfprintf(logstream, format, ap);
+ va_end(ap);
}
- va_end(ap);
fflush(logstream);
#endif

File diff suppressed because it is too large Load Diff