- Unbreak, unmark deprecated

- Pass maintainership to submitter

PR:		ports/68642
Submitted by:	Michael Ranner <mranner@inode.at>
This commit is contained in:
Pav Lucistnik 2004-07-06 13:53:40 +00:00
parent e7f94d7e88
commit 321942c115
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=113060
7 changed files with 142 additions and 52 deletions

View File

@ -7,21 +7,27 @@
PORTNAME= hostsentry
PORTVERSION= 0.02
PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ftp://ftp.netsys.com/len/
MASTER_SITES= ftp://ftp.netsys.com/len/ \
${MASTER_SITE_PACKETSTORM}
MASTER_SITE_SUBDIR= UNIX/IDS
MAINTAINER= ports@FreeBSD.org
MAINTAINER= mranner@inode.at
COMMENT= A Login Anomaly Detector
RUN_DEPENDS= ${LOCALBASE}/bin/python:${PORTSDIR}/lang/python
RUN_DEPENDS= ${PYTHONPREFIX_SITELIBDIR}/gdbm.so:${PORTSDIR}/databases/py-gdbm
IGNORE= is missing runtime dependencies; see ports/62516
EXPIRATION_DATE=2004-08-20
DEPRECATED= ${IGNORE}
USE_PYTHON= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
post-patch:
@${SED} 's|%%PREFIX%%|${PREFIX}|' ${.CURDIR}/pkg-message > ${PKGMESSAGE}
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/hostsentry
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.BUGS \
${WRKSRC}/README.credits \
${WRKSRC}/README.install \
@ -31,12 +37,8 @@ post-install:
${WRKSRC}/README.technical \
${WRKSRC}/README.why_python \
${WRKSRC}/README.wtmp \
${PREFIX}/share/doc/hostsentry
${DOCSDIR}
.endif
${INSTALL_DATA} ${WRKSRC}/hostsentry.conf \
${PREFIX}/etc/hostsentry.conf
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -0,0 +1,27 @@
--- Makefile.orig Thu Mar 25 23:06:01 1999
+++ Makefile Sat Jul 3 22:03:13 2004
@@ -4,7 +4,8 @@
#
# $Id: Makefile,v 1.4 1999/03/22 05:32:24 crowland Exp crowland $
-INSTALLDIR = /usr/local/abacus/hostsentry
+INSTALLDIR = /usr/local/lib/hostsentry
+CONFIGDIR = /usr/local/etc/hostsentry
all:
@@ -20,8 +21,13 @@
@echo "Installing HostSentry in: $(INSTALLDIR)"
install -d -g 0 -o root -m 0700 $(INSTALLDIR)
install -d -g 0 -o root -m 0700 $(INSTALLDIR)/modules
- install -g 0 -o root -m 0700 host* $(INSTALLDIR)
+ install -g 0 -o root -m 0700 host*.py $(INSTALLDIR)
install -g 0 -o root -m 0700 module* $(INSTALLDIR)/modules
+ install -d -g 0 -o root -m 0700 $(CONFIGDIR)
+ install -g 0 -o root -m 0600 hostsentry.action $(CONFIGDIR)/hostsentry.action-dist
+ install -g 0 -o root -m 0600 hostsentry.conf $(CONFIGDIR)/hostsentry.conf-dist
+ install -g 0 -o root -m 0600 hostsentry.ignore $(CONFIGDIR)/hostsentry.ignore-dist
+ install -g 0 -o root -m 0600 hostsentry.modules $(CONFIGDIR)/hostsentry.modules-dist
@echo ""
@echo ""

View File

@ -5,7 +5,7 @@
# This is the default config file. I'll make this more
# accessible in the future.
-CONFIG='/usr/local/abacus/hostsentry/hostsentry.conf'
+CONFIG='/usr/local/etc/hostsentry.conf'
+CONFIG='/usr/local/etc/hostsentry/hostsentry.conf'
class hostSentryConfig(hostSentryCore):

View File

@ -0,0 +1,24 @@
--- hostSentryLog.py.orig Sat Jul 3 21:56:35 2004
+++ hostSentryLog.py Sat Jul 3 21:56:40 2004
@@ -26,7 +26,7 @@
#
# $Id: hostSentryLog.py,v 1.1 1999/03/22 04:56:44 crowland Exp crowland $
-from hostSentryCore import *
+#from hostSentryCore import *
import sys
import syslog
import hostSentryConfig
@@ -44,10 +44,9 @@
if priority == '':
priority = syslog.LOG_INFO
- syslog.openlog('hostSentry', syslog.LOG_PID, priority)
- syslog.syslog(message)
+ syslog.openlog('hostSentry', syslog.LOG_PID, syslog.LOG_LOCAL1)
+ syslog.syslog(priority, message)
syslog.closelog()
-
if __name__ == '__main__':
log('Test log message')

View File

@ -0,0 +1,35 @@
--- hostsentry.conf.orig Sat Jul 3 20:59:32 2004
+++ hostsentry.conf Sat Jul 3 21:00:39 2004
@@ -27,13 +27,13 @@
# $Id: hostsentry.conf,v 1.3 1999/03/25 22:05:44 crowland Exp crowland $
-IGNORE_FILE = "/usr/local/abacus/hostsentry/hostsentry.ignore"
-ACTION_FILE = "/usr/local/abacus/hostsentry/hostsentry.action"
-MODULE_FILE = "/usr/local/abacus/hostsentry/hostsentry.modules"
-MODULE_PATH = "/usr/local/abacus/hostsentry/modules"
+IGNORE_FILE = "/usr/local/etc/hostsentry/hostsentry.ignore"
+ACTION_FILE = "/usr/local/etc/hostsentry/hostsentry.action"
+MODULE_FILE = "/usr/local/etc/hostsentry/hostsentry.modules"
+MODULE_PATH = "/usr/local/lib/hostsentry/modules"
WTMP_FILE = "/var/log/wtmp"
-DB_FILE = "/usr/local/abacus/hostsentry/hostsentry.db"
-DB_TTY_FILE = "/usr/local/abacus/hostsentry/hostsentry.tty.db"
+DB_FILE = "/usr/local/etc/hostsentry/hostsentry.db"
+DB_TTY_FILE = "/usr/local/etc/hostsentry/hostsentry.tty.db"
# WTMP formats vary between Unices. As a result you need to let HostSentry
@@ -70,10 +70,10 @@
# I wrap native getutent() functions for Python.
#
# RedHat
-WTMP_FORMAT = "384/8:32/44:32/76:256"
+#WTMP_FORMAT = "384/8:32/44:32/76:256"
# Slackware
#WTMP_FORMAT = "56/8:12/28:8/36:16"
# BSD variants
-#WTMP_FORMAT = "36/0:8/8:8/16:16"
+WTMP_FORMAT = "36/0:8/8:8/16:16"

View File

@ -1,5 +1,2 @@
Edit /usr/local/etc/hostssentry.conf and change"
your settings if you haven't already."
Edit %%PREFIX%%/etc/hostssentry/hostssentry.conf and change
your settings if you haven't already.

View File

@ -1,34 +1,39 @@
abacus/hostsentry/hostSentryConfig.py
abacus/hostsentry/hostSentryCore.py
abacus/hostsentry/hostSentryDB.py
abacus/hostsentry/hostSentryLog.py
abacus/hostsentry/hostSentryStat.py
abacus/hostsentry/hostSentryTTY.py
abacus/hostsentry/hostSentryTTYDB.py
abacus/hostsentry/hostSentryUser.py
abacus/hostsentry/hostSentryUtmp.py
abacus/hostsentry/hostsentry.py
abacus/hostsentry/modules/moduleExample.py
abacus/hostsentry/modules/moduleFirstLogin.py
abacus/hostsentry/modules/moduleForeignDomain.allow
abacus/hostsentry/modules/moduleForeignDomain.py
abacus/hostsentry/modules/moduleHistorySuspicious.py
abacus/hostsentry/modules/moduleHistoryTruncated.py
abacus/hostsentry/modules/moduleLoginLogout.py
abacus/hostsentry/modules/moduleMultipleLogins.allow
abacus/hostsentry/modules/moduleMultipleLogins.py
abacus/hostsentry/modules/moduleOddDirnames.py
abacus/hostsentry/modules/moduleRhostsCheck.py
@dirrm abacus/hostsentry/modules
@unexec rmdir %D/abacus/hostsentry 2>/dev/null || true
@unexec rmdir %D/abacus 2>/dev/null || echo "If you are permanently removing this port, you should do a "rm -rf ${PKG_PREFIX}/abacus" to remove any binary, configuration and log files left." | fmt
%%PORTDOCS%%share/doc/hostsentry/README.BUGS
%%PORTDOCS%%share/doc/hostsentry/README.credits
%%PORTDOCS%%share/doc/hostsentry/README.install
%%PORTDOCS%%share/doc/hostsentry/README.intro
%%PORTDOCS%%share/doc/hostsentry/README.modules
%%PORTDOCS%%share/doc/hostsentry/README.paper
%%PORTDOCS%%share/doc/hostsentry/README.technical
%%PORTDOCS%%share/doc/hostsentry/README.why_python
%%PORTDOCS%%share/doc/hostsentry/README.wtmp
%%PORTDOCS%%@dirrm share/doc/hostsentry
etc/hostsentry/hostsentry.action-dist
etc/hostsentry/hostsentry.conf-dist
etc/hostsentry/hostsentry.ignore-dist
etc/hostsentry/hostsentry.modules-dist
lib/hostsentry/hostSentryConfig.py
lib/hostsentry/hostSentryCore.py
lib/hostsentry/hostSentryDB.py
lib/hostsentry/hostSentryLog.py
lib/hostsentry/hostSentryStat.py
lib/hostsentry/hostSentryTTY.py
lib/hostsentry/hostSentryTTYDB.py
lib/hostsentry/hostSentryUser.py
lib/hostsentry/hostSentryUtmp.py
lib/hostsentry/hostsentry.py
lib/hostsentry/modules/moduleExample.py
lib/hostsentry/modules/moduleFirstLogin.py
lib/hostsentry/modules/moduleForeignDomain.allow
lib/hostsentry/modules/moduleForeignDomain.py
lib/hostsentry/modules/moduleHistorySuspicious.py
lib/hostsentry/modules/moduleHistoryTruncated.py
lib/hostsentry/modules/moduleLoginLogout.py
lib/hostsentry/modules/moduleMultipleLogins.allow
lib/hostsentry/modules/moduleMultipleLogins.py
lib/hostsentry/modules/moduleOddDirnames.py
lib/hostsentry/modules/moduleRhostsCheck.py
@dirrm lib/hostsentry/modules
@unexec rm %D/lib/hostsentry/*.pyc || true
@dirrm lib/hostsentry
@unexec rmdir %D/etc/hostsentry 2>/dev/null || echo "If you are permanently removing this port, you should do a "rm -rf ${PKG_PREFIX}/etc/hostsentry" to remove any binary, configuration and log files left." | fmt
%%PORTDOCS%%%%DOCSDIR%%/README.BUGS
%%PORTDOCS%%%%DOCSDIR%%/README.credits
%%PORTDOCS%%%%DOCSDIR%%/README.install
%%PORTDOCS%%%%DOCSDIR%%/README.intro
%%PORTDOCS%%%%DOCSDIR%%/README.modules
%%PORTDOCS%%%%DOCSDIR%%/README.paper
%%PORTDOCS%%%%DOCSDIR%%/README.technical
%%PORTDOCS%%%%DOCSDIR%%/README.why_python
%%PORTDOCS%%%%DOCSDIR%%/README.wtmp
%%PORTDOCS%%@dirrm %%DOCSDIR%%