port is no longer available.
"At the request of David Braben, one of the copyright holders and co-creator of Elite, I have removed all downloads from this site."
This commit is contained in:
parent
aace8a3a91
commit
3203e31060
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=85315
@ -1,54 +0,0 @@
|
||||
# New ports collection makefile for: Elite - The New Kind
|
||||
# Date created: 23 October 2001
|
||||
# Whom: Johann Visagie <wjv@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= newkind
|
||||
PORTVERSION= 1.0
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://home.clara.net/cjpinder/
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
DISTFILES= ${PORTNAME}${EXTRACT_SUFX} ${PORTNAME}b${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Elite: The New Kind - a remake of the 8-bit classic
|
||||
|
||||
LIB_DEPENDS= alleg.4:${PORTSDIR}/devel/allegro
|
||||
|
||||
NO_CDROM= Reverse-engineered version of copyrighted abandonware
|
||||
NO_PACKAGE= ${NO_CDROM}
|
||||
USE_ZIP= yes
|
||||
EXTRACT_BEFORE_ARGS= -oq
|
||||
NO_WRKSUBDIR= yes
|
||||
USE_GMAKE= yes
|
||||
MAKEFILE= makefile
|
||||
ALL_TARGET=
|
||||
NK_SCRIPT= ${WRKSRC}/newkind
|
||||
|
||||
# Currently, everything required to run newkind (including the binary) is
|
||||
# installed to ${DATADIR}. A shell script wrapper is then installed to
|
||||
# ${PREFIX}/bin. A more elegant installation to the standard directory
|
||||
# hierarchy under ${PREFIX} would require extensive patching of source files,
|
||||
# which will have to be maintained across future versions. If anyone feels
|
||||
# up to it, you're more than welcome... :-)
|
||||
do-install:
|
||||
@ ${MKDIR} ${DATADIR}/data
|
||||
@ ${INSTALL_PROGRAM} ${WRKSRC}/newkind.exe ${DATADIR}
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/elite.dat ${WRKSRC}/*.cfg \
|
||||
${WRKSRC}/*.bmp ${WRKSRC}/*.wav ${DATADIR}
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/data/* ${DATADIR}/data
|
||||
@ ${MKDIR} ${PREFIX}/bin
|
||||
@ ${ECHO_CMD} "#!${SH}" > ${NK_SCRIPT}
|
||||
@ ${ECHO_CMD} "cd ${DATADIR} && exec \"./newkind.exe\" \"\$$@\"" \
|
||||
>> ${NK_SCRIPT}
|
||||
@ ${INSTALL_SCRIPT} ${NK_SCRIPT} ${PREFIX}/bin
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@ ${MKDIR} ${DOCSDIR}
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,2 +0,0 @@
|
||||
MD5 (newkind.zip) = 515d893509f26763fc8f19ae5f6d3d50
|
||||
MD5 (newkindb.zip) = 139ef6b52b549fd5c7e9d97e0db743e1
|
@ -1,34 +0,0 @@
|
||||
--- makefile.orig Fri Jul 6 21:29:04 2001
|
||||
+++ makefile Sat Nov 23 16:06:24 2002
|
||||
@@ -2,26 +2,23 @@
|
||||
# Makefile for Elite - The New Kind.
|
||||
#
|
||||
|
||||
-CC = gcc
|
||||
+CC ?= gcc
|
||||
WRES = windres
|
||||
|
||||
-LIBS = -s -mwindows -lalleg_s -lkernel32 -lgdi32 -lcomdlg32 -luser32 -lole32 -lddraw -ldxguid -lwinmm -ldsound -ldinput
|
||||
-CFLAGS = -mpentium -O2 -funroll-loops -Wall -DALLEGRO_STATICLINK
|
||||
+LIBS = -L$(LOCALBASE)/lib -L$(LOCALBASE)/lib/allegro/4.0 -lalleg `$(LOCALBASE)/bin/allegro-config --libs`
|
||||
+CFLAGS += -funroll-loops -Wall -DALLEGRO_STATICLINK
|
||||
+CFLAGS += -I$(LOCALBASE)/include -I$(LOCALBASE)/include/allegro
|
||||
|
||||
OBJS = alg_gfx.o alg_main.o docked.o elite.o\
|
||||
intro.o planet.o shipdata.o shipface.o sound.o space.o\
|
||||
swat.o threed.o vector.o random.o trade.o options.o \
|
||||
- stars.o missions.o nkres.o pilot.o file.o keyboard.o
|
||||
+ stars.o missions.o pilot.o file.o keyboard.o
|
||||
|
||||
.c.o:
|
||||
$(CC) $(CFLAGS) -c $<
|
||||
|
||||
newkind.exe: $(OBJS)
|
||||
$(CC) -o newkind.exe $(OBJS) $(LIBS)
|
||||
-
|
||||
-nkres.o: nkres.rc
|
||||
- $(WRES) nkres.rc nkres.o
|
||||
-
|
||||
|
||||
alg_gfx.o: alg_gfx.c alg_data.h config.h elite.h planet.h gfx.h
|
||||
|
@ -1,21 +0,0 @@
|
||||
Elite: The New Kind - a remake of 1984's 8-bit classic space combat and
|
||||
trading game "Elite" by Ian Bell and David Braben.
|
||||
|
||||
There remains a large contingent of veteran gamers who maintain that the Bell
|
||||
and Braben classic Elite was the greatest computer game of all time. This
|
||||
remake - Elite: The New Kind - was produced by reverse engineering the
|
||||
original disk-based version of Elite on the BBC Microcomputer. However, it
|
||||
was updated with shaded polygon graphics and most of the enhanced gameplay
|
||||
elements which characterised later versions of Elite.
|
||||
|
||||
Snapshots of the original Elite for various emulators (including some which
|
||||
will run on FreeBSD) may be downloaded from co-author Ian Bell's Elite site:
|
||||
http://www.iancgbell.clara.net/elite/
|
||||
|
||||
Shareware versions of the later Elite sequels (for MS-DOS) may be downloaded
|
||||
from David Braben's Elite Club: http://www.eliteclub.co.uk/download/
|
||||
|
||||
Author: Christian Pinder <christian@newkind.co.uk>
|
||||
WWW: http://www.newkind.co.uk/
|
||||
|
||||
-- Johann Visagie <wjv@FreeBSD.org>
|
@ -1,37 +0,0 @@
|
||||
%%PORTDOCS%%share/doc/newkind/readme.txt
|
||||
bin/newkind
|
||||
share/newkind/beep.wav
|
||||
share/newkind/boop.wav
|
||||
share/newkind/crash.wav
|
||||
share/newkind/data/blake.bmp
|
||||
share/newkind/data/danube.mid
|
||||
share/newkind/data/ecm.bmp
|
||||
share/newkind/data/elitetx3.bmp
|
||||
share/newkind/data/greendot.bmp
|
||||
share/newkind/data/missgrn.bmp
|
||||
share/newkind/data/missred.bmp
|
||||
share/newkind/data/missyell.bmp
|
||||
share/newkind/data/reddot.bmp
|
||||
share/newkind/data/safe.bmp
|
||||
share/newkind/data/theme.mid
|
||||
share/newkind/data/verd2.pcx
|
||||
share/newkind/data/verd4.pcx
|
||||
share/newkind/dock.wav
|
||||
share/newkind/ecm.wav
|
||||
share/newkind/elite.dat
|
||||
share/newkind/explode.wav
|
||||
share/newkind/gameover.wav
|
||||
share/newkind/hitem.wav
|
||||
share/newkind/hyper.wav
|
||||
share/newkind/incom1.wav
|
||||
share/newkind/incom2.wav
|
||||
share/newkind/launch.wav
|
||||
share/newkind/missile.wav
|
||||
share/newkind/newkind.cfg
|
||||
share/newkind/newkind.exe
|
||||
share/newkind/newscan.cfg
|
||||
share/newkind/pulse.wav
|
||||
share/newkind/scanner.bmp
|
||||
@dirrm share/newkind/data
|
||||
@dirrm share/newkind
|
||||
%%PORTDOCS%%@dirrm share/doc/newkind
|
Loading…
Reference in New Issue
Block a user