sysutils/ior: New port: IOR and mdtest, parallel IO storage benchmark

This commit is contained in:
Yuri Victorovich 2023-01-20 01:00:59 -08:00
parent a9b17b4b9d
commit 31f202308a
6 changed files with 63 additions and 0 deletions

View File

@ -569,6 +569,7 @@
SUBDIR += iograph
SUBDIR += iohyve
SUBDIR += ioping
SUBDIR += ior
SUBDIR += ipa
SUBDIR += ipad_charge
SUBDIR += ipdbtools

31
sysutils/ior/Makefile Normal file
View File

@ -0,0 +1,31 @@
PORTNAME= ior
DISTVERSION= 3.3.0-20230112
CATEGORIES= sysutils
MAINTAINER= yuri@FreeBSD.org
COMMENT= IOR and mdtest, parallel IO storage benchmark
WWW= https://github.com/hpc/ior
LICENSE= GPLv2
USES= autoreconf gmake localbase:ldflags mpi:mpich pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= hpc
GH_TAGNAME= 24d5d41
GNU_CONFIGURE= yes
TEST_TARGET= check
PLIST_FILES= bin/ior \
bin/md-workbench \
bin/mdtest \
man/man1/mdtest.1.gz
post-install: # see https://github.com/hpc/ior/issues/454
@${RM} \
${STAGEDIR}${PREFIX}/lib/libaiori.a \
${STAGEDIR}${PREFIX}/share/USER_GUIDE
.include <bsd.port.mk>

3
sysutils/ior/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1674200636
SHA256 (hpc-ior-3.3.0-20230112-24d5d41_GH0.tar.gz) = 6bf404b27269e607c5f1d562a430cbdefd05da3f7cfe2ba4b3f53e6f0ae77654
SIZE (hpc-ior-3.3.0-20230112-24d5d41_GH0.tar.gz) = 561821

View File

@ -0,0 +1,11 @@
--- configure.ac.orig 2023-01-20 07:54:41 UTC
+++ configure.ac
@@ -145,7 +145,7 @@ AM_COND_IF([HAVE_GPU_DIRECT],[
# Check for system capabilities
AC_SYS_LARGEFILE
-AC_DEFINE([_XOPEN_SOURCE], [700], [C99 compatibility])
+#AC_DEFINE([_XOPEN_SOURCE], [700], [C99 compatibility])
# Check for lustre availability
AC_ARG_WITH([lustre],

View File

@ -0,0 +1,11 @@
--- src/utilities.c.orig 2023-01-20 07:46:47 UTC
+++ src/utilities.c
@@ -45,7 +45,7 @@
# include <regex.h>
# ifdef __sun /* SunOS does not support statfs(), instead uses statvfs() */
# include <sys/statvfs.h>
-# elif (defined __APPLE__)
+# elif (defined __APPLE__) || (defined __FreeBSD__)
# include <sys/param.h>
# include <sys/mount.h>
# else /* ! __sun or __APPLE__ */

6
sysutils/ior/pkg-descr Normal file
View File

@ -0,0 +1,6 @@
IOR is a parallel IO benchmark that can be used to test the performance of
parallel storage systems using various interfaces and access patterns. The IOR
repository also includes the mdtest benchmark which specifically tests the peak
metadata rates of storage systems under different directory structures. Both
benchmarks use a common parallel I/O abstraction backend and rely on MPI for
synchronization.