Add patch to work around bug in FreeBSD before r226610 (MFCed to stable/9

as r230953): Add #include <sys/types.h> before <netinet/tcp.h>.  This was
breaking the build on FreeBSD 8.4.

While I'm here, quiesce portlint by switching from EXTRACT_SUFX=.tgz to
the new spelling USES=tar:tgz.
This commit is contained in:
Colin Percival 2015-02-28 21:35:13 +00:00
parent c25d5f97ad
commit 31ef54eb30
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=380162
2 changed files with 13 additions and 2 deletions

View File

@ -4,7 +4,6 @@ PORTNAME= spiped
PORTVERSION= 1.5.0
CATEGORIES= sysutils security
MASTER_SITES= http://www.tarsnap.com/spiped/
EXTRACT_SUFX= .tgz
MAINTAINER= cperciva@tarsnap.com
COMMENT= Daemon for creating secure symmetric pipes
@ -14,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
# The spiped build only needs C99, but this will help to get us a compiler
# which has support for AESNI on x86 systems
USES= compiler:c11
USES= compiler:c11 tar:tgz
# Install into ${STAGEDIR}${PREFIX}
MAKE_ARGS+= BINDIR=${STAGEDIR}${PREFIX}/bin
@ -33,6 +32,11 @@ USE_RC_SUBR= spiped
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
.if ${OSVERSION} < 900503
EXTRA_PATCHES= ${FILESDIR}/extra-patch-proto_proto__conn.c
.endif
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}

View File

@ -0,0 +1,7 @@
--- proto/proto_conn.c.orig 2015-02-28 21:19:18 UTC
+++ proto/proto_conn.c
@@ -1,3 +1,4 @@
+#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>