Graphite is a project under development within SIL'ss Non-Roman Script

Initiative and Language Software Development groups to provide
rendering capabilities for complex non-Roman writing systems.  The
original goal was a system for the Windows platform; the system has
also been ported to Linux.  Graphite can be used to create "smart
fonts" capable of displaying writing systems with various complex
behaviors.  With respect to the Text Encoding Model, Graphite handles
the "Rendering" aspect of writing system implementation.

WWW: http://silgraphite.sourceforge.net/

PR:		ports/129346
Submitted by:	Dennis Herrmann <adox at mcx2.org>
This commit is contained in:
Martin Wilke 2008-12-07 11:02:18 +00:00
parent f6f0b1b78a
commit 31d3413e67
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=223927
6 changed files with 97 additions and 0 deletions

View File

@ -755,6 +755,7 @@
SUBDIR += shim
SUBDIR += show
SUBDIR += showimg
SUBDIR += silgraphite
SUBDIR += simage
SUBDIR += skanlite
SUBDIR += skencil

View File

@ -0,0 +1,37 @@
# New ports collection makefile for: silgraphite
# Date created: 30 November 2008
# Whom: Dennis Herrmann <adox@mcx2.org>
#
# $FreeBSD$
#
PORTNAME= silgraphite
PORTVERSION= 2.3
CATEGORIES= graphics devel
MASTER_SITES= SF
MAINTAINER= adox@mcx2.org
COMMENT= Font engine for complex non-Roman writing systems
OPTIONS= FREETYPE "Build with Freetype support" on
USE_GNOME= pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --without-xft --without-pangographite
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_FREETYPE)
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
USE_ICONV= yes
CONFIGURE_ARGS+= --with-freetype
PLIST_SUB+= WITH_FREETYPE=""
.else
CONFIGURE_ARGS+= --without-freetype
PLIST_SUB+= WITH_FREETYPE="@comment "
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,3 @@
MD5 (silgraphite-2.3.tar.gz) = 76a6daa2ec802bdd5e5f9a233b4e2ff8
SHA256 (silgraphite-2.3.tar.gz) = 574dbccd0480e7c571612251afafd8de2019997ee1450ee3e68039f64797f1ec
SIZE (silgraphite-2.3.tar.gz) = 3394463

View File

@ -0,0 +1,11 @@
--- engine/Makefile.in.orig 2008-11-30 19:57:26.000000000 +0100
+++ engine/Makefile.in 2008-11-30 19:58:25.000000000 +0100
@@ -196,7 +196,7 @@
build.bat build_d.bat makefile.vc \
README
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = ${PREFIX}/libdata/pkgconfig
pkgconfig_DATA = silgraphite.pc
# VC_VERSION is the last released version of the software

View File

@ -0,0 +1,10 @@
Graphite is a project under development within SIL'ss Non-Roman Script
Initiative and Language Software Development groups to provide
rendering capabilities for complex non-Roman writing systems. The
original goal was a system for the Windows platform; the system has
also been ported to Linux. Graphite can be used to create "smart
fonts" capable of displaying writing systems with various complex
behaviors. With respect to the Text Encoding Model, Graphite handles
the "Rendering" aspect of writing system implementation.
WWW: http://silgraphite.sourceforge.net/

View File

@ -0,0 +1,35 @@
%%WITH_FREETYPE%%include/graphite/FreetypeFont.h
%%WITH_FREETYPE%%lib/libgraphite-ft.a
%%WITH_FREETYPE%%lib/libgraphite-ft.la
%%WITH_FREETYPE%%lib/libgraphite-ft.so
%%WITH_FREETYPE%%lib/libgraphite-ft.so.0
include/graphite/FileFont.h
include/graphite/Font.h
include/graphite/GrAppData.h
include/graphite/GrClient.h
include/graphite/GrCommon.h
include/graphite/GrConstants.h
include/graphite/GrData.h
include/graphite/GrDebug.h
include/graphite/GrExt.h
include/graphite/GrFeature.h
include/graphite/GrMstypes.h
include/graphite/GrPlatform.h
include/graphite/GrResult.h
include/graphite/GrStructs.h
include/graphite/GrWrappers.h
include/graphite/GraphiteProcess.h
include/graphite/IGrEngine.h
include/graphite/IGrJustifier.h
include/graphite/IGraphiteProcess.h
include/graphite/ITextSource.h
include/graphite/MemoryUsage.h
include/graphite/Segment.h
include/graphite/SegmentAux.h
include/graphite/SegmentPainter.h
lib/libgraphite.a
lib/libgraphite.la
lib/libgraphite.so
lib/libgraphite.so.3
libdata/pkgconfig/silgraphite.pc
@dirrm include/graphite