Update original tcsh version from 6.07.09 to 6.07.12.
PR: ports/8056 Submitted by: Issei Suzuki <issei@jp.FreeBSD.ORG>
This commit is contained in:
parent
8dfb405dd5
commit
313cc21d95
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=13550
@ -1,31 +1,23 @@
|
||||
# New ports collection makefile for: tcsh with kanji patch
|
||||
# Version required: 6.07.09
|
||||
# New ports collection makefile for: tcsh with multibyte support enabled
|
||||
# Version required: 6.07.12
|
||||
# Date created: 29 November 1997
|
||||
# Whom: issei <issei@jp.FreeBSD.ORG>
|
||||
#
|
||||
# $Id: Makefile,v 1.4 1998/07/04 03:20:11 steve Exp $
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= tcsh-6.07.09
|
||||
PKGNAME= ja-tcsh-6.07.09b5
|
||||
DISTNAME= tcsh-6.07.12
|
||||
PKGNAME= ja-tcsh-6.07.12
|
||||
CATEGORIES= japanese shells
|
||||
MASTER_SITES= http://www2.wbs.ne.jp/~znc/tcsh/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
PATCH_SITES= http://www2.wbs.ne.jp/~znc/tcsh/
|
||||
PATCHFILES= ${DISTNAME}.kanji.patch7b5.gz
|
||||
MASTER_SITES= ftp://ftp.astron.com/pri/
|
||||
|
||||
MAINTAINER= issei@jp.FreeBSD.ORG
|
||||
|
||||
PATCH_DIST_STRIP= -p1
|
||||
GNU_CONFIGURE= yes
|
||||
# Ugly hack
|
||||
CONFIGURE_ARGS= --bindir=${PREFIX}/bin
|
||||
ALL_TARGET= all catalogs
|
||||
INSTALL_TARGET= install install.man
|
||||
MAN1= tcsh.1
|
||||
PORTDOCS= complete.tcsh FAQ HISTORY.kanji.patch.euc HowToMakeNLS.euc \
|
||||
README.kanji.patch.euc
|
||||
PORTDOCS= FAQ Fixes README WishList complete.tcsh
|
||||
|
||||
post-install:
|
||||
@(cd ${WRKSRC}; \
|
||||
|
@ -1,2 +1 @@
|
||||
MD5 (tcsh-6.07.09.tgz) = f285baaebbb3c5f9c32425558415a798
|
||||
MD5 (tcsh-6.07.09.kanji.patch7b5.gz) = fe918113362ba0446b12269356a6e2de
|
||||
MD5 (tcsh-6.07.12.tar.gz) = 754718dc9af006d50eda615dac7f5d40
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- ../../tcsh-6.07.09/config_f.h Wed Jul 22 01:03:32 1998
|
||||
+++ config_f.h Wed Jul 22 01:04:17 1998
|
||||
--- config_f.h.orig Sat Sep 19 23:48:08 1998
|
||||
+++ config_f.h Sat Sep 26 23:08:09 1998
|
||||
@@ -65,7 +65,11 @@
|
||||
* if you don't have <nl_types.h>, you don't want
|
||||
* to define this.
|
||||
@ -13,3 +13,36 @@
|
||||
|
||||
/*
|
||||
* LOGINFIRST Source ~/.login before ~/.cshrc
|
||||
@@ -117,20 +121,29 @@
|
||||
* be used with SHORT_STRINGS
|
||||
*
|
||||
*/
|
||||
-#undef KANJI
|
||||
+#define KANJI
|
||||
|
||||
/*
|
||||
* DSPMBYTE add variable "dspmbyte" and display multi-byte string at
|
||||
* only output, when "dspmbyte" is set.
|
||||
*/
|
||||
-#undef DSPMBYTE
|
||||
+#if defined(__FreeBSD__) || defined(__OpenBSD__)
|
||||
+# define DSPMBYTE
|
||||
+#else
|
||||
+# undef DSPMBYTE
|
||||
+#endif
|
||||
+
|
||||
|
||||
/*
|
||||
* MBYTEDEBUG when "dspmbyte" is changed, set multi-byte checktable to
|
||||
* variable "mbytemap".
|
||||
* (use for multi-byte table check)
|
||||
*/
|
||||
-#undef MBYTEDEBUG
|
||||
+#if defined(__FreeBSD__) || defined(__OpenBSD__)
|
||||
+# define MBYTEDEBUG
|
||||
+#else
|
||||
+# undef MBYTEDEBUG
|
||||
+#endif
|
||||
|
||||
/*
|
||||
* NEWGRP Provide a newgrp builtin.
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- ../../tcsh-6.07.09/sh.func.c Wed Jul 22 01:03:33 1998
|
||||
+++ sh.func.c Wed Jul 22 01:04:47 1998
|
||||
--- sh.func.c.orig Sat Sep 19 01:09:11 1998
|
||||
+++ sh.func.c Sat Sep 26 19:23:40 1998
|
||||
@@ -1286,6 +1286,9 @@
|
||||
struct command *c;
|
||||
{
|
||||
@ -10,7 +10,7 @@
|
||||
|
||||
USE(c);
|
||||
if (*++v == 0) {
|
||||
@@ -1338,7 +1341,15 @@
|
||||
@@ -1337,7 +1340,15 @@
|
||||
# ifdef LC_MESSAGES
|
||||
(void) setlocale(LC_MESSAGES, "");
|
||||
# endif /* LC_MESSAGES */
|
||||
|
@ -1,8 +1,8 @@
|
||||
--- nls/Makefile.orig Wed Aug 19 14:21:20 1998
|
||||
+++ nls/Makefile Wed Aug 19 14:23:51 1998
|
||||
--- nls/Makefile.old Sat Sep 26 23:05:31 1998
|
||||
+++ nls/Makefile Sat Sep 26 23:05:42 1998
|
||||
@@ -1,5 +1,5 @@
|
||||
|
||||
-SUBDIRS= C german french greek spanish ja.roomi ja.koshiki ja
|
||||
-SUBDIRS= C german french italian ja greek spanish
|
||||
+SUBDIRS= C
|
||||
#GENCAT= gencat -new
|
||||
GENCAT= gencat
|
||||
|
@ -1 +1 @@
|
||||
An extended C-shell with many useful features with Japanese and color support.
|
||||
An extended C-shell with many useful features with multibyte support.
|
||||
|
@ -2,8 +2,8 @@ TCSH is an extended C-shell with many useful features like
|
||||
filename completion, history editing, etc.
|
||||
|
||||
This also supports
|
||||
1. Japanese command-line editing
|
||||
2. Japanese NLS catalogs
|
||||
1. Multibyte command-line editing
|
||||
2. Multibyte NLS catalogs
|
||||
3. colorlized ls-F command
|
||||
|
||||
See also ${PREFIX}/share/doc/tcsh.
|
||||
|
@ -1,11 +1,11 @@
|
||||
bin/tcsh
|
||||
@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells
|
||||
@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells
|
||||
share/doc/tcsh/complete.tcsh
|
||||
share/doc/tcsh/FAQ
|
||||
share/doc/tcsh/HISTORY.kanji.patch.euc
|
||||
share/doc/tcsh/HowToMakeNLS.euc
|
||||
share/doc/tcsh/README.kanji.patch.euc
|
||||
share/doc/tcsh/Fixes
|
||||
share/doc/tcsh/README
|
||||
share/doc/tcsh/WishList
|
||||
share/doc/tcsh/complete.tcsh
|
||||
@dirrm share/doc/tcsh
|
||||
share/nls/C/tcsh.cat
|
||||
share/nls/C/tcsh.m
|
||||
|
Loading…
Reference in New Issue
Block a user