Use libio on alpha (-STABLE & -CURRENT).
PR: ports/52633 Submitted by: maintainer
This commit is contained in:
parent
27d05742bb
commit
30f60ee03e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=81874
@ -28,10 +28,16 @@ USE_PERL5= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} > 500000
|
||||
.if ${ARCH} == "i386" && ${OSVERSION} > 500000
|
||||
BROKEN= "ffs() clash, see i386/41930"
|
||||
.endif
|
||||
|
||||
.if ${ARCH} == "alpha"
|
||||
EXTRA_PATCHES= files/extra-patch-mlcd-Makefile.in \
|
||||
files/extra-patch-mlcd-ParPort.cpp \
|
||||
files/extra-patch-mlcd-ParPort.h
|
||||
.endif
|
||||
|
||||
.ifndef(WITHOUT_X11)
|
||||
USE_QT_VER= 3
|
||||
USE_XLIB= yes
|
||||
|
11
graphics/hpoj/files/extra-patch-mlcd-Makefile.in
Normal file
11
graphics/hpoj/files/extra-patch-mlcd-Makefile.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- mlcd/Makefile.in.orig Sat May 24 08:03:14 2003
|
||||
+++ mlcd/Makefile.in Sat May 24 08:03:37 2003
|
||||
@@ -35,7 +35,7 @@
|
||||
for link in $(LINKS) ; do ln -s . $$link ; done
|
||||
|
||||
$(GOAL): $(OBJS)
|
||||
- $(CXX) -o $(GOAL) $(OBJS)
|
||||
+ $(CXX) -o $(GOAL) -lio $(OBJS)
|
||||
|
||||
clean:
|
||||
rm -f $(OBJS) $(GOAL) $(LINKS)
|
12
graphics/hpoj/files/extra-patch-mlcd-ParPort.cpp
Normal file
12
graphics/hpoj/files/extra-patch-mlcd-ParPort.cpp
Normal file
@ -0,0 +1,12 @@
|
||||
--- mlcd/ParPort.cpp.orig Sat May 24 08:03:20 2003
|
||||
+++ mlcd/ParPort.cpp Sat May 24 08:03:48 2003
|
||||
@@ -926,9 +926,6 @@
|
||||
#elif defined(PAR_PLATFORM_FREEBSD)
|
||||
#include <unistd.h>
|
||||
#include <fcntl.h>
|
||||
- extern "C" {
|
||||
- #include <machine/cpufunc.h>
|
||||
- }
|
||||
#else
|
||||
/* TODO: Handle these more gracefully! */
|
||||
#error Undefined platform
|
14
graphics/hpoj/files/extra-patch-mlcd-ParPort.h
Normal file
14
graphics/hpoj/files/extra-patch-mlcd-ParPort.h
Normal file
@ -0,0 +1,14 @@
|
||||
--- mlcd/ParPort.h.orig Sat May 24 08:02:19 2003
|
||||
+++ mlcd/ParPort.h Sat May 24 07:59:13 2003
|
||||
@@ -27,6 +27,11 @@
|
||||
|
||||
#define ERROR_NO_DATA ERROR /* TODO: Remove. */
|
||||
|
||||
+extern "C" {
|
||||
+extern u_char inb (u_int port);
|
||||
+extern void outb(u_int port, u_char data);
|
||||
+}
|
||||
+
|
||||
class ParPort {
|
||||
protected: // ATTRIB
|
||||
int portType;
|
Loading…
Reference in New Issue
Block a user