Fix up previous fix:

- with KF5 5.71, each application can have its own FindTaglib, or
  uses the one from kdelibs4support (I think). This is generally an
  "old-style" CMake module.
- with KF5 5.72, ECM delivers a modern CMake module which is found
  **first**, but is also incompatible with the old version of FindTaglib.

Adjust the patches so they work with KF5 5.71 (now in-tree) and 5.72
(upcoming). Not bumping PORTREVISION here because the packages could
not have built with the previous patches.

Note to self: do not assume useful backwards-compatibility in CMake
modules from different sources.

PR:		247907
This commit is contained in:
Adriaan de Groot 2020-07-18 23:31:17 +00:00
parent 9eb83d06fe
commit 30d7ae8b37
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=542537
3 changed files with 20 additions and 15 deletions

View File

@ -1,11 +1,14 @@
--- CMakeLists.txt.orig 2020-07-18 20:38:56 UTC
+++ CMakeLists.txt
@@ -120,7 +120,7 @@ set(soundkonverter_SRCS
@@ -120,7 +120,10 @@ set(soundkonverter_SRCS
)
add_executable(soundkonverter ${soundkonverter_SRCS})
-target_link_libraries(soundkonverter KF5::WidgetsAddons KF5::KIOFileWidgets KF5::KIOCore KF5::Solid KF5::Cddb Phonon::phonon4qt5 ${TAGLIB_LIBRARIES} ${CDPARANOIA_LIBRARIES} KF5::KDELibs4Support soundkonvertercore)
+target_link_libraries(soundkonverter KF5::WidgetsAddons KF5::KIOFileWidgets KF5::KIOCore KF5::Solid KF5::Cddb Phonon::phonon4qt5 Taglib::Taglib ${CDPARANOIA_LIBRARIES} KF5::KDELibs4Support soundkonvertercore)
+if(NOT TAGLIB_LIBRARIES)
+ set(TAGLIB_LIBRARIES Taglib::Taglib)
+endif()
+target_link_libraries(soundkonverter KF5::WidgetsAddons KF5::KIOFileWidgets KF5::KIOCore KF5::Solid KF5::Cddb Phonon::phonon4qt5 ${TAGLIB_LIBRARIES} ${CDPARANOIA_LIBRARIES} KF5::KDELibs4Support soundkonvertercore)
install(TARGETS soundkonverter DESTINATION ${BIN_INSTALL_DIR})

View File

@ -1,11 +1,11 @@
--- plugins/mediaplayer/CMakeLists.txt.orig 2020-07-18 21:06:12 UTC
--- plugins/mediaplayer/CMakeLists.txt.orig 2020-06-06 18:08:08 UTC
+++ plugins/mediaplayer/CMakeLists.txt
@@ -34,7 +34,7 @@ kcoreaddons_desktop_to_json(ktorrent_mediaplayer ktorr
target_link_libraries(
ktorrent_mediaplayer
ktcore
- ${TAGLIB_LIBRARIES}
+ Taglib::Taglib
Phonon::phonon4qt5
KF5::Torrent
KF5::I18n
@@ -1,5 +1,8 @@
find_package(Taglib REQUIRED)
include_directories(${TAGLIB_INCLUDES})
+if(NOT TAGLIB_LIBRARIES)
+ set(TAGLIB_LIBRARIES Taglib::Taglib)
+endif()
#find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED Multimedia MultimediaWidgets)
#include_directories(${Qt5Multimedia_INCLUDE_DIRS})
include_directories(${PHONON_INCLUDES})

View File

@ -135,12 +135,15 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
--- src/CMakeLists.txt
+++ src/CMakeLists.txt
@@ -23,7 +23,7 @@ if(FREETYPE_FOUND)
@@ -23,7 +23,10 @@ if(FREETYPE_FOUND)
include_directories(${FREETYPE_INCLUDE_DIRS})
endif()
-add_definitions(${TAGLIB_CFLAGS} ${EXIV2_CFLAGS})
+add_definitions(${TAGLIB_CFLAGS})
+if(NOT TAGLIB_LIBRARIES)
+ set(TAGLIB_LIBRARIES Taglib::Taglib)
+endif()
# Exiv2 needs exceptions
kde_enable_exceptions()
@ -157,8 +160,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
)
if(TAGLIB_FOUND)
target_link_libraries(krename
- ${TAGLIB_LIBRARIES}
+ Taglib::Taglib
${TAGLIB_LIBRARIES}
)
endif()
-if(EXIV2_FOUND)