New Port: misc/gkrellshoot2
New port: gkrellshoot2, a screen lock and capture plugin for gkrellm 2 PR: ports/47622 Submitted by: Andrew Stuart <elitetek@tekrealm.net>
This commit is contained in:
parent
709dd56c79
commit
309b4a8bd4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=90732
@ -102,6 +102,7 @@
|
||||
SUBDIR += gkrellmlaunch
|
||||
SUBDIR += gkrellscore
|
||||
SUBDIR += gkrellshoot
|
||||
SUBDIR += gkrellshoot2
|
||||
SUBDIR += gkrellweather
|
||||
SUBDIR += gkrellweather2
|
||||
SUBDIR += gkx86info
|
||||
|
30
misc/gkrellshoot2/Makefile
Normal file
30
misc/gkrellshoot2/Makefile
Normal file
@ -0,0 +1,30 @@
|
||||
# New ports collection makefile for: gkrellshoot2
|
||||
# Date Created: 28 Jan 2003
|
||||
# Whom: Andrew Stuart <elitetek@tekrealm.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gkrellshoot
|
||||
PORTVERSION= 0.4.1
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
PKGNAMESUFFIX= 2
|
||||
|
||||
MAINTAINER= elitetek@tekrealm.net
|
||||
COMMENT= A screen locking and screen capture plugin for GKrellM 2
|
||||
|
||||
BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
|
||||
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2 \
|
||||
import:${PORTSDIR}/graphics/ImageMagick
|
||||
|
||||
WRKSRC= ${WRKDIR}/gkrellShoot-${PORTVERSION}
|
||||
USE_X_PREFIX= yes
|
||||
|
||||
ALL_TARGET= ${PORTNAME}.so
|
||||
|
||||
do-install:
|
||||
@${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.so ${PREFIX}/libexec/gkrellm2/plugins
|
||||
|
||||
.include <bsd.port.mk>
|
1
misc/gkrellshoot2/distinfo
Normal file
1
misc/gkrellshoot2/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (gkrellshoot-0.4.1.tar.gz) =3D db0835ef0ec77ab06547fff25ec134f7
|
17
misc/gkrellshoot2/files/patch-Makefile
Normal file
17
misc/gkrellshoot2/files/patch-Makefile
Normal file
@ -0,0 +1,17 @@
|
||||
--- Makefile.orig Thu Jan 30 21:20:26 2003
|
||||
+++ Makefile Thu Jan 30 21:23:35 2003
|
||||
@@ -1,11 +1,12 @@
|
||||
GTK_INCLUDE = `pkg-config gtk+-2.0 --cflags`
|
||||
GTK_LIB = `pkg-config gtk+-2.0 --libs`
|
||||
|
||||
-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE)
|
||||
+CFLAGS = -fPIC $(GTK_INCLUDE)
|
||||
LIBS = $(GTK_LIB)
|
||||
LFLAGS = -shared
|
||||
|
||||
-CC = gcc $(CFLAGS) $(FLAGS)
|
||||
+CC?= gcc
|
||||
+CC+= ${CFLAGS}
|
||||
|
||||
OBJS = gkrellshoot.o
|
||||
|
5
misc/gkrellshoot2/pkg-descr
Normal file
5
misc/gkrellshoot2/pkg-descr
Normal file
@ -0,0 +1,5 @@
|
||||
This plugin puts a lock and shoot button on your GKrellM 2, It uses
|
||||
ImageMagick for screen capture and can be configured for your screen
|
||||
saver program. Known to work with either Xlock or xscreensaver.
|
||||
|
||||
WWW: http://gkrellshoot.sourceforge.net/
|
1
misc/gkrellshoot2/pkg-plist
Normal file
1
misc/gkrellshoot2/pkg-plist
Normal file
@ -0,0 +1 @@
|
||||
libexec/gkrellm2/plugins/gkrellshoot.so
|
Loading…
Reference in New Issue
Block a user